aboutsummaryrefslogtreecommitdiff
path: root/converters/libb64/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-03 10:43:55 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-03 10:43:55 +0000
commitb461a0649fa1f620704362e03f0dc2e82c44824e (patch)
tree8eeaf1f73b5d8e67a757eed72fb68ac3634a63c0 /converters/libb64/Makefile
parentcbd5dd289279696a9b48c095df8c9dfe8b828bf9 (diff)
downloadports-b461a0649fa1f620704362e03f0dc2e82c44824e.tar.gz
ports-b461a0649fa1f620704362e03f0dc2e82c44824e.zip
- Improve COMMENT: make it concise and mention that it's about Base64
- Unbreak the build on PowerPC by adding -fsigned-char to CFLAGS (and also respect them by removing hardcoded -O3) - Rename a patch and regenerate it with `make makepatch' command - Clean up do-install target (sanitize symlink, wrap overly long line) - Reformat and kill EOL whitespace in the port description text
Notes
Notes: svn path=/head/; revision=395945
Diffstat (limited to 'converters/libb64/Makefile')
-rw-r--r--converters/libb64/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/converters/libb64/Makefile b/converters/libb64/Makefile
index 7281c9205398..41bc5179f01a 100644
--- a/converters/libb64/Makefile
+++ b/converters/libb64/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= converters mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}
MAINTAINER= ismail.yenigul@surgate.com
-COMMENT= Library of ANSI C routines for fast encoding/decoding data
+COMMENT= Library for fast Base64 encoding and decoding
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
@@ -15,13 +15,12 @@ USES= gmake zip
ALL_TARGET= all_src
USE_LDCONFIG= yes
-BROKEN_powerpc= Does not compile on powerpc
-
do-install:
${INSTALL_DATA} ${WRKSRC}/src/libb64.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/src/libb64.so.0 ${STAGEDIR}${PREFIX}/lib
- (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -fs libb64.so.0 libb64.so)
+ ${LN} -fs libb64.so.0 ${STAGEDIR}${PREFIX}/lib/libb64.so
@${MKDIR} ${STAGEDIR}${PREFIX}/include/b64
- ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h ${STAGEDIR}${PREFIX}/include/b64
+ ${INSTALL_DATA} ${WRKSRC}/include/b64/*.h \
+ ${STAGEDIR}${PREFIX}/include/b64
.include <bsd.port.mk>