aboutsummaryrefslogtreecommitdiff
path: root/converters/p5-MIME-Base64/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 20:57:24 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 20:57:24 +0000
commit9884a9972ea597a2070dfa2723385b800dff344f (patch)
treeb90c2531441b4304a0ac82f5f9b5ddbc13314a27 /converters/p5-MIME-Base64/Makefile
parent68b9360ed0b6b526220c2996a4d61b0501a02c2f (diff)
downloadports-9884a9972ea597a2070dfa2723385b800dff344f.tar.gz
ports-9884a9972ea597a2070dfa2723385b800dff344f.zip
Make this port respect CC/CFLAGS.
PR: 19123 Reported by: Christian Weisgerber <naddy@unix-ag.uni-kl.de>
Notes
Notes: svn path=/head/; revision=29469
Diffstat (limited to 'converters/p5-MIME-Base64/Makefile')
-rw-r--r--converters/p5-MIME-Base64/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/converters/p5-MIME-Base64/Makefile b/converters/p5-MIME-Base64/Makefile
index 72f69c0bec1f..2bbb5e4eddf5 100644
--- a/converters/p5-MIME-Base64/Makefile
+++ b/converters/p5-MIME-Base64/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= p5-MIME-Base64
+PORTNAME= MIME-Base64
PORTVERSION= 2.11
CATEGORIES= converters perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= MIME
-DISTNAME= MIME-Base64-${PORTVERSION}
+PKGNAMESUFFIX= p5-
MAINTAINER= ports@FreeBSD.org
@@ -20,7 +20,11 @@ MAN3= MIME::Base64.3 \
MIME::QuotedPrint.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+pre-build:
+ @${PERL} -pi -e "s:-O -pipe:${CFLAGS}:g" ${WRKSRC}/Makefile.PL
+ @${PERL} -pi -e "s:cc:${CC}:g" ${WRKSRC}/Makefile.PL
+
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>