aboutsummaryrefslogtreecommitdiff
path: root/converters/py-iconv
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /converters/py-iconv
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
downloadports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.tar.gz
ports-642be1b81d8342d3a3323f43bcf5a0bd87a5d363.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'converters/py-iconv')
-rw-r--r--converters/py-iconv/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/converters/py-iconv/Makefile b/converters/py-iconv/Makefile
index 5193fe4fdfa5..bfa5c990fffb 100644
--- a/converters/py-iconv/Makefile
+++ b/converters/py-iconv/Makefile
@@ -21,11 +21,18 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S|^${LOCALBASE}/||g}
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+SETUPINFO= ,library_dirs=["${LOCALBASE}/lib"],\
+ include_dirs=["${LOCALBASE}/include"]
+.else
SETUPINFO= ,libraries=["iconv"],library_dirs=["${LOCALBASE}/lib"],\
include_dirs=["${LOCALBASE}/include"]
+.endif
post-patch:
cd ${WRKSRC} && ${SED} 's!^\(.*ext_mod.*\)\()]\)$$!\1${SETUPINFO}\2!g'\
setup.py > setup.py.tmp && ${CAT} setup.py.tmp > setup.py
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>