aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2021-10-21 18:17:31 +0000
committerEd Maste <emaste@FreeBSD.org>2023-04-12 17:56:22 +0000
commita0cdafda51c9a9f0b843a55bc6be43185fd53731 (patch)
tree411c31759ed9146d46b87057d772fba912fc9ba7 /converters
parent662e28cb80602d444eb9ca10aff890256a0be8d1 (diff)
downloadports-a0cdafda51c9a9f0b843a55bc6be43185fd53731.tar.gz
ports-a0cdafda51c9a9f0b843a55bc6be43185fd53731.zip
converters/iconv: drop use of lorder(1)
lorder is obsolete and may be removed from the base system in the future. PR: 259254 [exp-run] Reviewed by: jrm Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D32593
Diffstat (limited to 'converters')
-rw-r--r--converters/iconv/Makefile2
-rw-r--r--converters/iconv/files/patch-ces__Makefile7
2 files changed, 6 insertions, 3 deletions
diff --git a/converters/iconv/Makefile b/converters/iconv/Makefile
index 5b283fe586f3..90e228ed3f44 100644
--- a/converters/iconv/Makefile
+++ b/converters/iconv/Makefile
@@ -1,6 +1,6 @@
PORTNAME= iconv
PORTVERSION= 2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= converters
MASTER_SITES= LOCAL/bland
diff --git a/converters/iconv/files/patch-ces__Makefile b/converters/iconv/files/patch-ces__Makefile
index 5c39a6915660..7f5c8a2961cd 100644
--- a/converters/iconv/files/patch-ces__Makefile
+++ b/converters/iconv/files/patch-ces__Makefile
@@ -9,7 +9,7 @@
INTERNALLIB =
-@@ -27,9 +27,9 @@ ces_builtin.c: ${CHARSETS_C} ${CHARSETS_
+@@ -27,11 +27,11 @@ ces_builtin.c: ${CHARSETS_C} ${CHARSETS_O}
${.CURDIR}/../iconv_builtin -mo ${.TARGET} \
${CHARSETS_C} PIC ${CHARSETS_O}
@@ -19,8 +19,11 @@
-.So.so:
+.So.so .pico.so:
@${LDDESTDIRENV} ${CC} -shared -Wl,-x -o ${.TARGET} \
- -Wl,-soname,${.TARGET} `lorder ${.ALLSRC} | tsort -q` \
+- -Wl,-soname,${.TARGET} `lorder ${.ALLSRC} | tsort -q` \
++ -Wl,-soname,${.TARGET} ${.ALLSRC} \
${LDDESTDIR} ${LDADD}
+
+ beforeinstall:
@@ -41,8 +41,8 @@ beforeinstall:
${INSTALLFLAGS} ${SHLINSTALLFLAGS} ${CHARSETS_SO} \
${DESTDIR}${MODULEDIR}