aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorEd Maste <emaste@FreeBSD.org>2018-09-18 19:53:46 +0000
committerEd Maste <emaste@FreeBSD.org>2018-09-18 19:53:46 +0000
commitc460a0dbeba0ec73c8b51a1bccb1568d32141274 (patch)
tree16473ef48337ca4684858f8bdcdb797fec10aa08 /converters
parent176251159f7dbce66885cf86376e67abb6237751 (diff)
downloadports-c460a0dbeba0ec73c8b51a1bccb1568d32141274.tar.gz
ports-c460a0dbeba0ec73c8b51a1bccb1568d32141274.zip
converters/lua*-iconv: enable -fPIC on arm64 and i386, for lld
Shared objects should be built as PIC, and lld enforces this by default. Add aarch64 and i386 cases to the existing set of per-arch CFLAGS, and remove the BROKEN_aarch64. Approved by: portmgr (lld blanket) Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=480070
Diffstat (limited to 'converters')
-rw-r--r--converters/lua-iconv/Makefile6
-rw-r--r--converters/lua51-iconv/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/converters/lua-iconv/Makefile b/converters/lua-iconv/Makefile
index 3a6f7ff39ac8..473148565bc0 100644
--- a/converters/lua-iconv/Makefile
+++ b/converters/lua-iconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iconv
PORTVERSION= 7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= converters
MASTER_SITES= GHC
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
@@ -15,8 +15,6 @@ COMMENT= Iconv binding for Lua 5
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ABS64 against local symbol in readonly segment
-
USES= pkgconfig iconv lua
USE_GITHUB= yes
@@ -27,7 +25,9 @@ PLIST_FILES= ${LUA_MODLIBDIR}/iconv.so
CFLAGS+= `pkgconf --cflags lua-${LUA_VER}` -I${LOCALBASE}/include
MAKE_ARGS= LUABIN=${LUA_CMD} CFLAGS="${CFLAGS}"
LDFLAGS+= -shared ${ICONV_LIB} -L${LOCALBASE}/lib
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
+CFLAGS_i386= -fPIC
do-install:
@${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
diff --git a/converters/lua51-iconv/Makefile b/converters/lua51-iconv/Makefile
index 2ab8295fbc90..9f599743e80f 100644
--- a/converters/lua51-iconv/Makefile
+++ b/converters/lua51-iconv/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iconv
PORTVERSION= 7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters
MASTER_SITES= GHC
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
@@ -12,8 +12,6 @@ DISTNAME= lua-${PORTNAME}-${PORTVERSION}
MAINTAINER= feld@FreeBSD.org
COMMENT= Iconv binding for Lua 5
-BROKEN_aarch64= fails to link: can't create dynamic relocation R_AARCH64_ABS64 against local symbol in readonly segment defined in iconv.lo
-
USES= pkgconfig iconv lua:51
USE_GITHUB= yes
@@ -24,7 +22,9 @@ PLIST_FILES= %%LUA_MODLIBDIR%%/iconv.so
CFLAGS+= `pkgconf --cflags lua-${LUA_VER}` -I${LOCALBASE}/include
MAKE_ARGS= LUABIN=${LUA_CMD} CFLAGS="${CFLAGS}"
LDFLAGS= -shared ${ICONV_LIB} -L${LOCALBASE}/lib
+CFLAGS_aarch64= -fPIC
CFLAGS_amd64= -fPIC
+CFLAGS_i386= -fPIC
do-install:
@${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}