aboutsummaryrefslogtreecommitdiff
path: root/converters
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-10 07:55:33 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-10 07:55:33 +0000
commitfb5b0c84fb8134192811153ddcf5a6af9a00d4f7 (patch)
treefd65ca8fc7e7bb8076000fc5b8b00d3d2017a2a3 /converters
parentc9d925f767c837e17997429211d0f8092edf4d58 (diff)
downloadports-fb5b0c84fb8134192811153ddcf5a6af9a00d4f7.tar.gz
ports-fb5b0c84fb8134192811153ddcf5a6af9a00d4f7.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=326872
Diffstat (limited to 'converters')
-rw-r--r--converters/fix-mime-charset/Makefile9
-rw-r--r--converters/iconv-rfc1345/Makefile8
-rw-r--r--converters/p5-Convert-Bencode/Makefile3
-rw-r--r--converters/p5-Convert-Recode/Makefile3
-rw-r--r--converters/p5-Data-AMF/Makefile8
-rw-r--r--converters/p5-Encode-JIS2K/Makefile9
-rw-r--r--converters/p5-Encode-Locale/Makefile3
-rw-r--r--converters/p5-Encode-Punycode/Makefile3
-rw-r--r--converters/p5-JSON-XS-VersionOneAndTwo/Makefile9
-rw-r--r--converters/p5-MIME-Base64-URLSafe/Makefile9
-rw-r--r--converters/p5-Net-IDN-Nameprep/Makefile3
-rw-r--r--converters/p5-PerlIO-via-Unidecode/Makefile3
-rw-r--r--converters/p5-Sereal-Encoder/Makefile3
-rw-r--r--converters/p5-Sereal/Makefile3
-rw-r--r--converters/p5-Storable-AMF/Makefile9
-rw-r--r--converters/p5-Unicode-RecursiveDowngrade/Makefile8
-rw-r--r--converters/p5-WAP-wbxml/Makefile3
-rw-r--r--converters/ytnef/Makefile9
18 files changed, 42 insertions, 63 deletions
diff --git a/converters/fix-mime-charset/Makefile b/converters/fix-mime-charset/Makefile
index fd9b6feaba2b..6070b09f9d89 100644
--- a/converters/fix-mime-charset/Makefile
+++ b/converters/fix-mime-charset/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fix-mime-charset
-# Date created: 26 November 2003
-# Whom: Nosov Artem <chip-set@mail.ru>
-#
+# Created by: Nosov Artem <chip-set@mail.ru>
# $FreeBSD$
-#
PORTNAME= fix-mime-charset
PORTVERSION= 0.5.3
@@ -19,7 +15,8 @@ LIB_DEPENDS= enca.5:${PORTSDIR}/converters/enca
PORTDOCS= README.koi8r README
GNU_CONFIGURE= yes
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/converters/iconv-rfc1345/Makefile b/converters/iconv-rfc1345/Makefile
index 0f33bc112a88..f2d569a3ba65 100644
--- a/converters/iconv-rfc1345/Makefile
+++ b/converters/iconv-rfc1345/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iconv
-# Date created: 10 September 2000
-# Whom: Konstantin Chuguev <Konstantin.Chuguev@dante.org.uk>
-#
+# Created by: Konstantin Chuguev <Konstantin.Chuguev@dante.org.uk>
# $FreeBSD$
-#
PORTNAME= iconv-rfc1345
PORTVERSION= 2.0
@@ -16,6 +12,6 @@ COMMENT= Additional charset modules for the iconv library (from RFC1345)
LIB_DEPENDS= biconv.2:${PORTSDIR}/converters/iconv
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.mk>
diff --git a/converters/p5-Convert-Bencode/Makefile b/converters/p5-Convert-Bencode/Makefile
index d11ab1e78f50..f0089a6b694d 100644
--- a/converters/p5-Convert-Bencode/Makefile
+++ b/converters/p5-Convert-Bencode/Makefile
@@ -12,7 +12,8 @@ MAINTAINER= mor@WhiteLuna.com
COMMENT= Module to encode and decode bencoded strings
BUILD_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Convert::Bencode.3
diff --git a/converters/p5-Convert-Recode/Makefile b/converters/p5-Convert-Recode/Makefile
index 3c53cb1497f6..1efb3097c0da 100644
--- a/converters/p5-Convert-Recode/Makefile
+++ b/converters/p5-Convert-Recode/Makefile
@@ -14,7 +14,8 @@ COMMENT= Front end to the GNU recode program
BUILD_DEPENDS= recode:${PORTSDIR}/converters/recode
RUN_DEPENDS= recode:${PORTSDIR}/converters/recode
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Convert::Recode.3
diff --git a/converters/p5-Data-AMF/Makefile b/converters/p5-Data-AMF/Makefile
index c77edabb5b7b..c78a50a8bb28 100644
--- a/converters/p5-Data-AMF/Makefile
+++ b/converters/p5-Data-AMF/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Data::AMF
-# Date created: 25 Dec 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Data-AMF
PORTVERSION= 0.09
@@ -21,7 +16,8 @@ RUN_DEPENDS= \
p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::AMF.3 \
Data::AMF::Formatter.3 \
diff --git a/converters/p5-Encode-JIS2K/Makefile b/converters/p5-Encode-JIS2K/Makefile
index 63f648a03fd5..31f1294fa4bf 100644
--- a/converters/p5-Encode-JIS2K/Makefile
+++ b/converters/p5-Encode-JIS2K/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Encode-JIS2K
-# Date created: May 21 2006
-# Whom: Rong-En Fan <rafan@infor.org>
-#
+# Created by: Rong-En Fan <rafan@infor.org>
# $FreeBSD$
-#
PORTNAME= Encode-JIS2K
PORTVERSION= 0.02
@@ -14,6 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= JIS X 0212 (aka JIS 2000) Encodings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/converters/p5-Encode-Locale/Makefile b/converters/p5-Encode-Locale/Makefile
index e36e88975945..6a2c17a5f3f8 100644
--- a/converters/p5-Encode-Locale/Makefile
+++ b/converters/p5-Encode-Locale/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Determine the locale encoding
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Encode::Locale.3
diff --git a/converters/p5-Encode-Punycode/Makefile b/converters/p5-Encode-Punycode/Makefile
index c2281cd0c574..0feaffff0695 100644
--- a/converters/p5-Encode-Punycode/Makefile
+++ b/converters/p5-Encode-Punycode/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Net-IDN-Encode>=0:${PORTSDIR}/textproc/p5-Net-IDN-Encode
BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Encode::Punycode.3
diff --git a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
index 20489f3c3cdf..9c9334b7bc35 100644
--- a/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
+++ b/converters/p5-JSON-XS-VersionOneAndTwo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-JSON-XS-VersionOneAndTwo
-# Date created: 21 Nov 2008
-# Whom: Denis Pokataev <catone@cpan.org>
-#
+# Created by: Denis Pokataev <catone@cpan.org>
# $FreeBSD$
-#
PORTNAME= JSON-XS-VersionOneAndTwo
PORTVERSION= 0.31
@@ -17,7 +13,8 @@ COMMENT= Support versions 1 and 2 of JSON::XS
RUN_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= JSON::XS::VersionOneAndTwo.3
diff --git a/converters/p5-MIME-Base64-URLSafe/Makefile b/converters/p5-MIME-Base64-URLSafe/Makefile
index ba1eeaac2f94..78c6b602ac39 100644
--- a/converters/p5-MIME-Base64-URLSafe/Makefile
+++ b/converters/p5-MIME-Base64-URLSafe/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: p5-MIME-Base64-URLSafe
-# Date created: Fri Aug 21, 2009
-# Whom: Dan Rench <citric@cubicone.tmetic.com>
-#
+# Created by: Dan Rench <citric@cubicone.tmetic.com>
# $FreeBSD$
-#
PORTNAME= MIME-Base64-URLSafe
PORTVERSION= 0.01
@@ -19,7 +15,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME:S/00//}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MIME::Base64::URLSafe.3
diff --git a/converters/p5-Net-IDN-Nameprep/Makefile b/converters/p5-Net-IDN-Nameprep/Makefile
index 35d8282038a4..80d49380a234 100644
--- a/converters/p5-Net-IDN-Nameprep/Makefile
+++ b/converters/p5-Net-IDN-Nameprep/Makefile
@@ -14,7 +14,8 @@ RUN_DEPENDS= p5-Unicode-Stringprep>=0:${PORTSDIR}/converters/p5-Unicode-Stringpr
BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::IDN::Nameprep.3
diff --git a/converters/p5-PerlIO-via-Unidecode/Makefile b/converters/p5-PerlIO-via-Unidecode/Makefile
index f33a530213ad..930bdb59be7f 100644
--- a/converters/p5-PerlIO-via-Unidecode/Makefile
+++ b/converters/p5-PerlIO-via-Unidecode/Makefile
@@ -13,7 +13,8 @@ COMMENT= A perlio layer for Unidecode
BUILD_DEPENDS= p5-Text-Unidecode>=0:${PORTSDIR}/converters/p5-Text-Unidecode
RUN_DEPENDS= p5-Text-Unidecode>=0:${PORTSDIR}/converters/p5-Text-Unidecode
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PerlIO::via::Unidecode.3
diff --git a/converters/p5-Sereal-Encoder/Makefile b/converters/p5-Sereal-Encoder/Makefile
index 78477e876cb9..492867c27eb1 100644
--- a/converters/p5-Sereal-Encoder/Makefile
+++ b/converters/p5-Sereal-Encoder/Makefile
@@ -15,7 +15,8 @@ TEST_DEPENDS= \
p5-Test-Warn>0:${PORTSDIR}/devel/p5-Test-Warn \
p5-Sereal-Decoder>0:${PORTSDIR}/converters/p5-Sereal-Decoder
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sereal::Encoder.3
diff --git a/converters/p5-Sereal/Makefile b/converters/p5-Sereal/Makefile
index 243dc2a3dea7..86ce50600801 100644
--- a/converters/p5-Sereal/Makefile
+++ b/converters/p5-Sereal/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Sereal-Encoder>=0.36:${PORTSDIR}/converters/p5-Sereal-Encoder
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sereal.3
diff --git a/converters/p5-Storable-AMF/Makefile b/converters/p5-Storable-AMF/Makefile
index d60bdeaab9c8..0c0acd62a088 100644
--- a/converters/p5-Storable-AMF/Makefile
+++ b/converters/p5-Storable-AMF/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Storable-AMF
-# Date created: 2009-02-04
-# Whom: Vladimir Timofeev <vovkasm@gmail.com>
-#
+# Created by: Vladimir Timofeev <vovkasm@gmail.com>
# $FreeBSD$
-#
PORTNAME= Storable-AMF
PORTVERSION= 1.00
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vovkasm@gmail.com
COMMENT= Perl extension for serialize/deserialize AMF0/AMF3 data
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Storable::AMF.3 \
Storable::AMF0.3 \
diff --git a/converters/p5-Unicode-RecursiveDowngrade/Makefile b/converters/p5-Unicode-RecursiveDowngrade/Makefile
index 2da05df630be..2571b794ba20 100644
--- a/converters/p5-Unicode-RecursiveDowngrade/Makefile
+++ b/converters/p5-Unicode-RecursiveDowngrade/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Unicode-RecursiveDowngrade
-# Date created: 4 Nov 2005
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Unicode-RecursiveDowngrade
PORTVERSION= 0.04
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension to turn off UTF-8 flags inside of comprex variable
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Unicode::RecursiveDowngrade.3
.include <bsd.port.mk>
diff --git a/converters/p5-WAP-wbxml/Makefile b/converters/p5-WAP-wbxml/Makefile
index ffd5706dad57..842ab13f2073 100644
--- a/converters/p5-WAP-wbxml/Makefile
+++ b/converters/p5-WAP-wbxml/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_DOS2UNIX= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= wbxmlc.1
MAN3= WAP::wbxml.3 WAP::wbxml::WbRules.3
diff --git a/converters/ytnef/Makefile b/converters/ytnef/Makefile
index 31f9b515cfbe..d252eb4806e2 100644
--- a/converters/ytnef/Makefile
+++ b/converters/ytnef/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ytnef
-# Date created: 21 Feb 2005
-# Whom: Rodrigo Graeff <delphus@gmail.com>
-#
+# Created by: Rodrigo Graeff <delphus@gmail.com>
# $FreeBSD$
-#
PORTNAME= ytnef
PORTVERSION= 2.6
@@ -17,7 +13,8 @@ COMMENT= Unpack data in MS Outlook TNEF format
LIB_DEPENDS= ytnef.0:${PORTSDIR}/devel/libytnef
RUN_DEPENDS= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include