aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2022-01-01 05:06:14 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2022-01-01 05:08:51 +0000
commit583287b7d536cc849d468332777339542a750f0a (patch)
tree3d8a438ee82daf3e3301fc97be0e90a1bbf0d3cf /databases/Makefile
parent97b1188b073a1e966708856902ff8b2036241b3a (diff)
downloadports-583287b7d536cc849d468332777339542a750f0a.tar.gz
ports-583287b7d536cc849d468332777339542a750f0a.zip
databases/py-ormar: add port: Simple async ORM with fastapi in mind and pydantic validation
The ormar package is an async mini ORM for Python, with support for Postgres, MySQL, and SQLite. The main benefit of using ormar are: * getting an async ORM that can be used with async frameworks (fastapi, starlette etc.) * getting just one model to maintain - you don't have to maintain pydantic and other orm model (sqlalchemy, peewee, gino etc.) The goal was to create a simple ORM that can be used directly (as request and response models) with fastapi that bases it's data validation on pydantic. WWW: https://github.com/collerek/ormar PR: 257370 Reported by: Goran Mekić <meka@tilda.center> (new maintainer) Reviewed by: koobs
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 2952b5e2e088..4b136c577340 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -796,6 +796,7 @@
SUBDIR += py-mycli
SUBDIR += py-mysql-connector-python
SUBDIR += py-mysqlclient
+ SUBDIR += py-ormar
SUBDIR += py-partd
SUBDIR += py-peewee
SUBDIR += py-peewee_migrate