aboutsummaryrefslogtreecommitdiff
path: root/databases/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-10 10:37:36 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-10 10:37:36 +0000
commitf05ec84bfffdca7e69af2b76eb1acdc3bf4c7b61 (patch)
treee1a74651cbe37a641328725e02034a1781197d20 /databases/Makefile
parent6fe6de2bda3375a98bf35cefcd4c3c4d93a56cf3 (diff)
downloadports-f05ec84bfffdca7e69af2b76eb1acdc3bf4c7b61.tar.gz
ports-f05ec84bfffdca7e69af2b76eb1acdc3bf4c7b61.zip
New port: databases/p5-App-Sqitch
Sqitch is a database change management application. What makes it different from your typical migration-style approaches? A few things: ## No opinions Sqitch is not integrated with any framework, ORM, or platform. Rather, it is a standalone change management system with no opinions about your database engine, application framework, or development environment. ## Native scripting Changes are implemented as scripts native to your selected database engine. Writing a PostgreSQL application? Write SQL scripts for psql. Writing a MySQL-backed app? Write SQL scripts for mysql. ## Dependency resolution Database changes may declare dependencies on other changes -- even on changes from other Sqitch projects. This ensures proper order of execution, even when you've committed changes to your VCS out-of-order. ## No numbering Change deployment is managed by maintaining a plan file. As such, there is no need to number your changes, although you can if you want. Sqitch doesn't much care how you name your changes. ## Iterative development Up until you tag and release your application, you can modify your change deployment scripts as often as you like. They're not locked in just because they've been committed to your VCS. This allows you to take an iterative approach to developing your database schema. Or, better, you can do test-driven database development. WWW: http://search.cpan.org/dist/App-Sqitch/ PR: 205943 Submitted by: Henrik Hodne <henrik@hodne.io>
Notes
Notes: svn path=/head/; revision=412912
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index a4b1c157ef11..332d39e1375e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -249,6 +249,7 @@
SUBDIR += p5-AnyEvent-DBD-Pg
SUBDIR += p5-AnyEvent-Memcached
SUBDIR += p5-AnyEvent-Redis
+ SUBDIR += p5-App-Sqitch
SUBDIR += p5-AsciiDB-TagFile
SUBDIR += p5-BDB
SUBDIR += p5-BSON