aboutsummaryrefslogtreecommitdiff
path: root/databases/bbdb/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-11-14 18:03:50 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-11-14 18:03:50 +0000
commit546e5a80c6e45f096d82617ff4efb703f7b33a44 (patch)
treee97170b2cbd66ca45830fe1ee9d53d72a9407f19 /databases/bbdb/Makefile
parent118d10c451762904e6d040659737765bd79fb942 (diff)
downloadports-546e5a80c6e45f096d82617ff4efb703f7b33a44.tar.gz
ports-546e5a80c6e45f096d82617ff4efb703f7b33a44.zip
databases/bbdb: Update to 3.2, fix w/ Emacs 26.1, add pkg-message
PR: 227257 Reported by: emss@free.fr
Notes
Notes: svn path=/head/; revision=484936
Diffstat (limited to 'databases/bbdb/Makefile')
-rw-r--r--databases/bbdb/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/databases/bbdb/Makefile b/databases/bbdb/Makefile
index 2fc530a4641b..51f7b69d0d21 100644
--- a/databases/bbdb/Makefile
+++ b/databases/bbdb/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= bbdb
-DISTVERSION= 3.1.2
-PORTREVISION= 1
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.2
CATEGORIES= databases elisp
-MASTER_SITES= SAVANNAH
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
MAINTAINER= ports@FreeBSD.org
@@ -13,32 +12,39 @@ COMMENT= Big Brother Database
LICENSE= GPLv3+
-.if ${FLAVOR:U} != devel && ${FLAVOR:U} != devel_nox
-# http://pkg.awarnach.mathstat.dal.ca/data/11i386-default/2018-05-30_07h36m11s/logs/errors/bbdb-emacs26-3.1.2_1.log
-BROKEN= fails to build
-.endif
-
-# do not depend on base texinfo on 10
BUILD_DEPENDS= texi2dvi:print/texinfo
-USES= emacs
+USES= autoreconf emacs
+USE_GITHUB= yes
+GH_ACCOUNT= emacsmirror
USE_TEX= latex:build
BBDB_LISPDIR= ${EMACS_SITE_LISPDIR}/${PORTNAME}
GNU_CONFIGURE= yes
-INFO= bbdb
+# Do not install the info file. Upstream has yet to add any real content to it.
+#INFO= bbdb
PORTDOCS= bbdb.pdf
NO_ARCH= yes
PLIST_SUB+= BBDB_LISPDIR=${BBDB_LISPDIR}
+MAKE_JOBS_UNSAFE= yes
+
OPTIONS_DEFINE= DOCS
+# See http://lists.nongnu.org/archive/html/bbdb-user/2018-11/msg00003.html
+.if ${FLAVOR:U} != devel_full && ${FLAVOR:U} != devel_nox
+post-configure:
+ ${REINPLACE_CMD} -e '/[[:blank:]]*--eval '\''(setq byte-compile-dest-file-function (lambda (_) "$$@"))'\'' \\/d' \
+ ${WRKSRC}/lisp/Makefile
+.endif
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${BBDB_LISPDIR}
${INSTALL_DATA} ${WRKSRC}/lisp/*.el ${WRKSRC}/lisp/*.elc \
${STAGEDIR}${PREFIX}/${BBDB_LISPDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.info \
- ${STAGEDIR}${PREFIX}/${INFO_PATH}
+# Do not install the info file. Upstream has yet to add any real content to it.
+# ${INSTALL_DATA} ${WRKSRC}/doc/${PORTNAME}.info \
+# ${STAGEDIR}${PREFIX}/${INFO_PATH}
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}