aboutsummaryrefslogtreecommitdiff
path: root/databases/cassandra2
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-29 07:18:10 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-29 07:18:10 +0000
commitebe20a9e0d0df1fe24d7c6259dad9e10b733a4d4 (patch)
tree518dc15059e009282af1509c63926b7a21576a65 /databases/cassandra2
parent7561227a140dae858d47dc644831506ef1d73793 (diff)
downloadports-ebe20a9e0d0df1fe24d7c6259dad9e10b733a4d4.tar.gz
ports-ebe20a9e0d0df1fe24d7c6259dad9e10b733a4d4.zip
New port: databases/cassandra2
Cassandra is a highly scalable, eventually consistent, distributed, structured key-value store. Cassandra brings together the distributed systems technologies from Dynamo and the data model from Google's BigTable. Like Dynamo, Cassandra is eventually consistent. Like BigTable, Cassandra provides a ColumnFamily-based data model richer than typical key/value systems. Cassandra was open sourced by Facebook in 2008, where it was designed by one of the authors of Amazon's Dynamo. In a lot of ways you can think of Cassandra as Dynamo 2.0. Cassandra is in production use at Facebook but is still under heavy development. WWW: http://cassandra.apache.org/ The previous version is still available as databases/cassandra. PR: 186056 Submitted by: admins@perceptyx.com
Notes
Notes: svn path=/head/; revision=366464
Diffstat (limited to 'databases/cassandra2')
-rw-r--r--databases/cassandra2/Makefile126
-rw-r--r--databases/cassandra2/distinfo2
-rw-r--r--databases/cassandra2/files/cassandra.in67
-rw-r--r--databases/cassandra2/files/patch-env7
-rw-r--r--databases/cassandra2/files/repaircluster.in12
-rw-r--r--databases/cassandra2/pkg-deinstall15
-rw-r--r--databases/cassandra2/pkg-descr13
-rw-r--r--databases/cassandra2/pkg-install16
-rw-r--r--databases/cassandra2/pkg-plist174
9 files changed, 432 insertions, 0 deletions
diff --git a/databases/cassandra2/Makefile b/databases/cassandra2/Makefile
new file mode 100644
index 000000000000..618a5b257d3c
--- /dev/null
+++ b/databases/cassandra2/Makefile
@@ -0,0 +1,126 @@
+# $FreeBSD$
+
+PORTNAME= cassandra
+PORTVERSION= 2.0.10
+CATEGORIES= databases java
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= cassandra/${PORTVERSION}
+DISTNAME= apache-cassandra-${PORTVERSION}
+EXTRACT_SUFX= -bin.tar.gz
+
+MAINTAINER= admins@perceptyx.com
+COMMENT= Open source distributed database management system
+
+LICENSE= APACHE20
+
+JAVA_VERSION= 1.7
+JAVA_VENDOR= openjdk
+REINPLACE_ARGS= -i ''
+USE_JAVA= yes
+USE_RC_SUBR= cassandra
+
+CONFIGS= cassandra-topology.properties \
+ cassandra.yaml \
+ log4j-server.properties \
+ log4j-tools.properties \
+ cassandra-rackdc.properties \
+ commitlog_archiving.properties
+SCRIPTS= cassandra \
+ cassandra-cli \
+ json2sstable \
+ nodetool \
+ sstable2json \
+ sstablekeys \
+ sstableloader \
+ sstablescrub
+
+CONFLICTS_INSTALL= cassandra-1.*
+
+OPTIONS_DEFINE= MX4J JNA CQL DOCS
+OPTIONS_SUB= yes
+
+MX4J_DESC= Enable HTTP interface for JMX
+JNA_DESC= Use JNA native access
+CQL_DESC= Install cqlsh
+DOCS_DESC= Install javadoc documentation
+
+SUB_FILES= repaircluster
+
+.include <bsd.port.options.mk>
+
+RUN_DEPENDS+= ${JAVALIBDIR}/snappy-java.jar:${PORTSDIR}/archivers/snappy-java
+
+MX4J_RUN_DEPENDS= ${JAVAJARDIR}/mx4j-tools.jar:${PORTSDIR}/java/mx4j
+JNA_RUN_DEPENDS= ${JAVAJARDIR}/jna.jar:${PORTSDIR}/devel/jna
+CQL_USE= python=yes
+
+PORTDOCS= javadoc *.txt
+
+.if ${PORT_OPTIONS:MCQL}
+SCRIPTS+= cqlsh
+USES= python:2
+.endif
+
+post-extract:
+ ${RM} ${WRKSRC}/bin/*.bat ${WRKSRC}/bin/stop-server \
+ ${WRKSRC}/tools/bin/*.bat ${WRKSRC}/lib/snappy-java-*.jar
+.for i in ${CONFIGS}
+ ${MV} ${WRKSRC}/conf/${i} ${WRKSRC}/conf/${i}.sample
+.endfor
+.if empty(PORT_OPTIONS:MCQL)
+ ${RM} -r ${WRKSRC}/pylib
+ ${RM} ${WRKSRC}/bin/cqlsh
+ ${RM} ${WRKSRC}/lib/*.zip
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/share/cassandra|${DATADIR}/bin|' \
+ ${WRKSRC}/bin/cassandra-cli \
+ ${WRKSRC}/bin/nodetool \
+ ${WRKSRC}/bin/sstableloader \
+ ${WRKSRC}/bin/sstable2json \
+ ${WRKSRC}/bin/json2sstable \
+ ${WRKSRC}/bin/sstablekeys
+ ${REINPLACE_CMD} -e 's|\`dirname \$$\0\`/..|${DATADIR}|' \
+ ${WRKSRC}/bin/cassandra.in.sh
+ ${RM} -f ${WRKSRC}/conf/*.orig
+.if ${PORT_OPTIONS:MCQL}
+ ${REINPLACE_CMD} -e 's|os.path.dirname(__file__)|"${DATADIR}/bin"|' \
+ ${WRKSRC}/bin/cqlsh
+.endif
+
+do-build:
+.if ${PORT_OPTIONS:MCQL}
+ ${PYTHON_CMD} -m compileall ${WRKSRC}/pylib
+.endif
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ ${LN} -sf ${JAVAJARDIR}/snappy-java.jar ${STAGEDIR}${DATADIR}/lib/snappy-java.jar
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MV} ${STAGEDIR}${DATADIR}/javadoc ${STAGEDIR}${DOCSDIR}
+ ${MV} ${STAGEDIR}${DATADIR}/*.txt ${STAGEDIR}${DOCSDIR}
+ cd ${STAGEDIR}${DATADIR}/bin/ && ${CHMOD} ${BINMODE} ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKDIR}/repaircluster ${STAGEDIR}${DATADIR}/bin
+ ${LN} -sf ${DATADIR}/bin/cassandra-cli ${STAGEDIR}${PREFIX}/bin/cassandra-cli
+ ${LN} -sf ${DATADIR}/bin/nodetool ${STAGEDIR}${PREFIX}/bin/nodetool
+ ${LN} -sf ${DATADIR}/bin/sstableloader ${STAGEDIR}${PREFIX}/bin/sstableloader
+ ${LN} -sf ${DATADIR}/bin/repaircluster ${STAGEDIR}${PREFIX}/bin/repaircluster
+ ${LN} -sf ${DATADIR}/bin/json2sstable ${STAGEDIR}${PREFIX}/bin/json2sstable
+ ${LN} -sf ${DATADIR}/bin/sstable2json ${STAGEDIR}${PREFIX}/bin/sstable2json
+ ${LN} -sf ${DATADIR}/bin/sstablekeys ${STAGEDIR}${PREFIX}/bin/sstablekeys
+ ${LN} -sf ${DATADIR}/bin/sstablescrub ${STAGEDIR}${PREFIX}/bin/sstablescrub
+
+.if ${PORT_OPTIONS:MCQL}
+ ${LN} -sf ${DATADIR}/bin/cqlsh ${STAGEDIR}${PREFIX}/bin/cqlsh
+.endif
+.if ${PORT_OPTIONS:MMX4J}
+ ${LN} -sf ${LOCALBASE}/share/java/classes/mx4j-tools.jar ${STAGEDIR}${DATADIR}/lib/mx4j-tools.jar
+.endif
+.if ${PORT_OPTIONS:MJNA}
+ ${LN} -sf ${LOCALBASE}/share/java/classes/jna.jar ${STAGEDIR}${DATADIR}/lib/jna.jar
+ ${LN} -sf ${LOCALBASE}/share/java/classes/jna-platform.jar ${STAGEDIR}${DATADIR}/lib/jna-platform.jar
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/cassandra2/distinfo b/databases/cassandra2/distinfo
new file mode 100644
index 000000000000..51ed50d92b55
--- /dev/null
+++ b/databases/cassandra2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (apache-cassandra-2.0.10-bin.tar.gz) = 962ab35b1767ed4c56eb9a2a6b9df374097dc48d4f1c718945cab3a977e5d9fa
+SIZE (apache-cassandra-2.0.10-bin.tar.gz) = 17969861
diff --git a/databases/cassandra2/files/cassandra.in b/databases/cassandra2/files/cassandra.in
new file mode 100644
index 000000000000..37ac7468752f
--- /dev/null
+++ b/databases/cassandra2/files/cassandra.in
@@ -0,0 +1,67 @@
+#!/bin/sh
+#
+# Copyright (c) 2011, Radim Kolar
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
+# DAMAGE.
+
+# PROVIDE: cassandra
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# $FreeBSD: databases/cassandra/files/cassandra.in 319455 2013-05-31 01:32:45Z bdrewery $
+
+. /etc/rc.subr
+
+name="cassandra"
+rcvar=cassandra_enable
+load_rc_config $name
+
+cassandra_enable=${cassandra_enable:-"NO"}
+cassandra_vmargs=${cassandra_vmargs:-""}
+cassandra_memory=${cassandra_memory:-"1000m"}
+cassandra_newgen=${cassandra_newgen:-"300m"}
+
+command=%%DATADIR%%/bin/cassandra
+command_args="-p /var/run/cassandra.pid >/dev/null"
+stop_precmd="${name}_prestop"
+sig_stop="KILL"
+
+procname="%%LOCALBASE%%/openjdk7/bin/java"
+pidfile=/var/run/cassandra.pid
+
+export MAX_HEAP_SIZE="$cassandra_memory"
+export HEAP_NEWSIZE="$cassandra_newgen"
+export PATH=$PATH:%%LOCALBASE%%/bin
+export CASSANDRA_HOME=%%DATADIR%%
+export JVM_OPTS=-javaagent:%%DATADIR%%/lib/jamm-0.2.5.jar
+export JVM_OVERRIDE_OPTS="$cassandra_vmargs"
+
+export JAVA_VENDOR=openjdk
+export JAVA_VERSION=1.7
+
+cassandra_prestop() {
+ $CASSANDRA_HOME/bin/nodetool -h localhost drain
+ return 0
+}
+
+run_rc_command "$1"
diff --git a/databases/cassandra2/files/patch-env b/databases/cassandra2/files/patch-env
new file mode 100644
index 000000000000..caacf9cbfe48
--- /dev/null
+++ b/databases/cassandra2/files/patch-env
@@ -0,0 +1,7 @@
+--- conf/cassandra-env.sh.orig 2011-11-04 11:47:16.000000000 +0100
++++ conf/cassandra-env.sh 2011-11-09 16:50:50.124144710 +0100
+@@ -192,3 +192,4 @@
+ JVM_OPTS="$JVM_OPTS -Dcom.sun.management.jmxremote.port=$JMX_PORT"
+ JVM_OPTS="$JVM_OPTS -Dcom.sun.management.jmxremote.ssl=false"
+ JVM_OPTS="$JVM_OPTS -Dcom.sun.management.jmxremote.authenticate=false"
++JVM_OPTS="$JVM_OPTS $JVM_OVERRIDE_OPTS"
diff --git a/databases/cassandra2/files/repaircluster.in b/databases/cassandra2/files/repaircluster.in
new file mode 100644
index 000000000000..678cfa4f4a4d
--- /dev/null
+++ b/databases/cassandra2/files/repaircluster.in
@@ -0,0 +1,12 @@
+#! /bin/sh
+set -e
+PATH=/bin:/usr/bin:%%LOCALBASE%%/bin:%%PREFIX%%/bin
+NODETOOL=%%DATADIR%%/bin/nodetool
+
+if test $# -eq 0; then
+ echo "$0 <any node in cluster> [keyspace]"
+ exit 1;
+fi
+for i in `$NODETOOL -h $1 ring | cut -d ' ' -f 1 | grep -e '^[0-9]'`; do
+ $NODETOOL -h $i repair $2
+done
diff --git a/databases/cassandra2/pkg-deinstall b/databases/cassandra2/pkg-deinstall
new file mode 100644
index 000000000000..9f449a8dfa86
--- /dev/null
+++ b/databases/cassandra2/pkg-deinstall
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# Removes unchanged configuration files
+#
+if [ "$2" = "DEINSTALL" ]; then
+ if [ ! -d $PKG_PREFIX/share/cassandra/conf ]; then exit 1; fi
+ cd $PKG_PREFIX/share/cassandra/conf
+ for cfgfile in cassandra.yaml commitlog_archiving.properties \
+ log4j-server.properties log4j-tools.properties \
+ cassandra-topology.properties cassandra-rackdc.properties;do
+ if cmp -s $cfgfile.sample $cfgfile; then
+ rm $cfgfile
+ fi
+ done
+fi
diff --git a/databases/cassandra2/pkg-descr b/databases/cassandra2/pkg-descr
new file mode 100644
index 000000000000..314f71490a1e
--- /dev/null
+++ b/databases/cassandra2/pkg-descr
@@ -0,0 +1,13 @@
+Cassandra is a highly scalable, eventually consistent, distributed,
+structured key-value store. Cassandra brings together the distributed
+systems technologies from Dynamo and the data model from Google's
+BigTable. Like Dynamo, Cassandra is eventually consistent. Like
+BigTable, Cassandra provides a ColumnFamily-based data model richer
+than typical key/value systems.
+
+Cassandra was open sourced by Facebook in 2008, where it was designed
+by one of the authors of Amazon's Dynamo. In a lot of ways you can
+think of Cassandra as Dynamo 2.0. Cassandra is in production use at
+Facebook but is still under heavy development.
+
+WWW: http://cassandra.apache.org/
diff --git a/databases/cassandra2/pkg-install b/databases/cassandra2/pkg-install
new file mode 100644
index 000000000000..a09c9b90a1fe
--- /dev/null
+++ b/databases/cassandra2/pkg-install
@@ -0,0 +1,16 @@
+#!/bin/sh
+#
+# Copy sample cassandra config files to real ones if real ones does not exists
+#
+if [ "$2" = "POST-INSTALL" ]; then
+ if [ ! -d $PKG_PREFIX/share/cassandra/conf ]; then exit 1; fi
+ umask 027
+ cd $PKG_PREFIX/share/cassandra/conf
+ for cfgfile in cassandra.yaml commitlog_archiving.properties \
+ log4j-server.properties log4j-tools.properties \
+ cassandra-topology.properties cassandra-rackdc.properties; do
+ if [ ! -f $cfgfile ]; then
+ cp -p $cfgfile.sample $cfgfile
+ fi
+ done
+fi
diff --git a/databases/cassandra2/pkg-plist b/databases/cassandra2/pkg-plist
new file mode 100644
index 000000000000..3687ef5ef76d
--- /dev/null
+++ b/databases/cassandra2/pkg-plist
@@ -0,0 +1,174 @@
+bin/cassandra-cli
+%%CQL%%bin/cqlsh
+bin/json2sstable
+bin/nodetool
+bin/repaircluster
+bin/sstable2json
+bin/sstablekeys
+bin/sstableloader
+bin/sstablescrub
+%%DATADIR%%/bin/cassandra
+%%DATADIR%%/bin/cassandra-cli
+%%DATADIR%%/bin/cassandra.in.sh
+%%CQL%%%%DATADIR%%/bin/cqlsh
+%%DATADIR%%/bin/debug-cql
+%%DATADIR%%/bin/json2sstable
+%%DATADIR%%/bin/nodetool
+%%DATADIR%%/bin/repaircluster
+%%DATADIR%%/bin/sstable2json
+%%DATADIR%%/bin/sstablekeys
+%%DATADIR%%/bin/sstableloader
+%%DATADIR%%/bin/sstablescrub
+%%DATADIR%%/bin/sstablesplit
+%%DATADIR%%/bin/sstableupgrade
+%%DATADIR%%/conf/README.txt
+%%DATADIR%%/conf/cassandra-env.sh
+@sample %%DATADIR%%/conf/cassandra-rackdc.properties.sample
+@sample %%DATADIR%%/conf/cassandra-topology.properties.sample
+%%DATADIR%%/conf/cassandra-topology.yaml
+@sample %%DATADIR%%/conf/cassandra.yaml.sample
+@sample %%DATADIR%%/conf/commitlog_archiving.properties.sample
+@sample %%DATADIR%%/conf/cqlshrc.sample
+@sample %%DATADIR%%/conf/log4j-server.properties.sample
+@sample %%DATADIR%%/conf/log4j-tools.properties.sample
+%%DATADIR%%/conf/metrics-reporter-config-sample.yaml
+%%DATADIR%%/conf/triggers/README.txt
+%%DATADIR%%/interface/cassandra.thrift
+%%DATADIR%%/lib/antlr-3.2.jar
+%%DATADIR%%/lib/apache-cassandra-2.0.10.jar
+%%DATADIR%%/lib/apache-cassandra-clientutil-2.0.10.jar
+%%DATADIR%%/lib/apache-cassandra-thrift-2.0.10.jar
+%%DATADIR%%/lib/commons-cli-1.1.jar
+%%DATADIR%%/lib/commons-codec-1.2.jar
+%%DATADIR%%/lib/commons-lang3-3.1.jar
+%%DATADIR%%/lib/compress-lzf-0.8.4.jar
+%%DATADIR%%/lib/concurrentlinkedhashmap-lru-1.3.jar
+%%CQL%%%%DATADIR%%/lib/cql-internal-only-1.4.1.zip
+%%DATADIR%%/lib/disruptor-3.0.1.jar
+%%DATADIR%%/lib/guava-15.0.jar
+%%DATADIR%%/lib/high-scale-lib-1.1.2.jar
+%%DATADIR%%/lib/jackson-core-asl-1.9.2.jar
+%%DATADIR%%/lib/jackson-mapper-asl-1.9.2.jar
+%%DATADIR%%/lib/jamm-0.2.5.jar
+%%DATADIR%%/lib/jbcrypt-0.3m.jar
+%%DATADIR%%/lib/jline-1.0.jar
+%%JNA%%%%DATADIR%%/lib/jna-platform.jar
+%%JNA%%%%DATADIR%%/lib/jna.jar
+%%DATADIR%%/lib/json-simple-1.1.jar
+%%DATADIR%%/lib/libthrift-0.9.1.jar
+%%DATADIR%%/lib/licenses/antlr-3.2.txt
+%%DATADIR%%/lib/licenses/commons-cli-1.1.txt
+%%DATADIR%%/lib/licenses/commons-codec-1.2.txt
+%%DATADIR%%/lib/licenses/commons-lang3-3.1.txt
+%%DATADIR%%/lib/licenses/compress-lzf-0.8.4.txt
+%%DATADIR%%/lib/licenses/concurrentlinkedhashmap-lru-1.3.txt
+%%DATADIR%%/lib/licenses/cql-1.4.0.txt
+%%DATADIR%%/lib/licenses/disruptor-3.0.1.txt
+%%DATADIR%%/lib/licenses/guava-15.0.txt
+%%DATADIR%%/lib/licenses/high-scale-lib-1.1.2.txt
+%%DATADIR%%/lib/licenses/jackson-core-asl-1.9.2.txt
+%%DATADIR%%/lib/licenses/jackson-mapper-asl-1.9.2.txt
+%%DATADIR%%/lib/licenses/jamm-0.2.5.txt
+%%DATADIR%%/lib/licenses/jbcrypt-0.3m.txt
+%%DATADIR%%/lib/licenses/jline-1.0.txt
+%%DATADIR%%/lib/licenses/json-simple-1.1.txt
+%%DATADIR%%/lib/licenses/libthrift-0.9.1.txt
+%%DATADIR%%/lib/licenses/log4j-1.2.16.txt
+%%DATADIR%%/lib/licenses/lz4-1.2.0.txt
+%%DATADIR%%/lib/licenses/metrics-core-2.2.0.txt
+%%DATADIR%%/lib/licenses/netty-3.5.9.txt
+%%DATADIR%%/lib/licenses/netty-3.6.6.txt
+%%DATADIR%%/lib/licenses/reporter-config-2.1.0.txt
+%%DATADIR%%/lib/licenses/servlet-api-2.5-20081211.txt
+%%DATADIR%%/lib/licenses/slf4j-api-1.7.2.txt
+%%DATADIR%%/lib/licenses/slf4j-log4j12-1.7.2.txt
+%%DATADIR%%/lib/licenses/snakeyaml-1.11.txt
+%%DATADIR%%/lib/licenses/snappy-java-1.0.5.txt
+%%DATADIR%%/lib/licenses/snaptree-0.1.txt
+%%DATADIR%%/lib/licenses/super-csv-2.1.0.txt
+%%DATADIR%%/lib/licenses/thrift-python-0.9.1.txt
+%%DATADIR%%/lib/licenses/thrift-server-0.3.3.txt
+%%DATADIR%%/lib/log4j-1.2.16.jar
+%%DATADIR%%/lib/lz4-1.2.0.jar
+%%DATADIR%%/lib/metrics-core-2.2.0.jar
+%%MX4J%%%%DATADIR%%/lib/mx4j-tools.jar
+%%DATADIR%%/lib/netty-3.6.6.Final.jar
+%%DATADIR%%/lib/reporter-config-2.1.0.jar
+%%DATADIR%%/lib/servlet-api-2.5-20081211.jar
+%%DATADIR%%/lib/slf4j-api-1.7.2.jar
+%%DATADIR%%/lib/slf4j-log4j12-1.7.2.jar
+%%DATADIR%%/lib/snakeyaml-1.11.jar
+%%DATADIR%%/lib/snappy-java.jar
+%%DATADIR%%/lib/snaptree-0.1.jar
+%%DATADIR%%/lib/super-csv-2.1.0.jar
+%%CQL%%%%DATADIR%%/lib/thrift-python-internal-only-0.9.1.zip
+%%DATADIR%%/lib/thrift-server-internal-only-0.3.3.jar
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/__init__.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/__init__.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/cql3handling.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/cql3handling.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/cqlhandling.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/cqlhandling.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/displaying.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/displaying.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/formatting.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/formatting.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/helptopics.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/helptopics.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/pylexotron.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/pylexotron.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/saferscanner.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/saferscanner.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/ssl.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/ssl.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/__init__.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/__init__.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/ansi_colors.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/ansi_colors.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/basecase.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/basecase.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/cassconnect.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/cassconnect.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/run_cqlsh.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/run_cqlsh.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cql_parsing.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cql_parsing.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_commands.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_commands.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_completion.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_completion.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_invocation.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_invocation.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_output.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_cqlsh_output.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/test/test_keyspace_init.cql
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/tfactory.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/tfactory.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/tracing.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/tracing.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/util.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/util.pyc
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/wcwidth.py
+%%CQL%%%%DATADIR%%/pylib/cqlshlib/wcwidth.pyc
+%%CQL%%%%DATADIR%%/pylib/setup.py
+%%CQL%%%%DATADIR%%/pylib/setup.pyc
+%%DATADIR%%/tools/bin/cassandra-stress
+%%DATADIR%%/tools/bin/cassandra-stressd
+%%DATADIR%%/tools/bin/cassandra.in.sh
+%%DATADIR%%/tools/bin/sstablelevelreset
+%%DATADIR%%/tools/bin/sstablemetadata
+%%DATADIR%%/tools/bin/token-generator
+%%DATADIR%%/tools/lib/stress.jar
+@dirrmtry %%DATADIR%%/bin
+@dirrmtry %%DATADIR%%/conf/triggers
+@dirrmtry %%DATADIR%%/conf
+@dirrmtry %%DATADIR%%/interface
+@dirrmtry %%DATADIR%%/lib/licenses
+@dirrmtry %%DATADIR%%/lib
+%%CQL%%@dirrmtry %%DATADIR%%/pylib/cqlshlib/test
+%%CQL%%@dirrmtry %%DATADIR%%/pylib/cqlshlib
+%%CQL%%@dirrmtry %%DATADIR%%/pylib
+@dirrmtry %%DATADIR%%/tools/bin
+@dirrmtry %%DATADIR%%/tools/lib
+@dirrmtry %%DATADIR%%/tools
+@dirrmtry %%DATADIR%%