aboutsummaryrefslogtreecommitdiff
path: root/databases/cassandra4
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-07-24 17:10:51 +0000
commit5bc1617efc876b99a806f7de78a9fe94a07304b7 (patch)
treebfbfce29f0c9b229834a1f0536dd6d8022ce8104 /databases/cassandra4
parentd841eb94b16fac58b307b35f0c2849842e5eea54 (diff)
downloadports-5bc1617efc876b99a806f7de78a9fe94a07304b7.tar.gz
ports-5bc1617efc876b99a806f7de78a9fe94a07304b7.zip
Multiple ports: improve regex compliance (part 2)
This is again a part of the project to stop extraneous escaping of ordinary characters and redefine some ordinary escapes as special behavior. Most of these ports are pushed over to use textproc/gsed because they want to use GNU extensions. Others are fixed to either escape appropriately (e.g. $$ rather than \$ in Makefiles!) or just remove redundant escapes (e.g. backtick in single quotes doesn't need escaped). PR: 229925 MFH: no (invasive risk)
Notes
Notes: svn path=/head/; revision=543267
Diffstat (limited to 'databases/cassandra4')
-rw-r--r--databases/cassandra4/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/cassandra4/Makefile b/databases/cassandra4/Makefile
index 88b736c634b6..f4d8d16bdb8b 100644
--- a/databases/cassandra4/Makefile
+++ b/databases/cassandra4/Makefile
@@ -95,10 +95,10 @@ post-build:
.for f in ${SCRIPT_FILES}
@${REINPLACE_CMD} -e 's|/usr/share/cassandra|${DATADIR}/bin|' ${BUILD_DIST_DIR}/bin/${f}
.endfor
- @${REINPLACE_CMD} -e 's|\`dirname "\$$\0"\`/..|${DATADIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/conf/cassandra-env.sh
- @${REINPLACE_CMD} -e 's|\$$\CASSANDRA_HOME/conf|${ETCDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|`dirname "$$0"`/..|${DATADIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/lib/sigar-bin|${JAVAJARDIR}|' ${BUILD_DIST_DIR}/conf/cassandra-env.sh
+ @${REINPLACE_CMD} -e 's|$$CASSANDRA_HOME/conf|${ETCDIR}|' ${BUILD_DIST_DIR}/bin/cassandra.in.sh
.for f in ${CONFIG_FILES}
@${MV} ${BUILD_DIST_DIR}/conf/${f} ${BUILD_DIST_DIR}/conf/${f}.sample
.endfor