aboutsummaryrefslogtreecommitdiff
path: root/databases/dbf/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-11 08:51:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-11 08:51:47 +0000
commitf092015a230c66f255b5e906eb8163e5c6a43c55 (patch)
tree7f7816d109c4b35f9eb62ff26bcc4cb4ea247a9c /databases/dbf/files
parentc0c56d01918641c873953db3b380aed4929e4333 (diff)
downloadports-f092015a230c66f255b5e906eb8163e5c6a43c55.tar.gz
ports-f092015a230c66f255b5e906eb8163e5c6a43c55.zip
upgrade to 0.8
Notes
Notes: svn path=/head/; revision=93723
Diffstat (limited to 'databases/dbf/files')
-rw-r--r--databases/dbf/files/patch-Makefile.rules27
-rw-r--r--databases/dbf/files/patch-dbf.c18
2 files changed, 33 insertions, 12 deletions
diff --git a/databases/dbf/files/patch-Makefile.rules b/databases/dbf/files/patch-Makefile.rules
index 332d277f74d6..f4dfa3daadec 100644
--- a/databases/dbf/files/patch-Makefile.rules
+++ b/databases/dbf/files/patch-Makefile.rules
@@ -1,18 +1,21 @@
---- ../Makefile.rules Thu May 8 14:53:12 2003
-+++ ../Makefile.rules Tue Aug 19 15:22:20 2003
-@@ -4,4 +4,3 @@
+--- ../Makefile.rules.orig Tue Nov 11 16:43:04 2003
++++ ../Makefile.rules Tue Nov 11 16:43:24 2003
+@@ -2,15 +2,15 @@
+ # Version 0.8
+
# Compiler flags
-CC = /usr/bin/gcc
-CFLAGS = -Wall
++#CC = /usr/bin/gcc
+CFLAGS += -Wall
-@@ -12,3 +11,3 @@
- VERSION = 0.6
--PREFIX = /usr/local/bin
-+PREFIX := ${PREFIX}/bin
+ # Settings
+ LOG = make.log
+ DIRS = src
+ BIN = dbf
+ VERSION = 0.8
+-PREFIX = /usr/local
++#PREFIX = /usr/local
-@@ -19,4 +18 @@
- RED = \033[1;31m
--
--.c.o:
-- $(CC) $(CFLAGS) -c $<
+ # Compiler settings - do not change
+ # erased dbfversion.o
diff --git a/databases/dbf/files/patch-dbf.c b/databases/dbf/files/patch-dbf.c
new file mode 100644
index 000000000000..cf2ce4073bc5
--- /dev/null
+++ b/databases/dbf/files/patch-dbf.c
@@ -0,0 +1,18 @@
+--- dbf.c.orig Tue Nov 11 16:48:07 2003
++++ dbf.c Tue Nov 11 16:48:19 2003
+@@ -315,6 +315,7 @@
+ exit(1);
+
+ if (writeLine) {
++ char *flag_byte;
+ if ((record = malloc(record_length + 1)) == NULL) {
+ perror("malloc"); exit(1);
+ }
+@@ -327,7 +328,6 @@
+ //lseek(dbfhandle, rotate2b(db->header_length) + 1, SEEK_SET);
+
+ /* At this point we look if the following data set is deleted */
+- char *flag_byte;
+ lseek(dbfhandle, rotate2b(db->header_length), SEEK_SET);
+
+ if ( (flag_byte = malloc(1)) == NULL ) {