aboutsummaryrefslogtreecommitdiff
path: root/databases/evolution-data-server
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-09-11 09:22:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-09-11 09:22:36 +0000
commitfa335f26e3255fa5cd7d0374b6abe0c51234ef1a (patch)
treebada68e8ebfd24e1a18fb739449cf367fef42f00 /databases/evolution-data-server
parent8667e32c1cd60ed436249d125cc07f44f2146ab6 (diff)
downloadports-fa335f26e3255fa5cd7d0374b6abe0c51234ef1a.tar.gz
ports-fa335f26e3255fa5cd7d0374b6abe0c51234ef1a.zip
databases/evolution-data-server: switch to C++11, required by ICU >= 59
In file included from e-alphabet-index-private.cpp:37: In file included from /usr/local/include/unicode/alphaindex.h:18: /usr/local/include/unicode/unistr.h:3025:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text)) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3087:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text), length) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3180:7: error: delegating constructors are permitted only in C++11 UnicodeString(Char16Ptr(buffer), buffLength, buffCapacity) {} ^~~~~~~~~~~~~ PR: 218788
Notes
Notes: svn path=/head/; revision=449621
Diffstat (limited to 'databases/evolution-data-server')
-rw-r--r--databases/evolution-data-server/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/evolution-data-server/Makefile b/databases/evolution-data-server/Makefile
index 8e3a2d020c80..f41078deea25 100644
--- a/databases/evolution-data-server/Makefile
+++ b/databases/evolution-data-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= evolution-data-server
PORTVERSION= 3.24.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -33,6 +33,7 @@ PORTSCOUT= limitw:1,even
USES= bdb:5 cmake compiler:c++11-lib gettext gnome gperf \
iconv localbase pathfix pkgconfig python:3.3+,build\
sqlite tar:xz
+USE_CXXSTD= gnu++11
USE_GNOME= cairo gdkpixbuf2 gtk30 intltool introspection:build libxml2
USE_LDCONFIG= yes