aboutsummaryrefslogtreecommitdiff
path: root/databases/fpc-mysql/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:56:21 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-04-12 21:56:21 +0000
commitab551f73077a2c729704e83189524dd0dea43c86 (patch)
treebd16464afd57ce590542d10785dad03b89d34ae0 /databases/fpc-mysql/Makefile
parent193e188899dfd165a858c91e797dfb930a40d2a9 (diff)
downloadports-ab551f73077a2c729704e83189524dd0dea43c86.tar.gz
ports-ab551f73077a2c729704e83189524dd0dea43c86.zip
Add fpc-mysql 1.0.10, Free Pascal interface to MySQL.
PR: 62621 Submitted by: John Merryweather Cooper Approved by: pav (mentor).
Notes
Notes: svn path=/head/; revision=106834
Diffstat (limited to 'databases/fpc-mysql/Makefile')
-rw-r--r--databases/fpc-mysql/Makefile77
1 files changed, 77 insertions, 0 deletions
diff --git a/databases/fpc-mysql/Makefile b/databases/fpc-mysql/Makefile
new file mode 100644
index 000000000000..da7d6ef4f351
--- /dev/null
+++ b/databases/fpc-mysql/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: Free Pascal mysql Unit
+# Date created: 9 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql
+PORTVERSION= 1.0.10
+CATEGORIES= databases lang
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal interface to MySQL
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= INSTDIR=lib/fpc/${PORTVERSION}/units/freebsd/mysql \
+ PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# mysql sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsmysqlsrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/mysql \
+ all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/mysql \
+ install
+
+.include <bsd.port.post.mk>