aboutsummaryrefslogtreecommitdiff
path: root/databases/fpc-oracle
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-26 14:57:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-26 14:57:34 +0000
commita3b8d42beedd38caf919241c41b5030d5452c60a (patch)
tree11ddaf73cdce1cc8aaecd715b895ae7954512714 /databases/fpc-oracle
parentd5ca487e793633c2184b9e1c249a7a71338bf71c (diff)
downloadports-a3b8d42beedd38caf919241c41b5030d5452c60a.tar.gz
ports-a3b8d42beedd38caf919241c41b5030d5452c60a.zip
Add fpc-oracle, a part of base packages of Free Pascal.
It provides interface to Oracle database. PR: ports/61114 Submitted by: John Merryweather Cooper <johnmary@adelphia.net>
Notes
Notes: svn path=/head/; revision=102196
Diffstat (limited to 'databases/fpc-oracle')
-rw-r--r--databases/fpc-oracle/Makefile81
-rw-r--r--databases/fpc-oracle/distinfo1
-rw-r--r--databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc10
-rw-r--r--databases/fpc-oracle/pkg-descr8
-rw-r--r--databases/fpc-oracle/pkg-plist3
5 files changed, 103 insertions, 0 deletions
diff --git a/databases/fpc-oracle/Makefile b/databases/fpc-oracle/Makefile
new file mode 100644
index 000000000000..977f3cbe812e
--- /dev/null
+++ b/databases/fpc-oracle/Makefile
@@ -0,0 +1,81 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 28 November 2001
+# Whom: John Merryweather Cooper et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= oracle
+PORTVERSION= 1.0.10
+CATEGORIES= databases lang
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal interface to PostGreSQL
+
+.include <bsd.port.pre.mk>
+
+ORACLE7_LIB= ${LOCALBASE}/oracle7/rdbms/lib
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
+ ${ORACLE7_LIB}/libnlsrtl3.a:${PORTSDIR}/databases/oracle7-client
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# postgres sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsoraclesrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+ ${REINPLACE_CMD} 's|/usr/local/oracle8cli/lib|${ORACLE7_LIB}|g' \
+ ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle/Makefile.fpc
+
+do-build:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle && \
+ ${GMAKE} ${MAKE_ENV} all
+
+do-install:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/oracle && \
+ ${GMAKE} ${MAKE_ENV} install
+
+.include <bsd.port.post.mk>
diff --git a/databases/fpc-oracle/distinfo b/databases/fpc-oracle/distinfo
new file mode 100644
index 000000000000..cdc32c64a7d3
--- /dev/null
+++ b/databases/fpc-oracle/distinfo
@@ -0,0 +1 @@
+MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
diff --git a/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc b/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc
new file mode 100644
index 000000000000..a2913d74f42f
--- /dev/null
+++ b/databases/fpc-oracle/files/patch-share::src::fpc-1.0.10::packages::base::oracle::Makefile.fpc
@@ -0,0 +1,10 @@
+--- share/src/fpc-1.0.10/packages/base/oracle/Makefile.fpc.bak Sun Apr 6 07:44:46 2003
++++ share/src/fpc-1.0.10/packages/base/oracle/Makefile.fpc Thu Jan 8 22:16:08 2004
+@@ -21,5 +21,5 @@
+
+ # in libdir variable must be path to libraries
+ # libclntsh.*,libnlsrtl3.*
+-#[compiler]
+-#libdir=/usr/local/oracle8cli/lib
++[compiler]
++libdir=/usr/local/oracle8cli/lib
diff --git a/databases/fpc-oracle/pkg-descr b/databases/fpc-oracle/pkg-descr
new file mode 100644
index 000000000000..b2339e674843
--- /dev/null
+++ b/databases/fpc-oracle/pkg-descr
@@ -0,0 +1,8 @@
+Oracle is part of the base packages of Free Pascal, a 32-bit
+Turbo Pascal/Delphi compatible compiler. Oracle provides an
+interface to Oracle databases.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/databases/fpc-oracle/pkg-plist b/databases/fpc-oracle/pkg-plist
new file mode 100644
index 000000000000..5f3c88c894d2
--- /dev/null
+++ b/databases/fpc-oracle/pkg-plist
@@ -0,0 +1,3 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/oracle/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/oracle/oraoci.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/oracle