aboutsummaryrefslogtreecommitdiff
path: root/databases/freetds-devel/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 16:24:00 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-05 16:24:00 +0000
commitf4f46a920e21b409b3f3b16873c6cef1eb4af378 (patch)
tree111c3e996440f35b3a05e66700954340c9919761 /databases/freetds-devel/Makefile
parent4007e179a6cb2c28428cd709099b5c1ff6b65402 (diff)
downloadports-f4f46a920e21b409b3f3b16873c6cef1eb4af378.tar.gz
ports-f4f46a920e21b409b3f3b16873c6cef1eb4af378.zip
Fix unixODBC vs libiodbc conflicts
Always rely on unixODBC each time a port is looking for libodbc.so Remove odbc compat from libiodbc This allows to install both kde and gnome at the same time While here: - Convert libiodbc to USES=libtool - Convert a bunch of libiodbc dependencies to USES=libtool - Chase libiodbc.so shlib change - Stagify some ports - Convert some ports to USES=pgsql Discussed with: rakuco (kde) With hat: portmgr
Notes
Notes: svn path=/head/; revision=353029
Diffstat (limited to 'databases/freetds-devel/Makefile')
-rw-r--r--databases/freetds-devel/Makefile30
1 files changed, 9 insertions, 21 deletions
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 6ea1733561c7..99b4f6458ae3 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= freetds
PORTVERSION= 0.92.79
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= databases
MASTER_SITES= ftp://ftp.freetds.org/pub/freetds/stable/
@@ -15,32 +16,32 @@ LICENSE= LGPL20
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
TDS_VER?= 5.0
-USES= gmake iconv pkgconfig
+USES= gmake iconv libtool:keepla pkgconfig
GNU_GONFIGURE= yes
-USE_AUTOTOOLS= autoconf:env libtool
+USE_AUTOTOOLS= autoconf:env
CPPFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tdsver=${TDS_VER}
USE_LDCONFIG= yes
SUB_FILES= pkg-message
+INSTALL_TARGET= install-strip
PORTDOCS= *
# OPTIONS_DEFINE= OPENSSL GNUTLS IODBC UNIXODBC MSDBLIB
-OPTIONS_DEFINE= MSDBLIB ODBCWIDE
+OPTIONS_DEFINE= MSDBLIB ODBCWIDE ODBC
-OPTIONS_SINGLE= ODBC SSL
-OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
+OPTIONS_SINGLE= SSL
OPTIONS_SINGLE_SSL= OPENSSL GNUTLS
-OPTIONS_DEFAULT= OPENSSL IODBC
+OPTIONS_DEFAULT= OPENSSL
OPENSSL_DESC= Use OpenSSL
GNUTLS_DESC= Use GnuTLS
-IODBC_DESC= Depend on iodbc
-UNIXODBC_DESC= Depend on unixodbc
MSDBLIB_DESC= MS SQL Server compatibility (breaks databases/sybtcl)
ODBCWIDE_DESC= Enable Wide ODBC Support
+ODBC_DESC= ODBC driver
CONFLICTS= freetds-0.64.[0-9]
@@ -60,21 +61,8 @@ LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --with-gnutls
.endif
-.if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
-CONFIGURE_ARGS+= --with-iodbc=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MUNIXODBC}
LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-unixodbc=${LOCALBASE}
-.endif
-
-.if ${PORT_OPTIONS:MIODBC} || ${PORT_OPTIONS:MUNIXODBC}
-PLIST_SUB+= ODBC=""
-.else
-PLIST_SUB+= ODBC="@comment "
-.endif
# We cannot use msdblib-style by default, because port databases/sybtcl
# relies on sybase-style dblib