aboutsummaryrefslogtreecommitdiff
path: root/databases/gigabase
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-05-14 18:30:38 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-05-14 18:30:38 +0000
commit9ba838979ec5425be3d880d863cfb3748bd43bf3 (patch)
treec9046e095368b7af663cc3bc82665acf930e5e8a /databases/gigabase
parent5862af14bd10225a1529017ddffc89ce1cae6c85 (diff)
downloadports-9ba838979ec5425be3d880d863cfb3748bd43bf3.tar.gz
ports-9ba838979ec5425be3d880d863cfb3748bd43bf3.zip
databases/gigabase: work around GCC >= 6 bustage
testtimeseries.cpp: In function 'float fmax(float, float)': testtimeseries.cpp:50:35: error: 'float fmax(float, float)' conflicts with a previous declaration inline float fmax(float x, float y) { return x > y ? x : y; } ^ In file included from /usr/local/lib/gcc6/include/c++/math.h:36:0, from testtimeseries.cpp:15: /usr/local/lib/gcc6/include/c++/cmath:1452:3: note: previous declaration 'constexpr float std::fmax(float, float)' fmax(float __x, float __y) ^~~~ testtimeseries.cpp: In function 'float fmin(float, float)': testtimeseries.cpp:51:35: error: 'float fmin(float, float)' conflicts with a previous declaration inline float fmin(float x, float y) { return x < y ? x : y; } ^ In file included from /usr/local/lib/gcc6/include/c++/math.h:36:0, from testtimeseries.cpp:15: /usr/local/lib/gcc6/include/c++/cmath:1472:3: note: previous declaration 'constexpr float std::fmin(float, float)' fmin(float __x, float __y) ^~~~ testtimeseries.cpp: In function 'int main(int, char**)': testtimeseries.cpp:69:54: error: call of overloaded 'fmax(float&, float&)' is ambiguous quote.high = fmax(quote.open, quote.close); ^ In file included from /usr/local/lib/gcc6/include/c++/cmath:45:0, from /usr/local/lib/gcc6/include/c++/math.h:36, from testtimeseries.cpp:15: /usr/include/math.h:309:8: note: candidate: double fmax(double, double) double fmax(double, double) __pure2; ^~~~ In file included from /usr/local/lib/gcc6/include/c++/math.h:36:0, from testtimeseries.cpp:15: /usr/local/lib/gcc6/include/c++/cmath:1463:5: note: candidate: constexpr typename __gnu_cxx::__promote_2<_Tp, _Up>::__type std::fmax(_Tp, _Up) [with _Tp = float; _Up = float; typename __gnu_cxx::__promote_2<_Tp, _Up>::__type = float] fmax(_Tp __x, _Up __y) ^~~~ /usr/local/lib/gcc6/include/c++/cmath:1456:3: note: candidate: constexpr long double std::fmax(long double, long double) fmax(long double __x, long double __y) ^~~~ /usr/local/lib/gcc6/include/c++/cmath:1452:3: note: candidate: constexpr float std::fmax(float, float) fmax(float __x, float __y) ^~~~ testtimeseries.cpp:50:14: note: candidate: float fmax(float, float) inline float fmax(float x, float y) { return x > y ? x : y; } ^~~~ testtimeseries.cpp:70:53: error: call of overloaded 'fmin(float&, float&)' is ambiguous quote.low = fmin(quote.open, quote.close); ^ In file included from /usr/local/lib/gcc6/include/c++/cmath:45:0, from /usr/local/lib/gcc6/include/c++/math.h:36, from testtimeseries.cpp:15: /usr/include/math.h:310:8: note: candidate: double fmin(double, double) double fmin(double, double) __pure2; ^~~~ In file included from /usr/local/lib/gcc6/include/c++/math.h:36:0, from testtimeseries.cpp:15: /usr/local/lib/gcc6/include/c++/cmath:1483:5: note: candidate: constexpr typename __gnu_cxx::__promote_2<_Tp, _Up>::__type std::fmin(_Tp, _Up) [with _Tp = float; _Up = float; typename __gnu_cxx::__promote_2<_Tp, _Up>::__type = float] fmin(_Tp __x, _Up __y) ^~~~ /usr/local/lib/gcc6/include/c++/cmath:1476:3: note: candidate: constexpr long double std::fmin(long double, long double) fmin(long double __x, long double __y) ^~~~ /usr/local/lib/gcc6/include/c++/cmath:1472:3: note: candidate: constexpr float std::fmin(float, float) fmin(float __x, float __y) ^~~~ testtimeseries.cpp:51:14: note: candidate: float fmin(float, float) inline float fmin(float x, float y) { return x < y ? x : y; } ^~~~ PR: 219275
Notes
Notes: svn path=/head/; revision=440885
Diffstat (limited to 'databases/gigabase')
-rw-r--r--databases/gigabase/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index 283df76da905..e4d8c520a45c 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -19,6 +19,7 @@ GNU_CONFIGURE= yes
USES= autoreconf dos2unix gmake libtool
DOS2UNIX_FILES= Makefile.in configure.in *.cpp *.h
USE_GCC= any
+USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
post-build: