aboutsummaryrefslogtreecommitdiff
path: root/databases/hs-hedis
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-11-10 22:09:03 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-11-10 22:09:03 +0000
commit816aa09f518c8e4398be602e88d69e41ead63f1c (patch)
tree6436c83198bbce77db29bffadd5d6352d801f627 /databases/hs-hedis
parentbc1fcafa419644c3e1d3c1e43d36231ae0a7064d (diff)
downloadports-816aa09f518c8e4398be602e88d69e41ead63f1c.tar.gz
ports-816aa09f518c8e4398be602e88d69e41ead63f1c.zip
- Add Haskell API and bindings for Redis:
devel/hs-BoundedChan Channels with bounded sizes devel/hs-bytestring-lexing Parse and produce literals from bytestrings databases/hs-hedis Haskell API for Redis PR: 194299 Submitted by: martin@sugioarto.com Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=372423
Diffstat (limited to 'databases/hs-hedis')
-rw-r--r--databases/hs-hedis/Makefile17
-rw-r--r--databases/hs-hedis/distinfo2
-rw-r--r--databases/hs-hedis/pkg-descr6
3 files changed, 25 insertions, 0 deletions
diff --git a/databases/hs-hedis/Makefile b/databases/hs-hedis/Makefile
new file mode 100644
index 000000000000..6916deda2f11
--- /dev/null
+++ b/databases/hs-hedis/Makefile
@@ -0,0 +1,17 @@
+# Created by: martin@sugioarto.com
+# $FreeBSD$
+
+PORTNAME= hedis
+PORTVERSION= 0.6.5
+CATEGORIES= databases haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell API for Redis
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= attoparsec>=0.10 BoundedChan>=1.0 bytestring-lexing>=0.4 \
+ mtl>=2.0 network>=2.0 resource-pool>=0.2 vector>=0.9
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/databases/hs-hedis/distinfo b/databases/hs-hedis/distinfo
new file mode 100644
index 000000000000..24cfdf9b3253
--- /dev/null
+++ b/databases/hs-hedis/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/hedis-0.6.5.tar.gz) = 70fa3843b3d52203b831ec13bf7f29273ee6fd4695f8cbe55d41d7ee1389c8ce
+SIZE (cabal/hedis-0.6.5.tar.gz) = 27113
diff --git a/databases/hs-hedis/pkg-descr b/databases/hs-hedis/pkg-descr
new file mode 100644
index 000000000000..a6a74e2854c5
--- /dev/null
+++ b/databases/hs-hedis/pkg-descr
@@ -0,0 +1,6 @@
+Redis is an open source, advanced key-value store. It is often referred to
+as a data structure server since keys can contain strings, hashes, lists,
+sets and sorted sets. This library is a Haskell client for the Redis
+datastore.
+
+WWW: https://github.com/informatikr/hedis