aboutsummaryrefslogtreecommitdiff
path: root/databases/jdb
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-23 23:02:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-23 23:02:26 +0000
commitb741c8cfa43f05f8ed0d344978b04f4e8d7c13ac (patch)
treea6de8df217971e921fa7fd719c97e03071ce724f /databases/jdb
parent3c0597d32adf7155747dffe0d48e15f795b91917 (diff)
downloadports-b741c8cfa43f05f8ed0d344978b04f4e8d7c13ac.tar.gz
ports-b741c8cfa43f05f8ed0d344978b04f4e8d7c13ac.zip
Update port: databases/jdb bugfixes for perl-5.8
PR: ports/48219 Submitted by: Lars Eggert <larse@isi.edu>
Notes
Notes: svn path=/head/; revision=76327
Diffstat (limited to 'databases/jdb')
-rw-r--r--databases/jdb/Makefile1
-rw-r--r--databases/jdb/files/patch-aa11
-rw-r--r--databases/jdb/files/patch-ab91
3 files changed, 103 insertions, 0 deletions
diff --git a/databases/jdb/Makefile b/databases/jdb/Makefile
index ecb7930bc5de..37bf74bbda35 100644
--- a/databases/jdb/Makefile
+++ b/databases/jdb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jdb
PORTVERSION= 1.12
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= http://www.isi.edu/~johnh/SOFTWARE/JDB/
diff --git a/databases/jdb/files/patch-aa b/databases/jdb/files/patch-aa
new file mode 100644
index 000000000000..d198e4c4de92
--- /dev/null
+++ b/databases/jdb/files/patch-aa
@@ -0,0 +1,11 @@
+--- d Wed Feb 12 15:33:25 2003
++++ dblib.pl Wed Feb 12 15:33:39 2003
+@@ -330,7 +330,7 @@
+
+ sub force_numeric {
+ my($value, $ignore_non_numeric) = @_;
+- if ($value =~ /^[-+]?[0-9]+(.[0-9]+)?(e[-+0-9]+)?$/) {
++ if ($value =~ /^\s*[-+]?[0-9]+(.[0-9]+)?(e[-+0-9]+)?\s*$/) {
+ return $value + 0.0; # force numeric
+ } else {
+ if ($ignore_non_numeric) {
diff --git a/databases/jdb/files/patch-ab b/databases/jdb/files/patch-ab
new file mode 100644
index 000000000000..ac5551e1ecc2
--- /dev/null
+++ b/databases/jdb/files/patch-ab
@@ -0,0 +1,91 @@
+--- dbcolmultiscale.O Wed Feb 12 15:15:35 2003
++++ dbcolmultiscale Wed Feb 12 15:15:50 2003
+@@ -127,7 +127,6 @@
+ push(@INC, $dblibdir);
+ }
+ use DbGetopt;
+-use FileCache;
+ require "$dblibdir/dblib.pl";
+
+ @orig_argv = @ARGV;
+--- dbmultistats.O Wed Feb 12 15:08:07 2003
++++ dbmultistats Wed Feb 12 15:09:28 2003
+@@ -57,7 +57,6 @@
+ push(@INC, $dblibdir);
+ }
+ use DbGetopt;
+-use FileCache;
+ require "$dblibdir/dblib.pl";
+
+ @orig_argv = @ARGV;
+@@ -112,13 +111,13 @@
+ # open a new file
+ $path = $tag_files{$tag} = &db_tmpfile(TMP);
+ close(TMP);
+- cacheout $path;
+- print $path "$col_headertag data\n";
++ open PATH, ">>$path";
++ print PATH "$col_headertag data\n";
+ $tag_counts{$tag} = 1;
+ };
+ $path = $tag_files{$tag};
+- cacheout $path;
+- print $path "$val\n";
++ open PATH, ">>$path";
++ print PATH "$val\n";
+ };
+
+ @dbstats_args = ("$dbbindir/dbstats");
+@@ -131,8 +130,7 @@
+ foreach $tag (sort keys %tag_files) {
+ # close it
+ $path = $tag_files{$tag};
+- cacheout $path;
+- close($path);
++ close(PATH);
+
+ open(FROMMEAN, join(" ", @dbstats_args) . " <$tag_files{$tag} |") || die "$prog: cannot run dbstats.\n";
+ @meanout = <FROMMEAN>;
+--- dbrowsplituniq.O Wed Feb 12 15:10:08 2003
++++ dbrowsplituniq Wed Feb 12 15:14:43 2003
+@@ -77,7 +77,6 @@
+ require "$dblibdir/dblib.pl";
+ use DbGetopt;
+ use English;
+-use FileCache;
+
+ @orig_argv = @ARGV;
+ my($prog) = &progname;
+@@ -130,8 +129,8 @@
+ my($path) = $prefix . $index . ".jdb";
+ $index++;
+ $keys_to_paths{$key} = $path;
+- cacheout $path;
+- write_header_fh_tag($path, $col_headertag);
++ open $fh, ">>$path";
++ write_header_fh_tag($fh, $col_headertag);
+ return $path;
+ }
+
+@@ -141,15 +140,15 @@
+ &split_cols;
+ ] . $code . q[
+ my($path) = &key_to_path($key);
+- cacheout $path;
+- write_these_cols_fh($path, @f);
++ open $fh, ">>$path";
++ write_these_cols_fh($fh, @f);
+ };
+ # cleanup
+ foreach (values %keys_to_paths) {
+- cacheout $_;
+- delayed_write_comments($_);
+- print $_ "# | $prog ", join(" ", @orig_argv), "\n";
+- close $_;
++ open $fh, ">>$_";
++ delayed_write_comments($fh);
++ print $fh "# | $prog ", join(" ", @orig_argv), "\n";
++ close $fh;
+ };
+ ];
+ print $loop if ($debug);