aboutsummaryrefslogtreecommitdiff
path: root/databases/kbibtex/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-07 13:32:25 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-07 13:32:25 +0000
commitb05f3ff1aca4a3c49313864145ed0c1301425d36 (patch)
tree0da8c0d2c403dbbd575cbf58e9918b813b01ef40 /databases/kbibtex/Makefile
parente829e9b49f8776200c4952d69b5a2912ad177e2f (diff)
downloadports-b05f3ff1aca4a3c49313864145ed0c1301425d36.tar.gz
ports-b05f3ff1aca4a3c49313864145ed0c1301425d36.zip
databases/kbibtex: update to 0.8.1 and switch to Qt5
- An upcoming release of poppler will drop support for Qt4. Prepare this port by switching to Qt5 already.
Notes
Notes: svn path=/head/; revision=481445
Diffstat (limited to 'databases/kbibtex/Makefile')
-rw-r--r--databases/kbibtex/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index cb511a0e5490..9fba4bea1f64 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -2,23 +2,29 @@
# $FreeBSD$
PORTNAME= kbibtex
-DISTVERSION= 0.6.2
-PORTREVISION= 4
+DISTVERSION= 0.8.1
CATEGORIES= databases kde
-MASTER_SITES= http://download.gna.org/${PORTNAME}/${PORTVERSION:R}/
+MASTER_SITES= KDE/stable/KBibTeX/${DISTVERSION}/
MAINTAINER= kde@FreeBSD.org
COMMENT= Bibliography editor for KDE
-LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4 \
- libqca.so:devel/qca@qt4 \
- libqoauth.so:net/qoauth
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libqca-qt5.so:devel/qca@qt5 \
+ libpoppler.so:graphics/poppler \
+ libpoppler-qt5.so:graphics/poppler-qt5 \
+ libqoauth-qt5.so:net/qoauth-qt5
-USES= cmake gettext iconv kde:4 qt:4 shared-mime-info tar:xz
+USES= cmake desktop-file-utils gettext iconv kde:5 qt:5 \
+ shared-mime-info tar:xz
USE_GNOME= libxml2 libxslt
-USE_KDE= kdelibs automoc4
-USE_QT= qmake_build moc_build uic_build rcc_build \
- webkit
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons crash ecm i18n iconthemes itemviews jobwidgets \
+ kio parts service solid sonnet textwidgets wallet \
+ widgetsaddons xmlgui
+USE_QT= concurrent core dbus gui location network printsupport qml \
+ quick webchannel webengine widgets xml xmlpatterns \
+ buildtools_build qmake_build
USE_LDCONFIG= yes
.include <bsd.port.mk>