aboutsummaryrefslogtreecommitdiff
path: root/databases/kyototycoon
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-01 07:24:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-01 07:24:16 +0000
commit2ec75b05a46675e49cb1b910eabdc03c0ab45771 (patch)
tree356c9aecb46291c387724af5531218bca03e9972 /databases/kyototycoon
parent49a375037a218aa6f91e0387e436c2bb3da74987 (diff)
downloadports-2ec75b05a46675e49cb1b910eabdc03c0ab45771.tar.gz
ports-2ec75b05a46675e49cb1b910eabdc03c0ab45771.zip
- Use BINMODE and DOCMODE
- Simplify Makefile
Notes
Notes: svn path=/head/; revision=346599
Diffstat (limited to 'databases/kyototycoon')
-rw-r--r--databases/kyototycoon/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
index 7a08213fe2d6..c408479780af 100644
--- a/databases/kyototycoon/Makefile
+++ b/databases/kyototycoon/Makefile
@@ -25,13 +25,8 @@ REINPLACE_ARGS= -i ''
USE_LDCONFIG= yes
USES= gmake pkgconfig
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|-pthread|g; s|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile
-.if !${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/DOCDIR/d' ${WRKSRC}/Makefile.in
-.endif
post-build:
@cd ${WRKSRC}/ && ${STRIP_CMD} ktplugdbvoid.so ktplugservmemc.so \
@@ -39,12 +34,10 @@ post-build:
ktutilmgr ktutilserv ktutiltest
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${FIND} ${STAGEDIR}${DOCSDIR}/ -type d -exec ${CHMOD} 755 '{}' \;
- ${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} 444 '{}' \;
-.endif
+ ${FIND} ${STAGEDIR}${DOCSDIR}/ -type d -exec ${CHMOD} ${BINMODE} '{}' \;
+ ${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${DOCMODE} '{}' \;
regression-test test: build
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>