aboutsummaryrefslogtreecommitdiff
path: root/databases/kyototycoon
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-18 16:14:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-18 16:14:03 +0000
commitc1483697ef07c3634007bd848dda1864222a4fcb (patch)
treed3106c40aa48045d360d842c80318a98fa9862eb /databases/kyototycoon
parent70a73aa61d502ec165671b9bdaadb59d3d62d94b (diff)
downloadports-c1483697ef07c3634007bd848dda1864222a4fcb.tar.gz
ports-c1483697ef07c3634007bd848dda1864222a4fcb.zip
- Strip binary executable and shared library in post-install: phase
Notes
Notes: svn path=/head/; revision=348575
Diffstat (limited to 'databases/kyototycoon')
-rw-r--r--databases/kyototycoon/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
index c408479780af..f072fdc9a88e 100644
--- a/databases/kyototycoon/Makefile
+++ b/databases/kyototycoon/Makefile
@@ -28,16 +28,12 @@ USES= gmake pkgconfig
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|-pthread|g; s|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile
-post-build:
- @cd ${WRKSRC}/ && ${STRIP_CMD} ktplugdbvoid.so ktplugservmemc.so \
- ktremotemgr ktremotetest ktserver kttimedmgr kttimedtest \
- ktutilmgr ktutilserv ktutiltest
-
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libkyototycoon.so.2.19.0 ${STAGEDIR}${PREFIX}/libexec/*.so
${FIND} ${STAGEDIR}${DOCSDIR}/ -type d -exec ${CHMOD} ${BINMODE} '{}' \;
${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${DOCMODE} '{}' \;
regression-test test: build
- cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} check
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check
.include <bsd.port.mk>