aboutsummaryrefslogtreecommitdiff
path: root/databases/ldb12
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2018-02-20 23:17:49 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2018-02-20 23:17:49 +0000
commitf8a1071d968bbfc7993ae758df93f6a326ef77d6 (patch)
tree2fabf740e561c19f0117481a1e3f78a32d90d928 /databases/ldb12
parente5a42a8c3c099681d4041c42d0e3e9888a69950e (diff)
downloadports-f8a1071d968bbfc7993ae758df93f6a326ef77d6.tar.gz
ports-f8a1071d968bbfc7993ae758df93f6a326ef77d6.zip
Update supplimentary Samba libs to the latest versions.
Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=462465
Diffstat (limited to 'databases/ldb12')
-rw-r--r--databases/ldb12/Makefile15
-rw-r--r--databases/ldb12/files/patch-buildtools__wafsamba__samba_autoconf.py43
-rw-r--r--databases/ldb12/files/patch-buildtools__wafsamba__samba_python.py14
-rw-r--r--databases/ldb12/files/patch-buildtools__wafsamba__wscript22
-rw-r--r--databases/ldb12/files/patch-common__ldb_modules.c11
5 files changed, 94 insertions, 11 deletions
diff --git a/databases/ldb12/Makefile b/databases/ldb12/Makefile
index 32e2d91b8b0e..ccb1a4027dd6 100644
--- a/databases/ldb12/Makefile
+++ b/databases/ldb12/Makefile
@@ -19,12 +19,17 @@ BUILD_DEPENDS= ${LDB_DEPENDS}
RUN_DEPENDS= ${LDB_DEPENDS}
LDB_DEPENDS= talloc>=2.1.10:devel/talloc \
- tevent>=0.9.33:devel/tevent \
+ tevent>=0.9.34:devel/tevent \
tdb>=1.3.15:databases/tdb \
cmocka>=1.1.1:sysutils/cmocka \
popt>=0:devel/popt
-CONFLICTS= ldb-1.1.* ldb13-1.3.*
+CONFLICTS_INSTALL= ldb-1.1.* ldb13-1.3.*
+
+#FLAVORS= default nopython
+#nopython_PKGNAMESUFFIX= -nopython
+#nopython_CONFLICTS= ldb
+#default_CONFLICTS= ldb-nopython
USES= compiler pkgconfig waf
USE_LDCONFIG= yes
@@ -40,7 +45,7 @@ CONFIGURE_ARGS+= --bundled-libraries=!talloc,!tevent,!tdb,!popt,!cmocka \
--with-privatelibdir=${PREFIX}/lib/ldb
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
- --infodir=${PREFIX}/${INFO_PATH}/${INFO_SUBDIR} \
+ --with-openldap=${LOCALBASE} \
--disable-rpath \
--without-gettext
@@ -113,7 +118,7 @@ PLIST_SUB+= SAMBA4_PYTHON3_SO_ABI=${SAMBA4_PYTHON3_SO_ABI} \
PLIST_FILES+= lib/libpyldb-util.%%SAMBA4_PYTHON3_SO_ABI%%.so \
lib/libpyldb-util.%%SAMBA4_PYTHON3_SO_ABI%%.so.1 \
- %%SAMBA4_PYTHON3_SITELIBDIR%%/ldb.so \
+ %%SAMBA4_PYTHON3_SITELIBDIR%%/ldb.%%SAMBA4_PYTHON3_SO_ABI%%.so \
%%SAMBA4_PYTHON3_SITELIBDIR%%/_ldb_text.py \
%%PKGCONFIGDIR%%/pyldb-util.%%SAMBA4_PYTHON3_SO_ABI%%.pc
.endif
@@ -173,7 +178,7 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ldb.so
.if defined(SAMBA4_PYTHON3)
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpyldb-util.${SAMBA4_PYTHON3_SO_ABI}.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SAMBA4_PYTHON3_SITELIBDIR}/ldb.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SAMBA4_PYTHON3_SITELIBDIR}/ldb.${SAMBA4_PYTHON3_SO_ABI}.so
.endif
.endif
diff --git a/databases/ldb12/files/patch-buildtools__wafsamba__samba_autoconf.py b/databases/ldb12/files/patch-buildtools__wafsamba__samba_autoconf.py
index 5245d0e4857b..c92d308462be 100644
--- a/databases/ldb12/files/patch-buildtools__wafsamba__samba_autoconf.py
+++ b/databases/ldb12/files/patch-buildtools__wafsamba__samba_autoconf.py
@@ -1,6 +1,47 @@
--- buildtools/wafsamba/samba_autoconf.py.orig 2016-10-07 04:45:35 UTC
+++ buildtools/wafsamba/samba_autoconf.py
-@@ -873,7 +873,7 @@ def SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS(c
+@@ -548,7 +548,7 @@ def library_flags(self, libs):
+
+
+ @conf
+-def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False):
++def CHECK_LIB(conf, libs, mandatory=False, empty_decl=True, set_target=True, shlib=False, msg=None):
+ '''check if a set of libraries exist as system libraries
+
+ returns the sublist of libs that do exist as a syslib or []
+@@ -568,11 +568,29 @@ int foo()
+ ret.append(lib)
+ continue
+
++ if msg is None:
++ msg = 'Checking for library %s' % lib
++
+ (ccflags, ldflags, cpppath) = library_flags(conf, lib)
++
+ if shlib:
+- res = conf.check(features='c cshlib', fragment=fragment, lib=lib, uselib_store=lib, ccflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
++ res = conf.check(features='c cshlib',
++ fragment=fragment,
++ lib=lib,
++ uselib_store=lib,
++ ccflags=ccflags,
++ ldflags=ldflags,
++ uselib=lib.upper(),
++ mandatory=False,
++ msg=msg)
+ else:
+- res = conf.check(lib=lib, uselib_store=lib, ccflags=ccflags, ldflags=ldflags, uselib=lib.upper(), mandatory=False)
++ res = conf.check(lib=lib,
++ uselib_store=lib,
++ ccflags=ccflags,
++ ldflags=ldflags,
++ uselib=lib.upper(),
++ mandatory=False,
++ msg=msg)
+
+ if not res:
+ if mandatory:
+@@ -873,7 +891,7 @@ def SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS(c
conf.env.undefined_ldflags = conf.ADD_LDFLAGS('-Wl,-no-undefined', testflags=True)
if not sys.platform.startswith("openbsd") and conf.env.undefined_ignore_ldflags == []:
diff --git a/databases/ldb12/files/patch-buildtools__wafsamba__samba_python.py b/databases/ldb12/files/patch-buildtools__wafsamba__samba_python.py
index dcea3ffd78c3..429ec5e778f9 100644
--- a/databases/ldb12/files/patch-buildtools__wafsamba__samba_python.py
+++ b/databases/ldb12/files/patch-buildtools__wafsamba__samba_python.py
@@ -1,6 +1,6 @@
---- buildtools/wafsamba/samba_python.py.orig 2017-04-28 08:57:26 UTC
+--- buildtools/wafsamba/samba_python.py.orig 2018-01-13 09:07:51 UTC
+++ buildtools/wafsamba/samba_python.py
-@@ -76,17 +76,31 @@ def SAMBA_CHECK_PYTHON_HEADERS(conf, man
+@@ -76,17 +76,35 @@ def SAMBA_CHECK_PYTHON_HEADERS(conf, man
def _check_python_headers(conf, mandatory):
try:
@@ -19,12 +19,16 @@
if conf.env['PYTHON_VERSION'] > '3':
- abi_pattern = os.path.splitext(conf.env['pyext_PATTERN'])[0]
- conf.env['PYTHON_SO_ABI_FLAG'] = abi_pattern % ''
-+ override_PYTHON3_SO_ABI_FLAG = os.getenv('PYTHON3_SO_ABI_FLAG', None)
-+ if override_PYTHON3_SO_ABI_FLAG is not None:
-+ conf.env['PYTHON_SO_ABI_FLAG'] = override_PYTHON3_SO_ABI_FLAG
++ '''Be caucious here - conf parameter is PYTHON_SO_ABI_FLAG,
++ while environment variable is PYTHON3_SO_ABI_FLAG'''
++ override_PYTHON_SO_ABI_FLAG = os.getenv('PYTHON3_SO_ABI_FLAG', None)
++ if override_PYTHON_SO_ABI_FLAG is not None:
++ conf.env['PYTHON_SO_ABI_FLAG'] = override_PYTHON_SO_ABI_FLAG
++ conf.env['pyext_PATTERN'] = '%%s%s.%s' % (conf.env['PYTHON_SO_ABI_FLAG'], conf.env['SHLIBEXT'])
+ if not conf.env['PYTHON_SO_ABI_FLAG']:
+ if conf.env['PYTHON_SO_ABI']:
+ conf.env['PYTHON_SO_ABI_FLAG'] = '.'+conf.env['PYTHON_SO_ABI']
++ conf.env['pyext_PATTERN'] = '%%s%s.%s' % (conf.env['PYTHON_SO_ABI_FLAG'], conf.env['SHLIBEXT'])
+ else:
+ abi_pattern = os.path.splitext(conf.env['pyext_PATTERN'])[0]
+ conf.env['PYTHON_SO_ABI_FLAG'] = abi_pattern % ''
diff --git a/databases/ldb12/files/patch-buildtools__wafsamba__wscript b/databases/ldb12/files/patch-buildtools__wafsamba__wscript
new file mode 100644
index 000000000000..9327600e7bd2
--- /dev/null
+++ b/databases/ldb12/files/patch-buildtools__wafsamba__wscript
@@ -0,0 +1,22 @@
+--- buildtools/wafsamba/wscript.orig 2017-04-28 11:57:26 UTC
++++ buildtools/wafsamba/wscript
+@@ -74,12 +74,17 @@ def set_options(opt):
+ help=("private library directory [PREFIX/lib/%s]" % Utils.g_module.APPNAME),
+ action="store", dest='PRIVATELIBDIR', default=None)
+
++ opt.add_option('--with-openldap',
++ help='additional directory to search for OpenLDAP libs',
++ action='store', dest='ldap_open', default=None,
++ match = ['Checking for library lber', 'Checking for library ldap'])
++
+ opt.add_option('--with-libiconv',
+ help='additional directory to search for libiconv',
+- action='store', dest='iconv_open', default='/usr/local',
++ action='store', dest='iconv_open', default=None,
+ match = ['Checking for library iconv', 'Checking for iconv_open', 'Checking for header iconv.h'])
+ opt.add_option('--without-gettext',
+- help=("Disable use of gettext"),
++ help=("disable use of gettext"),
+ action="store_true", dest='disable_gettext', default=False)
+
+ gr = opt.option_group('developer options')
diff --git a/databases/ldb12/files/patch-common__ldb_modules.c b/databases/ldb12/files/patch-common__ldb_modules.c
new file mode 100644
index 000000000000..ed26d1c55c9e
--- /dev/null
+++ b/databases/ldb12/files/patch-common__ldb_modules.c
@@ -0,0 +1,11 @@
+--- common/ldb_modules.c.orig 2018-02-14 01:18:43 UTC
++++ common/ldb_modules.c
+@@ -1103,7 +1103,7 @@ static int ldb_modules_load_dir(const ch
+ */
+ void ldb_set_modules_dir(struct ldb_context *ldb, const char *path)
+ {
+- int ret = ldb_modules_load_path(path, LDB_VERSION);
++ int ret = ldb_modules_load_dir(path, LDB_VERSION);
+ if (ret != LDB_SUCCESS) {
+ ldb_asprintf_errstring(ldb, "Failed to load modules from: %s\n", path);
+ }