aboutsummaryrefslogtreecommitdiff
path: root/databases/libgda3-mysql
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 04:22:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 04:22:10 +0000
commit8b4fe8856a0ef7bc1fe3329dcd6069695d1d0535 (patch)
tree049b5f95ee4780a8a398cf6727e2feeb10a59319 /databases/libgda3-mysql
parent631cf84c537e9f4fec86792bcd797f5543409c5d (diff)
downloadports-8b4fe8856a0ef7bc1fe3329dcd6069695d1d0535.tar.gz
ports-8b4fe8856a0ef7bc1fe3329dcd6069695d1d0535.zip
Update libgda3 to 3.0.2, and split out the various database backends as
slave ports. Submitted by: kwm
Notes
Notes: svn path=/head/; revision=209659
Diffstat (limited to 'databases/libgda3-mysql')
-rw-r--r--databases/libgda3-mysql/Makefile23
-rw-r--r--databases/libgda3-mysql/pkg-plist14
2 files changed, 37 insertions, 0 deletions
diff --git a/databases/libgda3-mysql/Makefile b/databases/libgda3-mysql/Makefile
new file mode 100644
index 000000000000..ad05df8abdb2
--- /dev/null
+++ b/databases/libgda3-mysql/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libgda2
+# Date created: 02 June 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/databases/libgda3-mysql/Makefile,v 1.2 2008/02/26 21:23:35 kwm Exp $
+#
+
+PORTREVISION?= 0
+CATEGORIES= databases gnome
+PKGNAMESUFFIX?= -mysql
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Provides mysql backend for the libgda3 library
+
+MASTERDIR= ${.CURDIR}/../libgda3
+BUILD_WRKSRC= ${WRKSRC}/providers/postgres/
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PLIST= ${.CURDIR}/pkg-plist
+
+LIBGDA3_SLAVE= mysql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/libgda3-mysql/pkg-plist b/databases/libgda3-mysql/pkg-plist
new file mode 100644
index 000000000000..de93385653ba
--- /dev/null
+++ b/databases/libgda3-mysql/pkg-plist
@@ -0,0 +1,14 @@
+lib/libgda-%%VERSION%%/providers/libgda-mysql.a
+lib/libgda-%%VERSION%%/providers/libgda-mysql.la
+lib/libgda-%%VERSION%%/providers/libgda-mysql.so
+libdata/pkgconfig/libgda-mysql-%%VERSION%%.pc
+share/libgda-%%VERSION%%/mysql_specs_add_column.xml
+share/libgda-%%VERSION%%/mysql_specs_create_db.xml
+share/libgda-%%VERSION%%/mysql_specs_create_index.xml
+share/libgda-%%VERSION%%/mysql_specs_create_table.xml
+share/libgda-%%VERSION%%/mysql_specs_drop_column.xml
+share/libgda-%%VERSION%%/mysql_specs_drop_db.xml
+share/libgda-%%VERSION%%/mysql_specs_drop_index.xml
+share/libgda-%%VERSION%%/mysql_specs_drop_table.xml
+share/libgda-%%VERSION%%/mysql_specs_dsn.xml
+share/libgda-%%VERSION%%/mysql_specs_rename_table.xml