aboutsummaryrefslogtreecommitdiff
path: root/databases/libgdamm/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-04-22 05:41:26 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-04-22 05:41:26 +0000
commit22b9c80eab348e6ca6fa91b0d137c371753e17a2 (patch)
treec5c2bb1e22f14cdfbcc07fa66e4aad4a1e84b794 /databases/libgdamm/Makefile
parent96c78cdd40f8e0423c8d7e86fa243a64a75c0c93 (diff)
downloadports-22b9c80eab348e6ca6fa91b0d137c371753e17a2.tar.gz
ports-22b9c80eab348e6ca6fa91b0d137c371753e17a2.zip
Fix build failure triggered by pkgconfig update.
Notes
Notes: svn path=/head/; revision=133910
Diffstat (limited to 'databases/libgdamm/Makefile')
-rw-r--r--databases/libgdamm/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
index 756f6fae7c2a..8dbde0ba72bc 100644
--- a/databases/libgdamm/Makefile
+++ b/databases/libgdamm/Makefile
@@ -22,6 +22,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GCC= 3.4
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack libgda2
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
@@ -36,4 +37,8 @@ patch-autotools:
${RM} $$file.tmp; \
done);
+post-patch:
+ @${REINPLACE_CMD} -e "s|\(-lglibmm\)|-L\$$(GMM_PROCDIR)/../.. \1|" \
+ ${WRKSRC}/tools/extra_defs_gen/Makefile.in
+
.include <bsd.port.mk>