aboutsummaryrefslogtreecommitdiff
path: root/databases/libiodbc
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-14 21:39:04 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-14 21:39:04 +0000
commit141d91e47f46a499199e56c31f7d233bdc49097c (patch)
treec55e51e70ba7a56898ef2c5b5c39b6a025d98e84 /databases/libiodbc
parent51bf375bfb1d26c4df5e37507893991c7e7a0e34 (diff)
downloadports-141d91e47f46a499199e56c31f7d233bdc49097c.tar.gz
ports-141d91e47f46a499199e56c31f7d233bdc49097c.zip
Update to 3.52.3
Add SHA256 PR: 89013 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=148282
Diffstat (limited to 'databases/libiodbc')
-rw-r--r--databases/libiodbc/Makefile14
-rw-r--r--databases/libiodbc/distinfo5
-rw-r--r--databases/libiodbc/files/patch-iodbc__unicode.c18
-rw-r--r--databases/libiodbc/pkg-plist2
4 files changed, 31 insertions, 8 deletions
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index 1e9dfec7dd8e..4a4cd8ef78a2 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -9,7 +9,7 @@
# databases/unixODBC.
PORTNAME= libiodbc
-PORTVERSION= 3.52.2
+PORTVERSION= 3.52.3
CATEGORIES= databases
MASTER_SITES= http://www.iodbc.org/downloads/iODBC/ \
${MASTER_SITE_SOURCEFORGE}
@@ -20,7 +20,7 @@ COMMENT= An ODBC 3.x driver manager, for universal data source access
CONFLICTS= unixODBC-*
-USE_GNOME= gnometarget
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -48,18 +48,20 @@ post-patch:
's|$$CFLAGS -pthread|$$CFLAGS|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s|samples||' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-ldl||g' ${WRKSRC}/admin/libiodbc.pc.in
post-install:
@${MKDIR} ${INIDIR}
${INSTALL_DATA} ${WRKSRC}/etc/odbc*.ini.sample ${INIDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog NEWS README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for f in AUTHORS ChangeLog NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
@${MKDIR} ${EXAMPLESDIR}
-.for file in Makefile iodbctest.c
- ${INSTALL_DATA} ${WRKSRC}/samples/${file} ${EXAMPLESDIR}
+.for f in Makefile iodbctest.c
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/databases/libiodbc/distinfo b/databases/libiodbc/distinfo
index b206aed23897..0d6eaa113fec 100644
--- a/databases/libiodbc/distinfo
+++ b/databases/libiodbc/distinfo
@@ -1,2 +1,3 @@
-MD5 (libiodbc-3.52.2.tar.gz) = bf767019d90db0bee10c7531d9b2053a
-SIZE (libiodbc-3.52.2.tar.gz) = 574405
+MD5 (libiodbc-3.52.3.tar.gz) = bdaca2c8b1c1b39bb3fa35ee66615373
+SHA256 (libiodbc-3.52.3.tar.gz) = 25697a711e9816b9ce33c8ab02fdee44644d85a62e620921da86215dc89482c8
+SIZE (libiodbc-3.52.3.tar.gz) = 720332
diff --git a/databases/libiodbc/files/patch-iodbc__unicode.c b/databases/libiodbc/files/patch-iodbc__unicode.c
new file mode 100644
index 000000000000..58c4b2ec9951
--- /dev/null
+++ b/databases/libiodbc/files/patch-iodbc__unicode.c
@@ -0,0 +1,18 @@
+--- iodbc/unicode.c.orig Tue Aug 30 22:24:12 2005
++++ iodbc/unicode.c Thu Nov 10 13:35:19 2005
+@@ -192,6 +192,7 @@
+ #if !defined(HAVE_TOWLOWER)
+ #if (defined(__APPLE__) && !defined (_LP64)) || defined (macintosh)
+ #include <Carbon/Carbon.h>
++#endif
+ wchar_t towlower(wchar_t wc)
+ {
+ #ifdef __APPLE__
+@@ -213,7 +214,6 @@
+ return wc;
+ #endif
+ }
+-#endif
+ #endif
+
+ #if !defined(HAVE_WCSNCASECMP)
diff --git a/databases/libiodbc/pkg-plist b/databases/libiodbc/pkg-plist
index fd3a3410d650..1c9d8d6d21c4 100644
--- a/databases/libiodbc/pkg-plist
+++ b/databases/libiodbc/pkg-plist
@@ -8,6 +8,7 @@ include/iodbcunix.h
include/isql.h
include/isqlext.h
include/isqltypes.h
+include/odbcinst.h
include/sql.h
include/sqlext.h
include/sqltypes.h
@@ -30,6 +31,7 @@ lib/libiodbcinst.so
lib/libiodbcinst.so.3
lib/libodbc.a
lib/libodbc.so
+libdata/pkgconfig/libiodbc.pc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS