aboutsummaryrefslogtreecommitdiff
path: root/databases/libmemcached
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2017-06-09 16:45:34 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2017-06-09 16:45:34 +0000
commit58480d53f2737b57c6248171d2b65fff31f76c23 (patch)
tree3c87e6054d128c3e4c62060b7ad71043fc8a1ee0 /databases/libmemcached
parent0d68bec0b7ed26ee9ae8cbaed589d73cdbb85005 (diff)
downloadports-58480d53f2737b57c6248171d2b65fff31f76c23.tar.gz
ports-58480d53f2737b57c6248171d2b65fff31f76c23.zip
Fix the build of libmemcached: add -lthr to the libraries
plus modifications to the autoconf files. PR: 219168 Submitted by: m.tsatsenko@gmail.com (maintainer) Reported by: 000.fbsd@quip.cz Approved by: m.tsatsenko@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=443019
Diffstat (limited to 'databases/libmemcached')
-rw-r--r--databases/libmemcached/Makefile2
-rw-r--r--databases/libmemcached/files/patch-bug12455628
-rw-r--r--databases/libmemcached/files/patch-libmemcached_assert.hpp2
-rw-r--r--databases/libmemcached/files/patch-libtest_lite.h2
-rw-r--r--databases/libmemcached/files/patch-log.hpp10
-rw-r--r--databases/libmemcached/files/patch-m4_ax__debug.m4 (renamed from databases/libmemcached/files/patch-bug1400560)7
-rw-r--r--databases/libmemcached/files/patch-util_log.hpp10
7 files changed, 18 insertions, 23 deletions
diff --git a/databases/libmemcached/Makefile b/databases/libmemcached/Makefile
index 2721e5041cee..5e89b34a0437 100644
--- a/databases/libmemcached/Makefile
+++ b/databases/libmemcached/Makefile
@@ -23,7 +23,7 @@ CONFIGURE_ARGS= --without-memcached \
--without-sphinx-build \
--enable-libmemcachedprotocol
-LIBS+= -L${LOCALBASE}/lib -lexecinfo
+LIBS+= -L${LOCALBASE}/lib -lexecinfo -lthr
CXXFLAGS+= -D__STDC_CONSTANT_MACROS
OPTIONS_DEFINE= DEBUG DTRACE MEMASLAP SASL
diff --git a/databases/libmemcached/files/patch-bug1245562 b/databases/libmemcached/files/patch-bug1245562
index a0b146e5b72e..6c29b93886a5 100644
--- a/databases/libmemcached/files/patch-bug1245562
+++ b/databases/libmemcached/files/patch-bug1245562
@@ -1,6 +1,4 @@
-diff --git a/clients/memflush.cc b/clients/memflush.cc
-index 8bd0dbf..cdba743 100644
---- clients/memflush.cc
+--- clients/memflush.cc.orig 2014-02-09 11:52:42 UTC
+++ clients/memflush.cc
@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
{
@@ -20,9 +18,7 @@ index 8bd0dbf..cdba743 100644
{
std::cerr << "No Servers provided" << std::endl;
exit(EXIT_FAILURE);
-diff --git a/libmemcached-1.0/memcached.h b/libmemcached-1.0/memcached.h
-index bc16e73..dcee395 100644
---- libmemcached-1.0/memcached.h
+--- libmemcached-1.0/memcached.h.orig 2014-02-09 11:52:42 UTC
+++ libmemcached-1.0/memcached.h
@@ -43,7 +43,11 @@
#endif
diff --git a/databases/libmemcached/files/patch-libmemcached_assert.hpp b/databases/libmemcached/files/patch-libmemcached_assert.hpp
index 83a464c748e3..91c68e89a1cc 100644
--- a/databases/libmemcached/files/patch-libmemcached_assert.hpp
+++ b/databases/libmemcached/files/patch-libmemcached_assert.hpp
@@ -1,4 +1,4 @@
---- libmemcached/assert.hpp.orig 2014-12-10 05:16:11 UTC
+--- libmemcached/assert.hpp.orig 2014-02-09 11:52:42 UTC
+++ libmemcached/assert.hpp
@@ -51,8 +51,10 @@
# ifdef _WIN32
diff --git a/databases/libmemcached/files/patch-libtest_lite.h b/databases/libmemcached/files/patch-libtest_lite.h
index 01a2641c3ea1..c9cd4a3605e1 100644
--- a/databases/libmemcached/files/patch-libtest_lite.h
+++ b/databases/libmemcached/files/patch-libtest_lite.h
@@ -1,4 +1,4 @@
---- libtest/lite.h.orig 2014-12-09 03:34:21 UTC
+--- libtest/lite.h.orig 2014-02-09 11:52:42 UTC
+++ libtest/lite.h
@@ -54,8 +54,10 @@
#if defined(WIN32)
diff --git a/databases/libmemcached/files/patch-log.hpp b/databases/libmemcached/files/patch-log.hpp
deleted file mode 100644
index d39dd87d876b..000000000000
--- a/databases/libmemcached/files/patch-log.hpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- util/log.hpp.orig 2012-04-22 19:10:08.624721461 +0200
-+++ util/log.hpp 2012-04-22 19:11:43.651275813 +0200
-@@ -27,6 +27,7 @@
- #include <fcntl.h>
- #include <iostream>
- #include <string>
-+#include <string.h>
- #include <syslog.h>
-
- #define UTIL_MAX_ERROR_SIZE 2048
diff --git a/databases/libmemcached/files/patch-bug1400560 b/databases/libmemcached/files/patch-m4_ax__debug.m4
index 6dbab3180a3e..53a5aeceff9c 100644
--- a/databases/libmemcached/files/patch-bug1400560
+++ b/databases/libmemcached/files/patch-m4_ax__debug.m4
@@ -1,8 +1,7 @@
Fixed a bug that caused configure to disobey the enable/disable debug flag. The debug flag will default to disabled if not specified.
-diff -ru libmemcached-1.0.18-orig/m4/ax_debug.m4 libmemcached-1.0.18/m4/ax_debug.m4
---- m4/ax_debug.m4 2014-11-05 14:43:53.720284916 -0600
-+++ m4/ax_debug.m4 2014-11-19 14:23:19.512482198 -0600
-@@ -49,16 +49,18 @@
+--- m4/ax_debug.m4.orig 2014-02-09 11:52:42 UTC
++++ m4/ax_debug.m4
+@@ -49,16 +49,18 @@ AC_DEFUN([AX_DEBUG],
[AC_PREREQ([2.63])dnl
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
diff --git a/databases/libmemcached/files/patch-util_log.hpp b/databases/libmemcached/files/patch-util_log.hpp
new file mode 100644
index 000000000000..5dd9f530971e
--- /dev/null
+++ b/databases/libmemcached/files/patch-util_log.hpp
@@ -0,0 +1,10 @@
+--- util/log.hpp.orig 2014-02-09 11:52:42 UTC
++++ util/log.hpp
+@@ -42,6 +42,7 @@
+ #include <fcntl.h>
+ #include <iostream>
+ #include <string>
++#include <string.h>
+ #include <syslog.h>
+
+ #define UTIL_MAX_ERROR_SIZE 2048