aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb32
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-02-10 14:32:11 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-02-10 14:32:11 +0000
commit1754dd912836c31e00c07630bc3ddcc5f827adf5 (patch)
tree418534d326fa3342968296ef7d6debdbb6b370ce /databases/mongodb32
parent274c13f1a6d02a207f35e88bb3768a3871f75ea9 (diff)
downloadports-1754dd912836c31e00c07630bc3ddcc5f827adf5.tar.gz
ports-1754dd912836c31e00c07630bc3ddcc5f827adf5.zip
databases/mongodb32{-tools}: Disable WIRETIGER on i386, Mark BROKEN on 9.x
MongoDB 3.2 doesn't build on FreeBSD 9.x, and its tools fail to build for a separate reason: TLS 1.1 and 1.2 are not found in the OpenSSL version that the builder detects. Fortunately, we don't have to solve that as the primary port does not support FreeBSD 9 either. Patched to IGNORE on < FreeBSD 10. PR: 206795, 206796 Submitted by: Brendan Molloy <brendan+freebsd bbqsrc net> (maintainer) MFH: 2016Q1
Notes
Notes: svn path=/head/; revision=408633
Diffstat (limited to 'databases/mongodb32')
-rw-r--r--databases/mongodb32/Makefile31
1 files changed, 26 insertions, 5 deletions
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index fa1307f92e4c..b3e28a9c07f5 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -4,6 +4,7 @@
PORTNAME= mongodb32
PORTVERSION= 3.2.1
DISTVERSIONPREFIX= r
+PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/ \
@@ -11,7 +12,7 @@ MASTER_SITES= https://fastdl.mongodb.org/src/ \
DISTNAME= mongodb-src-${DISTVERSIONPREFIX}${PORTVERSION}
MAINTAINER= brendan+freebsd@bbqsrc.net
-COMMENT= NOSQL distributed document-oriented database
+COMMENT= Distributed document-oriented "NoSQL" database
# mongodb is AGPLv3, C++ driver is APACHE20
LICENSE= AGPLv3 APACHE20
@@ -25,17 +26,26 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:${PORTSDIR}/devel/py-yaml \
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-OPTIONS_DEFINE= SASL SSL
-OPTIONS_DEFAULT=SSL
+OPTIONS_DEFINE= SASL SSL WIREDTIGER
+OPTIONS_DEFAULT= SSL WIREDTIGER
+
+# Only supported on 64-bit
+OPTIONS_EXCLUDE_i386= WIREDTIGER
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
-SASL_MAKE_ARGS= --use-sasl-client
+SASL_MAKE_ARGS= --use-sasl-client
SSL_USE= openssl=yes
SSL_MAKE_ARGS= --ssl
+WIREDTIGER_DESC= WiredTiger database engine support
+WIREDTIGER_VARS= wiredtiger_build=on
+WIREDTIGER_VARS_OFF= wiredtiger_build=off
+
USES= cpe execinfo python:build scons
+
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
+ --wiredtiger=${WIREDTIGER_BUILD} \
--use-system-pcre --use-system-snappy \
--release
@@ -47,6 +57,17 @@ USE_RC_SUBR= mongod
ALL_TARGET= core
TEST_TARGET= unittests
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+WIREDTIGER_BUILD= off
+.endif
+
+.if ${OSVERSION} < 1000000
+# Cannot be built
+IGNORE= unsupported on FreeBSD 9 or older
+.endif
+
post-install:
.for f in mongo mongod mongoperf mongos mongosniff
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
@@ -62,4 +83,4 @@ PORTSCOUT= limitw:1,even
CPE_PRODUCT= mongodb
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>