aboutsummaryrefslogtreecommitdiff
path: root/databases/mongodb50
diff options
context:
space:
mode:
authorRonald Klop <ronald-lists@klop.ws>2021-08-28 13:06:47 +0000
committerMikael Urankar <mikael@FreeBSD.org>2021-08-28 13:42:10 +0000
commit77c5529691824fc93c8e8fe203d020a84bcb3bca (patch)
tree101db077b229dbcc856525275217a00452863d62 /databases/mongodb50
parentd67dc22f7508cce82f712ff14c9f16011e494b70 (diff)
downloadports-77c5529691824fc93c8e8fe203d020a84bcb3bca.tar.gz
ports-77c5529691824fc93c8e8fe203d020a84bcb3bca.zip
databases/mongodb50: Fix build failure with scons 4.2.0 by using in source scons 3.1.2
- Fix scons by using in source scons 3.1.2 (They are planning to move to Scons 4.2.0 in the future) - Disable LTO on clang12/aarch64, bug #257765 - Build already installs in $STAGEDIR, so only strip in do-install. - Fix a portlint warnings about the comment at the LICENSE section. PR: 257925
Diffstat (limited to 'databases/mongodb50')
-rw-r--r--databases/mongodb50/Makefile15
-rw-r--r--databases/mongodb50/files/patch-buildscripts_scons.py25
2 files changed, 36 insertions, 4 deletions
diff --git a/databases/mongodb50/Makefile b/databases/mongodb50/Makefile
index bbf4ae522253..593808b7b8e3 100644
--- a/databases/mongodb50/Makefile
+++ b/databases/mongodb50/Makefile
@@ -10,8 +10,7 @@ DISTNAME= mongodb-src-${DISTVERSIONPREFIX}${DISTVERSION}
MAINTAINER= ronald-lists@klop.ws
COMMENT= Distributed document-oriented "NoSQL" database (5.0.x Branch)
-# mongodb is SSPLv1, C++ driver is APACHE20
-LICENSE= SSPLv1 APACHE20
+LICENSE= SSPLv1 APACHE20 # mongodb is SSPLv1, C++ driver is APACHE20
LICENSE_COMB= multi
LICENSE_NAME_SSPLv1= Server Side Public License Version 1
LICENSE_FILE_SSPLv1= ${WRKSRC}/LICENSE-Community.txt
@@ -28,13 +27,18 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libcurl.so:ftp/curl \
libsnappy.so:archivers/snappy
-USES= compiler:c++17-lang cpe python:3.5+,build scons
+USES= compiler:c++17-lang cpe python:3.5+,build scons shebangfix
USE_RC_SUBR= mongod
CONFLICTS_INSTALL= mongodb36 mongodb4[024]
OPTIONS_DEFINE= LTO SASL SSL
OPTIONS_DEFAULT=LTO SASL SSL
+OPTIONS_EXCLUDE_aarch64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
+OPTIONS_EXCLUDE_aarch64_14= LTO # Does not work with llvm12 on aarch64.
+
+SHEBANG_FILES= buildscripts/scons.py
+python_OLD_CMD= @python_interpreter@
MAKE_ARGS= --use-system-zlib \
--use-system-pcre \
@@ -79,9 +83,12 @@ CPE_PRODUCT= mongodb
pre-patch:
${MV} ${WRKSRC}/src/third_party/wiredtiger/src/checksum/power8/crc32.sx ${WRKSRC}/src/third_party/wiredtiger/src/checksum/power8/crc32.S
+do-build:
+ ${WRKSRC}/buildscripts/scons.py -C ${WRKSRC} ${MAKE_ARGS}
+
do-install:
.for f in mongo mongod mongos
- ${INSTALL_PROGRAM} ${WRKSRC}/build/install${PREFIX}/bin/${f} ${STAGEDIR}${PREFIX}/bin
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
${INSTALL_DATA} ${WRKSRC}/rpm/mongod.conf ${STAGEDIR}${PREFIX}/etc/mongodb.conf.sample
diff --git a/databases/mongodb50/files/patch-buildscripts_scons.py b/databases/mongodb50/files/patch-buildscripts_scons.py
new file mode 100644
index 000000000000..20d0429965af
--- /dev/null
+++ b/databases/mongodb50/files/patch-buildscripts_scons.py
@@ -0,0 +1,25 @@
+--- buildscripts/scons.py.orig 2021-08-23 09:10:10 UTC
++++ buildscripts/scons.py
+@@ -18,14 +18,14 @@ SITE_TOOLS_DIR = os.path.join(MONGODB_ROOT, 'site_scon
+
+ sys.path = [SCONS_DIR, SITE_TOOLS_DIR] + sys.path
+
+-# pylint: disable=C0413
+-from mongo.pip_requirements import verify_requirements, MissingRequirements
+-
+-try:
+- verify_requirements('etc/pip/compile-requirements.txt')
+-except MissingRequirements as ex:
+- print(ex)
+- sys.exit(1)
++## pylint: disable=C0413
++#from mongo.pip_requirements import verify_requirements, MissingRequirements
++#
++#try:
++# verify_requirements('etc/pip/compile-requirements.txt')
++#except MissingRequirements as ex:
++# print(ex)
++# sys.exit(1)
+
+ try:
+ import SCons.Script