aboutsummaryrefslogtreecommitdiff
path: root/databases/msql3
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-01-14 11:01:06 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-01-14 11:01:06 +0000
commit8127cfce921ec69662bef3f53968dbd4b741696f (patch)
treefe120ae818ec139c8843044932a6af1c37c5fb47 /databases/msql3
parent536becde89e6757f332aa6ad1716aeb6049aa7fa (diff)
downloadports-8127cfce921ec69662bef3f53968dbd4b741696f.tar.gz
ports-8127cfce921ec69662bef3f53968dbd4b741696f.zip
MSQL port from Michael Reifenberger.
Submitted by: mr
Notes
Notes: svn path=/head/; revision=771
Diffstat (limited to 'databases/msql3')
-rw-r--r--databases/msql3/Makefile17
-rw-r--r--databases/msql3/distinfo1
-rw-r--r--databases/msql3/files/patch-aa27
-rw-r--r--databases/msql3/pkg-comment1
-rw-r--r--databases/msql3/pkg-descr146
-rw-r--r--databases/msql3/pkg-plist21
6 files changed, 213 insertions, 0 deletions
diff --git a/databases/msql3/Makefile b/databases/msql3/Makefile
new file mode 100644
index 000000000000..fa575e140b34
--- /dev/null
+++ b/databases/msql3/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: msql
+# Version required: 1.0
+# Date created: ?
+# Whom: mr (original)
+#
+# $Id: Makefile,v 1.2 1995/01/07 11:01:38 asami Exp $
+#
+
+DISTNAME= msql-1.0
+EXTRACT_SUFX= .tar.gz
+MASTER_SITES= ftp://bond.edu.au:/pub/Minerva/msql
+#INSTALL_MANPAGES= YES
+IS_INTERACTIVE= YES
+PREFIX= /usr/local/Minerva
+
+.include <bsd.port.mk>
+
diff --git a/databases/msql3/distinfo b/databases/msql3/distinfo
new file mode 100644
index 000000000000..35e01596bf1b
--- /dev/null
+++ b/databases/msql3/distinfo
@@ -0,0 +1 @@
+MD5 (msql-1.0.tar.gz) = bcb80a68ef3113b669381698cad73bee
diff --git a/databases/msql3/files/patch-aa b/databases/msql3/files/patch-aa
new file mode 100644
index 000000000000..88315504e035
--- /dev/null
+++ b/databases/msql3/files/patch-aa
@@ -0,0 +1,27 @@
+*** Makefile.orig Thu Jan 12 21:18:36 1995
+--- Makefile Thu Jan 12 21:32:38 1995
+***************
+*** 20,24 ****
+ all:
+! @ echo ""; echo "You have not read the installation procedures.";\
+! echo "Please read the README file for build instructions.";\
+! echo
+
+--- 20,27 ----
+ all:
+! cd targets/freebsd ;\
+! make all
+!
+! install:
+! cd targets/freebsd ;\
+! make install
+
+***************
+*** 34,36 ****
+ echo ;\
+! TARG=`scripts/sys-arch` ;\
+ if test -d targets/$${TARG} ;\
+--- 37,39 ----
+ echo ;\
+! TARG=freebsd;\
+ if test -d targets/$${TARG} ;\
diff --git a/databases/msql3/pkg-comment b/databases/msql3/pkg-comment
new file mode 100644
index 000000000000..683ec06c53b7
--- /dev/null
+++ b/databases/msql3/pkg-comment
@@ -0,0 +1 @@
+msql version 1.0 - Mini SQL Database
diff --git a/databases/msql3/pkg-descr b/databases/msql3/pkg-descr
new file mode 100644
index 000000000000..95b1c50f767e
--- /dev/null
+++ b/databases/msql3/pkg-descr
@@ -0,0 +1,146 @@
+README for mSQL version 1.0 14 December 1994
+----------------------------------------------------------------------------
+
+
+What's new in 1.0
+-----------------
+
+1.0 is actually what was going to be 0.3-release. I decided to give it
+a "real" number because it has enough features and appears stable enough
+to be used seriously now (we're even using it in production at Bond
+hanging of the back of our WWW server and campus user database). 2
+months of alpha and beta testing has produced what appears to be a
+pretty solid hunk of code.
+
+1.0 brings per-database access control, joins, ordering, mmap() support
+if you have it (and it'll do shared read/write regions - unlike Linux, HPUX
+etc), distinct, and many bug fixes to mSQL. The doco has also been updated
+for for this release to reflect the changes to both the SQL supported
+and also the API and programs.
+
+
+msqladmin now offers a "shutdown" command and also a "reload" command
+for reloading the access control info on the fly. You can only run
+msqladmin as root (or whoever you specified as the root user) from the
+local machine. There's further info about the access control mechanism
+in the manual.
+
+msqladmin also offers a version command. This will report the version
+of msqladmin, the version of the server it's talking to, and the
+protocol version used to talk to the server.
+
+msql will use the VISUAL environment variable for your editor rather
+than forcing you to use vi. If it isn't set it'll default to vi anyway.
+
+A new program called msqldump is included to generate an ASCII dump of a
+table or an entire database. The output is formatted as an msql script
+and includes the "create table" and "insert" commands required to
+recreate whatever was dumped. It'll work over the net too so you can
+grab an entire database off a remote box.
+
+The MSQL_HOST environment variable has gone. All msql programs now
+offer a -h option for talking to a remote host. In the API, if
+msqlConnect() is called with NULL, it forces it to use the UNIX socket
+on the local host.
+
+The lex/flex based scanner has been replaced by a hand written C
+scanner. This removes a heap of portability problems with various
+version of lex/flex and the good old "I'm flex but I'll call myself lex"
+problem on Linux and *BSD.
+
+A regression test suite is now available in tests/rtest. Run it after
+you've compiled and installed the code to ensure that it's working OK.
+
+
+General Info
+------------
+
+mSQL has been developed under Sun OS 4.1.1 but has been tested under
+Solaris 2.3, Ultrix 4.3, Linux, FreeBSD 2, and OSF/1 (cc not gcc). That
+said, it should "autoconf" and build on most BSD derived systems, SVR4
+based systems or POSIX O/S's (that should cover most of them). It has been
+reported that it works out-of-the-box on HP-UX, NeXT, SCO, Sequent,
+Cray, Tandem and a few others. I haven't tested these so buyer beware.
+
+
+Installation
+------------
+
+To build mSQL, type "make target" in the top directory. This will build
+a directory where the object files for your system will be made. This
+mechanism allows you to NFS mount the sources onto different machines
+and build mSQL on different platforms without having to make copies of
+the sources. The directory will be under the "targets" directory (e.g.
+$(TOP)/targets/Solaris-2.3-Sparc )
+
+Once the target directory has been created, change directory into it and
+run "setup". That will run autoconf and some other configuration
+scripts. Once that has completed, just type make. You should install
+the software with "make install" when you're happy with it.
+
+The default installation directory is /usr/local/Minerva. This area is
+shared by all the development of Minerva (including the ESL scripting
+language and Minerva itself). It's probably a good idea to leave it as
+that rather than /usr/local/msql or similar if you wish to use ESL
+(check out doc/Minerva for details on ESL or grab the ESL manual via ftp
+from Bond.edu.au in /pub/Minerva/esl )
+
+
+Testing the software
+--------------------
+
+Once it is installed, you can try the sample mSQL script provided in
+the msql source directory. Fire up the server using
+
+ /usr/local/Minerva/bin/msqld&
+
+Create a test database using
+
+ /usr/local/Minerva/bin/msqladmin create test
+
+Run the script through the terminal monitor using
+
+ /usr/local/Minerva/bin/msql test < sample.msql
+
+There are also some further test scripts in the tests directory. The
+"killer" test will produce performance figures about mSQL running on
+your machine. details such as the number of operations per second for
+inserts, fills and selects on both keyed and flat tables is generated.
+
+For a real test, run the regression test suite (rtest) in the tests
+directory.
+
+
+Notes :
+------
+
+ o Because this stuff is pretty new, there's a script in the
+ scripts directory that you may want to use to run the server. It
+ restarts the server if it crashes and mails you a notification
+ of the failure. It's called run_daemon and may save you some
+ heart ache.
+
+ o If you run this on a Cray (what? you don't have a Y-MP at
+ home? :) you'll have to add -lsocket to EXTRA_LIB in site.mm
+ after you run setup.
+
+ o OSF/1 and gcc don't appear to like this stuff. If you're
+ using OSF/1 use the standard DEC compiler and everything is
+ fine.
+
+ o The manual is formatted for an A4 page. I have run the
+ postscript through a filter that should let it print on any
+ paper size although the margins may get stuffed up a bit.
+
+
+If you decide to use mSQL for anything, could you drop me a line. I'd
+like to keep track of just how many people are using it and what it's
+being used for. You may also wish to join the mailing list by sending a
+message to msql-list-request@Bond.edu.au.
+
+
+ __ David J. Hughes - Bambi@Bond.edu.au
+ / \ / / / http://Bond.edu.au/People/bambi.html
+ /___/ __ _ ____/ / / _
+/ \ / \ / \ / / / / / \ / Senior Network Programmer, Bond University
+\___/ \__// / \__/ \__/ / / / Qld. 4229 AUSTRALIA (+61 75 951450)
diff --git a/databases/msql3/pkg-plist b/databases/msql3/pkg-plist
new file mode 100644
index 000000000000..d338a8faccbe
--- /dev/null
+++ b/databases/msql3/pkg-plist
@@ -0,0 +1,21 @@
+@cd /usr/local/Minerva
+@mode 755
+@owner root
+@group bin
+bin/msql
+@mode 4750
+bin/msqld
+bin/msqladmin
+@mode 4755
+bin/relshow
+bin/msqldump
+@mode 644
+include/msql.h
+@mode 644
+lib/libmsql.a
+@mode 644
+doc/mSQL-1.0.ps
+doc/License.mSQL
+@mode 600
+msql.acl.sample
+@exec mkdir -p %D/msqldb/.tmp