aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql41-client
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-11 05:37:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-11 05:37:39 +0000
commitdbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b (patch)
treedeebef625a152490a0bbcb7e5602d05a59b1c010 /databases/mysql41-client
parentc2e32ac36f406a78d4fb097baacb7fd65c4817d8 (diff)
downloadports-dbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b.tar.gz
ports-dbc8aa6cc1cb1abadce30cfe133c7a5c2ed2f34b.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Notes
Notes: svn path=/head/; revision=14465
Diffstat (limited to 'databases/mysql41-client')
-rw-r--r--databases/mysql41-client/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/mysql41-client/Makefile b/databases/mysql41-client/Makefile
index 5ed51094cf47..58d40fc5d51e 100644
--- a/databases/mysql41-client/Makefile
+++ b/databases/mysql41-client/Makefile
@@ -3,7 +3,7 @@
# Date created: 26 Jan 1998
# Whom: Josh Tiefenbach <josh@ican.net>
#
-# $Id: Makefile,v 1.29 1998/10/08 01:20:26 asami Exp $
+# $Id: Makefile,v 1.30 1998/10/22 07:47:24 thepish Exp $
#
DISTNAME= mysql-3.22.9-beta
@@ -30,7 +30,8 @@ CONFIGURE_ENV+= PERL=${PERL5} \
PERL5=${PERL5} \
INSTALL_SCRIPT="${INSTALL_SCRIPT}"
-OSVERSION!= sysctl -n kern.osreldate
+.include <bsd.port.pre.mk>
+
.if defined(NATIVE_THREADS) && ${OSVERSION} >= 300000
CONFIGURE_ARGS+= --with-named-thread-libs=-lc_r
.else
@@ -58,7 +59,7 @@ pre-fetch:
@${ECHO} "Using mit-pthreads."
@${ECHO}
.endif
-
+
pre-install:
.if defined(PACKAGE_BUILDING)
@ ${RM} -rf /var/db/mysql
@@ -95,4 +96,4 @@ post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib/mysql
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>