aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql41-server/files
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-01-31 16:02:39 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-01-31 16:02:39 +0000
commitb62043221b3c551395356d35e5af4e0f7e27bb3d (patch)
tree85f3c5c1113767b61cec4507fb0d635abe5fc57d /databases/mysql41-server/files
parentec93488ff6e13140ab1aa50ad0f0bf0460880cc4 (diff)
downloadports-b62043221b3c551395356d35e5af4e0f7e27bb3d.tar.gz
ports-b62043221b3c551395356d35e5af4e0f7e27bb3d.zip
Update to MySQL 4.0.9 after a repo-copy from the mysql323-* ports.
PR: 45543 Submitted by: Alex Dupre <sysadmin@alexdupre.com> Repo-copy approved by: portmgr (will) Repo-copy performed by: cvs (josefk)
Notes
Notes: svn path=/head/; revision=74356
Diffstat (limited to 'databases/mysql41-server/files')
-rw-r--r--databases/mysql41-server/files/mysql-server.sh4
-rw-r--r--databases/mysql41-server/files/patch-Makefile.in23
-rw-r--r--databases/mysql41-server/files/patch-af79
-rw-r--r--databases/mysql41-server/files/patch-configure147
-rw-r--r--databases/mysql41-server/files/patch-include::Makefile.in6
-rw-r--r--databases/mysql41-server/files/patch-sql_mysqld.cc12
6 files changed, 21 insertions, 250 deletions
diff --git a/databases/mysql41-server/files/mysql-server.sh b/databases/mysql41-server/files/mysql-server.sh
index 6a5acb39a962..5180b9c0c1eb 100644
--- a/databases/mysql41-server/files/mysql-server.sh
+++ b/databases/mysql41-server/files/mysql-server.sh
@@ -5,9 +5,9 @@ PIDFILE=${DB_DIR}/`/bin/hostname -s`.pid
case "$1" in
start)
- if [ -x %%PREFIX%%/bin/safe_mysqld ]; then
+ if [ -x %%PREFIX%%/bin/mysqld_safe ]; then
/usr/bin/limits -U mysql \
- %%PREFIX%%/bin/safe_mysqld --user=mysql --datadir=${DB_DIR} --pid-file=${PIDFILE} > /dev/null &
+ %%PREFIX%%/bin/mysqld_safe --user=mysql --datadir=${DB_DIR} --pid-file=${PIDFILE} > /dev/null &
echo -n ' mysqld'
fi
;;
diff --git a/databases/mysql41-server/files/patch-Makefile.in b/databases/mysql41-server/files/patch-Makefile.in
index 987cf407da8f..c8bf28bc02bc 100644
--- a/databases/mysql41-server/files/patch-Makefile.in
+++ b/databases/mysql41-server/files/patch-Makefile.in
@@ -1,19 +1,20 @@
---- Makefile.in.orig Thu Jan 23 16:13:43 2003
-+++ Makefile.in Wed Jan 29 17:11:29 2003
-@@ -195,11 +195,11 @@
+--- Makefile.in.orig Wed Nov 20 00:06:37 2002
++++ Makefile.in Wed Nov 20 00:07:31 2002
+@@ -207,12 +207,11 @@
EXTRA_DIST = INSTALL-SOURCE README \
- COPYING COPYING.LIB MIRRORS
+ COPYING COPYING.LIB
--SUBDIRS = . include @docs_dirs@ @readline_dir@ \
-- @thread_dirs@ @sql_client_dirs@ \
-- @sql_server_dirs@ scripts tests man \
-- @bench_dirs@ support-files os2
+-SUBDIRS = include @docs_dirs@ @readline_dir@ \
+- @thread_dirs@ pstack @sql_client_dirs@ \
+- @sql_server_dirs@ @libmysqld_dirs@ scripts man \
+- tests BUILD os2 \
+- @bench_dirs@ support-files @fs_dirs@ @tools_dirs@
-
+.if defined(CLIENT_ONLY)
-+SUBDIRS = include @readline_dir@ @sql_client_dirs@ tests man
++SUBDIRS = include @sql_client_dirs@ tests man
+.else
-+SUBDIRS = include @thread_dirs@ @docs_dirs@ @sql_server_dirs@ scripts support-files
++SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts support-files
+.endif
# Relink after clean
- CLEANFILES = linked_client_sources linked_server_sources linked_libmysql_sources linked_libmysql_r_sources linked_include_sources
+ linked_sources = linked_client_sources linked_server_sources \
diff --git a/databases/mysql41-server/files/patch-af b/databases/mysql41-server/files/patch-af
deleted file mode 100644
index 8d2d1003f2e4..000000000000
--- a/databases/mysql41-server/files/patch-af
+++ /dev/null
@@ -1,79 +0,0 @@
---- scripts/safe_mysqld.sh.orig Thu Oct 10 12:17:29 2002
-+++ scripts/safe_mysqld.sh Sun Nov 10 21:27:46 2002
-@@ -68,30 +68,9 @@
- done
- }
-
--MY_PWD=`pwd`
--# Check if we are starting this relative (for the binary release)
--if test -d $MY_PWD/data/mysql -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./bin/mysqld
--then
-- MY_BASEDIR_VERSION=$MY_PWD # Where bin, share and data are
-- ledir=$MY_BASEDIR_VERSION/bin # Where mysqld is
-- DATADIR=$MY_BASEDIR_VERSION/data
-- if test -z "$defaults"
-- then
-- defaults="--defaults-extra-file=$MY_BASEDIR_VERSION/data/my.cnf"
-- fi
--# Check if this is a 'moved install directory'
--elif test -f ./var/mysql/db.frm -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./libexec/mysqld
--then
-- MY_BASEDIR_VERSION=$MY_PWD # Where libexec, share and var are
-- ledir=$MY_BASEDIR_VERSION/libexec # Where mysqld is
-- DATADIR=$MY_BASEDIR_VERSION/var
--else
-- MY_BASEDIR_VERSION=@prefix@
-- DATADIR=@localstatedir@
-- ledir=@libexecdir@
--fi
-+MY_BASEDIR_VERSION=@prefix@
-+DATADIR=@localstatedir@
-+ledir=@libexecdir@
-
- MYSQL_UNIX_PORT=${MYSQL_UNIX_PORT:-@MYSQL_UNIX_ADDR@}
- MYSQL_TCP_PORT=${MYSQL_TCP_PORT:-@MYSQL_TCP_PORT@}
-@@ -106,7 +85,6 @@
- fi
-
- # these rely on $DATADIR by default, so we'll set them later on
--pid_file=
- err_log=
- SET_USER=0
-
-@@ -239,34 +217,6 @@
- if test ! -f $pid_file # This is removed if normal shutdown
- then
- break
-- fi
--
-- if @IS_LINUX@
-- then
-- # Test if one process was hanging.
-- # This is only a fix for Linux (running as base 3 mysqld processes)
-- # but should work for the rest of the servers.
-- # The only thing is ps x => redhat 5 gives warnings when using ps -x.
-- # kill -9 is used or the process won't react on the kill.
-- numofproces=`ps xa | grep -v "grep" | grep -c $ledir/$MYSQLD`
-- echo -e "\nNumber of processes running now: $numofproces" | tee -a $err_log
-- I=1
-- while test "$I" -le "$numofproces"
-- do
-- PROC=`ps xa | grep $ledir/$MYSQLD | grep -v "grep" | sed -n '$p'`
-- for T in $PROC
-- do
-- break
-- done
-- # echo "TEST $I - $T **"
-- if kill -9 $T
-- then
-- echo "$MYSQLD process hanging, pid $T - killed" | tee -a $err_log
-- else
-- break
-- fi
-- I=`expr $I + 1`
-- done
- fi
-
- echo "`date +'%y%m%d %H:%M:%S'` mysqld restarted" | tee -a $err_log
diff --git a/databases/mysql41-server/files/patch-configure b/databases/mysql41-server/files/patch-configure
index 6c6e0ad044fa..5f5155735ee1 100644
--- a/databases/mysql41-server/files/patch-configure
+++ b/databases/mysql41-server/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Thu Dec 5 10:37:31 2002
-+++ configure Mon Dec 16 19:49:41 2002
-@@ -8059,6 +8059,7 @@
+--- configure.orig Mon Dec 16 10:12:16 2002
++++ configure Fri Dec 20 18:11:14 2002
+@@ -8071,6 +8071,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,7 +8,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -8988,7 +8989,7 @@
+@@ -9000,7 +9001,7 @@
;;
esac
fi
@@ -17,142 +17,3 @@
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
-@@ -9177,43 +9178,7 @@
- echo "${ECHO_T}no" >&6
- fi
-
--echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
--echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6
--PS=$ac_cv_path_PS
--# Linux style
--if $PS p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
--# Solaris
--elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
--# BSD style
--elif $PS -uaxww 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# SysV style
--elif $PS -ef 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -ef | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# Do anybody use this?
--elif $PS $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS \$\$PID | grep mysqld > /dev/null"
--else
-- case $SYSTEM_TYPE in
-- *darwin*)
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *cygwin*)
-- FIND_PROC="$PS -e | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *)
-- { { echo "$as_me:$LINENO: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." >&5
--echo "$as_me: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." >&2;}
-- { (exit 1); exit 1; }; }
-- esac
--fi
-+FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
-
- echo "$as_me:$LINENO: result: \"$FIND_PROC\"" >&5
- echo "${ECHO_T}\"$FIND_PROC\"" >&6
-@@ -13208,7 +13173,6 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lc_r $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-@@ -13262,7 +13226,6 @@
- #define HAVE_LIBC_R 1
- _ACEOF
-
-- LIBS="-lc_r $LIBS"
-
- fi
-
-@@ -13706,29 +13669,6 @@
- fi
-
-
--# Build optimized or debug version ?
--# First check for gcc and g++
--if test "$ac_cv_c_compiler_gnu" = "yes"
--then
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC="-O"
-- OPTIMIZE_CFLAGS="$MAX_C_OPTIMIZE"
--else
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC=""
-- OPTIMIZE_CFLAGS="-O"
--fi
--if test "$ac_cv_prog_cxx_g" = "yes"
--then
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX="-O"
-- OPTIMIZE_CXXFLAGS="-O3"
--else
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX=""
-- OPTIMIZE_CXXFLAGS="-O"
--fi
--
-
- # Check whether --with-debug or --without-debug was given.
- if test "${with_debug+set}" = set; then
-@@ -16081,10 +16021,6 @@
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
--if test "$ac_cv_cxx_compiler_gnu" = "yes"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- mysql_cv_btype_last_arg_accept=none
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
-@@ -19222,14 +19158,6 @@
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
-
--# Do not treat warnings as errors if we are linking against other libc
--# this is to work around gcc not being permissive on non-system includes
--# with respect to ANSI C++
--if test "$ac_cv_cxx_compiler_gnu" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
--
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-@@ -19313,10 +19241,6 @@
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
--if test "$ac_cv_cxx_compiler_gnu" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
-@@ -19399,10 +19323,6 @@
- ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
- ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
-
--if test "$ac_cv_cxx_compiler_gnu" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
- #include "confdefs.h"
diff --git a/databases/mysql41-server/files/patch-include::Makefile.in b/databases/mysql41-server/files/patch-include::Makefile.in
index 3ff10ce708d5..34b404c0a255 100644
--- a/databases/mysql41-server/files/patch-include::Makefile.in
+++ b/databases/mysql41-server/files/patch-include::Makefile.in
@@ -1,6 +1,6 @@
---- include/Makefile.in.orig Thu Dec 5 10:37:22 2002
-+++ include/Makefile.in Sat Dec 14 16:26:53 2002
-@@ -324,7 +324,11 @@
+--- include/Makefile.in.orig Tue Nov 19 17:13:35 2002
++++ include/Makefile.in Tue Nov 19 17:14:10 2002
+@@ -335,7 +335,11 @@
installdirs:
$(mkinstalldirs) $(DESTDIR)$(pkgincludedir)
diff --git a/databases/mysql41-server/files/patch-sql_mysqld.cc b/databases/mysql41-server/files/patch-sql_mysqld.cc
deleted file mode 100644
index 5155bd5f33cd..000000000000
--- a/databases/mysql41-server/files/patch-sql_mysqld.cc
+++ /dev/null
@@ -1,12 +0,0 @@
---- sql/mysqld.cc.orig Thu Oct 10 12:17:28 2002
-+++ sql/mysqld.cc Tue Nov 12 23:23:27 2002
-@@ -92,7 +92,8 @@
- int allow_severity = LOG_INFO;
- int deny_severity = LOG_WARNING;
-
--#ifdef __STDC__
-+#include <osreldate.h>
-+#if defined(__STDC__) && __FreeBSD_version < 500000
- #define my_fromhost(A) fromhost(A)
- #define my_hosts_access(A) hosts_access(A)
- #define my_eval_client(A) eval_client(A)