aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql50-client
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-03-16 02:46:42 +0000
committerSteve Price <steve@FreeBSD.org>1998-03-16 02:46:42 +0000
commit40d865261319bdf6f2391e15e32c9b517a129698 (patch)
treeedcfff37494c4730089b778cc0578d17da077a2f /databases/mysql50-client
parent3ca4c93b96c0aecfdd23b4b9d3f7281824c65fb7 (diff)
downloadports-40d865261319bdf6f2391e15e32c9b517a129698.tar.gz
ports-40d865261319bdf6f2391e15e32c9b517a129698.zip
Upgrade to version 3.21.25g-gamma.
PR: 5983 Submitted by: Dirk Foremberg <ibex@physik.TU-Berlin.DE>
Notes
Notes: svn path=/head/; revision=10166
Diffstat (limited to 'databases/mysql50-client')
-rw-r--r--databases/mysql50-client/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/databases/mysql50-client/Makefile b/databases/mysql50-client/Makefile
index 05680d8383d9..199e6bc092fc 100644
--- a/databases/mysql50-client/Makefile
+++ b/databases/mysql50-client/Makefile
@@ -1,13 +1,13 @@
# ports collection makefile for: mySQL
-# Version required: v3.21.21
+# Version required: v3.21.25-gamma
# Date created: 26 Jan 1998
# Whom: Josh Tiefenbach <josh@ican.net>
#
-# $Id: Makefile,v 1.15 1998/01/26 18:24:42 jfitz Exp $
+# $Id: Makefile,v 1.16 1998/02/23 02:55:16 steve Exp $
#
-DISTNAME= mysql-3.21.21a-beta
-PKGNAME= mysql-3.21.21b
+DISTNAME= mysql-3.21.25-gamma
+PKGNAME= mysql-3.21.25g
CATEGORIES= databases
MASTER_SITES= http://www.buoy.com/mysql/Downloads/MySQL-3.21/ \
http://mysql.polaris.ca/Downloads/MySQL-3.21/ \
@@ -31,10 +31,10 @@ pre-install:
.if defined(PACKAGE_BUILDING)
@ ${RM} -rf /var/db/mysql
.endif
- @ ${SETENV} ${MAKE_ENV} /usr/bin/perl ${SCRIPTDIR}/check_old_version
+ @ ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl ${SCRIPTDIR}/check_old_version
post-install:
- ${MKDIR} -p ${PREFIX}/share/mysql/mysql
+ ${MKDIR} ${PREFIX}/share/mysql/mysql
${CP} ${WRKSRC}/data/mysql/*.frm ${PREFIX}/share/mysql/mysql
${PREFIX}/bin/mysql_install_db
@ /usr/bin/killall mysqld
@@ -50,5 +50,10 @@ post-install:
.for doc in manual.html manual.ps manual_toc.html manual.txt manual.texi include.texi
${INSTALL_DATA} ${WRKSRC}/Docs/${doc} ${PREFIX}/share/doc/mysql
.endfor
+ @if [ ! -f ${PREFIX}/info/dir -a -f /usr/share/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+ ${INSTALL_DATA} ${WRKSRC}/Docs/mysql.info ${PREFIX}/info
+ @install-info ${PREFIX}/info/mysql.info ${PREFIX}/info/dir
.include <bsd.port.mk>