aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql51-server
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2000-01-05 21:03:03 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2000-01-05 21:03:03 +0000
commitc73aca2ef0ab80026d0c11da182f2ad6567b19f2 (patch)
treea50a859b5d665a67576edb18b13e837a77a3966c /databases/mysql51-server
parent8a2c53d6e56beb37d761b4848e01c8704e60e7a8 (diff)
downloadports-c73aca2ef0ab80026d0c11da182f2ad6567b19f2.tar.gz
ports-c73aca2ef0ab80026d0c11da182f2ad6567b19f2.zip
- upgrade to 3.22.29
- add -O0 for compiling sql/sql_yacc.cc. Otherwise gcc eats a lot of memory and cpu time. It seems to be a gcc compiler bug in conjunction with -O.
Notes
Notes: svn path=/head/; revision=24452
Diffstat (limited to 'databases/mysql51-server')
-rw-r--r--databases/mysql51-server/Makefile6
-rw-r--r--databases/mysql51-server/distinfo2
-rw-r--r--databases/mysql51-server/files/patch-Makefile.in15
-rw-r--r--databases/mysql51-server/files/patch-ap18
-rw-r--r--databases/mysql51-server/files/patch-aq13
-rw-r--r--databases/mysql51-server/files/patch-include::Makefile.in14
-rw-r--r--databases/mysql51-server/pkg-plist8
-rw-r--r--databases/mysql51-server/pkg-plist.client6
8 files changed, 59 insertions, 23 deletions
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 6e4c0ebb7b13..afe679e62a16 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-DISTNAME= mysql-3.22.27
+DISTNAME= mysql-3.22.29
PKGNAME?= ${DISTNAME:S/-/-server-/}
CATEGORIES= databases
MASTER_SITES= http://www.fh-wolfenbuettel.de/ftp/pub/database/mysql/Downloads/MySQL-3.22/ \
@@ -94,8 +94,8 @@ pre-fetch:
@${ECHO}
.endif
-post-patch:
- ${MV} ${WRKSRC}/strings/strings.s ${WRKSRC}/strings/strings.S
+pre-build:
+ ${MV} ${WRKSRC}/strings/strings-x86.s ${WRKSRC}/strings/strings-x86.S
${MV} ${WRKSRC}/strings/longlong2str-x86.s ${WRKSRC}/strings/longlong2str-x86.S
pre-install:
diff --git a/databases/mysql51-server/distinfo b/databases/mysql51-server/distinfo
index e06721973a08..deefd3c48db1 100644
--- a/databases/mysql51-server/distinfo
+++ b/databases/mysql51-server/distinfo
@@ -1 +1 @@
-MD5 (mysql-3.22.27.tar.gz) = 385bee829a157b0a50e61402fc859035
+MD5 (mysql-3.22.29.tar.gz) = d567b6f1ac63bb7b18281a3350f2b36e
diff --git a/databases/mysql51-server/files/patch-Makefile.in b/databases/mysql51-server/files/patch-Makefile.in
index ca3680549992..00190736f765 100644
--- a/databases/mysql51-server/files/patch-Makefile.in
+++ b/databases/mysql51-server/files/patch-Makefile.in
@@ -1,16 +1,15 @@
---- Makefile.in.orig Sun Jun 6 04:51:50 1999
-+++ Makefile.in Sat Jun 26 08:53:51 1999
-@@ -141,8 +141,11 @@
+--- Makefile.in.orig Sat Jan 1 17:59:38 2000
++++ Makefile.in Mon Jan 3 17:19:23 2000
+@@ -144,7 +144,11 @@
# These are built from source in the Docs directory
EXTRA_DIST = INSTALL-SOURCE-GENERIC README PUBLIC INSTALL-SOURCE MIRRORS
--SUBDIRS = @docs_dirs@ @readline_dir@ client @sql_server_dirs@ scripts include tests man @bench_dirs@ support-files
--
+-SUBDIRS = include @docs_dirs@ @readline_dir@ client @sql_server_dirs@ scripts tests man @bench_dirs@ support-files
+.if defined(CLIENT_ONLY)
-+SUBDIRS = @readline_dir@ client include tests man
++SUBDIRS = include @readline_dir@ client tests man
+.else
-+SUBDIRS = @docs_dirs@ @sql_server_dirs@ scripts @bench_dirs@ support-files
++SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts @bench_dirs@ support-files
+.endif
+
# Relink after clean
- CLEANFILES = linked_client_sources
diff --git a/databases/mysql51-server/files/patch-ap b/databases/mysql51-server/files/patch-ap
index f42968f78ee6..097b449a181a 100644
--- a/databases/mysql51-server/files/patch-ap
+++ b/databases/mysql51-server/files/patch-ap
@@ -1,11 +1,11 @@
---- strings/Makefile.in.orig Thu Sep 9 10:52:02 1999
-+++ strings/Makefile.in Sun Sep 12 23:56:25 1999
-@@ -143,7 +143,7 @@
+--- strings/Makefile.in.orig Sat Jan 1 18:00:30 2000
++++ strings/Makefile.in Mon Jan 3 17:21:19 2000
+@@ -145,7 +145,7 @@
+ INCLUDES = @MT_INCLUDES@ -I$(srcdir)/../include -I../include
pkglib_LIBRARIES = libmystrings.a
+ #no assembler
+-@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.s longlong2str-x86.s
++@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.S longlong2str-x86.S
+ @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_TRUE@ASRCS = bmove_upp-sparc.s strappend-sparc.s strend-sparc.s strinstr-sparc.s strmake-sparc.s strmov-sparc.s strnmov-sparc.s strstr-sparc.s strxmov-sparc.s
+ @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_FALSE@ASRCS =
# These file MUST all be on the same line!! Otherwise automake
- # generats a very broken makefile
--@ASSEMBLER_TRUE@ESRCS = strings.s longlong2str-x86.s
-+@ASSEMBLER_TRUE@ESRCS = strings.S longlong2str-x86.S
- @ASSEMBLER_FALSE@ESRCS = strxmov.c bmove_upp.c strappend.c strcont.c strend.c strfill.c strcend.c is_prefix.c strstr.c strinstr.c strmake.c strnmov.c strmov.c longlong2str.c
-
- libmystrings_a_SOURCES = bfill.c bmove.c bmove512.c bchange.c strxnmov.c int2str.c str2int.c r_strinstr.c ct_init.c atof.c ptr_cmp.c bcmp.c strtol.c strtoul.c strtoll.c strtoull.c @CHARSET_SRCS@ $(ESRCS)
diff --git a/databases/mysql51-server/files/patch-aq b/databases/mysql51-server/files/patch-aq
new file mode 100644
index 000000000000..573324175921
--- /dev/null
+++ b/databases/mysql51-server/files/patch-aq
@@ -0,0 +1,13 @@
+--- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
++++ sql/Makefile.in Wed Jan 5 20:28:17 2000
+@@ -317,6 +317,10 @@
+ else :; fi
+ sql_yacc.hh: sql_yacc.cc
+
++# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
++sql_yacc.o: sql_yacc.cc
++ $(CXXCOMPILE) -O0 -c $<
++
+
+ # This directory's subdirectories are mostly independent; you can cd
+ # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql51-server/files/patch-include::Makefile.in b/databases/mysql51-server/files/patch-include::Makefile.in
new file mode 100644
index 000000000000..ed7654838e66
--- /dev/null
+++ b/databases/mysql51-server/files/patch-include::Makefile.in
@@ -0,0 +1,14 @@
+--- include/Makefile.in.orig Sat Jan 1 17:59:41 2000
++++ include/Makefile.in Wed Jan 5 21:04:23 2000
+@@ -259,7 +259,11 @@
+
+ install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
++.if defined(CLIENT_ONLY)
+ install: install-am
++.else
++install:
++.endif
+ uninstall-am: uninstall-pkgincludeHEADERS
+ uninstall: uninstall-am
+ all-am: Makefile $(HEADERS) all-local
diff --git a/databases/mysql51-server/pkg-plist b/databases/mysql51-server/pkg-plist
index b25e97cd6c85..a536a0ed0840 100644
--- a/databases/mysql51-server/pkg-plist
+++ b/databases/mysql51-server/pkg-plist
@@ -26,6 +26,7 @@ lib/mysql/libnisam.a
libexec/mysqld
share/doc/mysql/Img/australia.gif
share/doc/mysql/Img/austria.gif
+share/doc/mysql/Img/brazil.gif
share/doc/mysql/Img/bulgaria.gif
share/doc/mysql/Img/canada.gif
share/doc/mysql/Img/chile.gif
@@ -41,10 +42,14 @@ share/doc/mysql/Img/great-britain.gif
share/doc/mysql/Img/greece.gif
share/doc/mysql/Img/html-fs.gif
share/doc/mysql/Img/hungary.gif
+share/doc/mysql/Img/iceland.gif
+share/doc/mysql/Img/ireland.gif
+share/doc/mysql/Img/island.gif
share/doc/mysql/Img/israel.gif
share/doc/mysql/Img/italy.gif
share/doc/mysql/Img/japan.gif
share/doc/mysql/Img/kroatia.gif
+share/doc/mysql/Img/mysql-logo.gif
share/doc/mysql/Img/mysql5.gif
share/doc/mysql/Img/netherlands.gif
share/doc/mysql/Img/poland.gif
@@ -55,6 +60,7 @@ share/doc/mysql/Img/singapore.gif
share/doc/mysql/Img/south-africa.gif
share/doc/mysql/Img/south-africa1.gif
share/doc/mysql/Img/south-korea.gif
+share/doc/mysql/Img/spain.gif
share/doc/mysql/Img/sweden.gif
share/doc/mysql/Img/switzerland.gif
share/doc/mysql/Img/taiwan.gif
@@ -94,7 +100,7 @@ share/mysql/korean/errmsg.sys
share/mysql/korean/errmsg.txt
share/mysql/make_binary_distribution
share/mysql/my-example.cnf
-share/mysql/mysql-3.22.27.spec
+share/mysql/mysql-3.22.29.spec
share/mysql/mysql-log-rotate
share/mysql/mysql.server
share/mysql/norwegian-ny/errmsg.sys
diff --git a/databases/mysql51-server/pkg-plist.client b/databases/mysql51-server/pkg-plist.client
index b293ad704aa8..8cbf374f66a7 100644
--- a/databases/mysql51-server/pkg-plist.client
+++ b/databases/mysql51-server/pkg-plist.client
@@ -6,14 +6,18 @@ bin/mysqlshow
etc/rc.d/mysql-client.sh
include/mysql/dbug.h
include/mysql/errmsg.h
-include/mysql/m_ctype.h.in
+include/mysql/m_ctype.h
include/mysql/m_string.h
+include/mysql/my_config.h
+include/mysql/my_global.h
include/mysql/my_list.h
+include/mysql/my_pthread.h
include/mysql/my_sys.h
include/mysql/mysql.h
include/mysql/mysql_com.h
include/mysql/mysql_version.h
include/mysql/mysqld_error.h
+include/mysql/raid.h
lib/mysql/libmysqlclient.a
lib/mysql/libmysqlclient.so
lib/mysql/libmysqlclient.so.6