aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Class-DBI-SAK/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-22 14:31:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-22 14:31:57 +0000
commita51078f35395e1a9792aceef4b09e9c5db32f55a (patch)
tree1885a7a09cc9287f1d1656f8ba5e37abc016cfe4 /databases/p5-Class-DBI-SAK/Makefile
parent29b725543f41fcd57777d1b03d5256c23e3f4541 (diff)
downloadports-a51078f35395e1a9792aceef4b09e9c5db32f55a.tar.gz
ports-a51078f35395e1a9792aceef4b09e9c5db32f55a.zip
New port databases/p5-Class-DBI-SAK
By taking the busy work out of using Class::DBI as you see fit, your code becomes more useful by size. Most of us end up using at least a couple Class::DBI extensions in our programs, and it's just a pain. Enter the Swiss Army Knife. PR: 54748 Submitted by: Mathieu Arnold <m@absolight.net> Approved by: fjoe (mentor)
Notes
Notes: svn path=/head/; revision=85384
Diffstat (limited to 'databases/p5-Class-DBI-SAK/Makefile')
-rw-r--r--databases/p5-Class-DBI-SAK/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/databases/p5-Class-DBI-SAK/Makefile b/databases/p5-Class-DBI-SAK/Makefile
new file mode 100644
index 000000000000..0155a739bdb3
--- /dev/null
+++ b/databases/p5-Class-DBI-SAK/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Class-DBI-SAK
+# Date created: 22 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-DBI-SAK
+PORTVERSION= 1.3
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Class::DBI Swiss Army Knife (SAK)
+
+RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
+ ${SITE_PERL}/Class/DBI/AbstractSearch.pm:${PORTSDIR}/databases/p5-Class-DBI-AbstractSearch \
+ ${SITE_PERL}/Class/DBI/Pager.pm:${PORTSDIR}/databases/p5-Class-DBI-Pager
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
+ ${SITE_PERL}/mixin.pm:${PORTSDIR}/devel/p5-mixin
+
+PERL_CONFIGURE= yes
+
+# Class::DBI::Join is no more
+post-patch:
+ @${PERL} -pi -e '$$_ = "" if (/Class::DBI::Join/ || /'\''Join'\''/)' \
+ ${WRKSRC}/Build.PL ${WRKSRC}/META.yml ${WRKSRC}/lib/Class/DBI/SAK.pm
+
+.include <bsd.port.mk>