aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Class-DBI/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-05-27 09:43:29 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-05-27 09:43:29 +0000
commit1683c7d6baedfcb37b31918a6481823b850d5a6c (patch)
tree5f8e8455e82acff97df6644ec963bd68e09ab20d /databases/p5-Class-DBI/Makefile
parent9c7c131ab1e978bcfb18edbf92173a9291a7b36b (diff)
downloadports-1683c7d6baedfcb37b31918a6481823b850d5a6c.tar.gz
ports-1683c7d6baedfcb37b31918a6481823b850d5a6c.zip
Add p5-Class-DBI 0.86, simple Database Abstraction.
Notes
Notes: svn path=/head/; revision=60107
Diffstat (limited to 'databases/p5-Class-DBI/Makefile')
-rw-r--r--databases/p5-Class-DBI/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/databases/p5-Class-DBI/Makefile b/databases/p5-Class-DBI/Makefile
new file mode 100644
index 000000000000..2449aca3db03
--- /dev/null
+++ b/databases/p5-Class-DBI/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Class-DBI
+# Date created: 15 Dec 2001
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-DBI
+PORTVERSION= 0.86
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Carp/Assert.pm:${PORTSDIR}/devel/p5-Carp-Assert \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/DBD/CSV.pm:${PORTSDIR}/databases/p5-DBD-CSV \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Ima/DBI.pm:${PORTSDIR}/databases/p5-Ima-DBI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/protected.pm:${PORTSDIR}/devel/p5-Class-Fields \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Class::DBI.3
+
+post-configure:
+# dirty hack to deceive irritable pod2man
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>