aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-SQLite/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2010-11-05 01:40:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2010-11-05 01:40:26 +0000
commit18190d37bfafc24f330bb2b8186018b881256ed3 (patch)
tree8d5444a5bceaf1f9b620e13c4dc4cc9ca20c393c /databases/p5-DBD-SQLite/Makefile
parentbd9404a522b1c1fb1368d39ee00563b644964290 (diff)
downloadports-18190d37bfafc24f330bb2b8186018b881256ed3.tar.gz
ports-18190d37bfafc24f330bb2b8186018b881256ed3.zip
- Update to 1.31
PR: ports/151928 Submitted by: leeym
Notes
Notes: svn path=/head/; revision=264111
Diffstat (limited to 'databases/p5-DBD-SQLite/Makefile')
-rw-r--r--databases/p5-DBD-SQLite/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/databases/p5-DBD-SQLite/Makefile b/databases/p5-DBD-SQLite/Makefile
index 7a677396b409..671972a93d36 100644
--- a/databases/p5-DBD-SQLite/Makefile
+++ b/databases/p5-DBD-SQLite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DBD-SQLite
-PORTVERSION= 1.29
+PORTVERSION= 1.31
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,23 +14,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Provides access to SQLite3 databases through the DBI
-# We use sqlite3's own library & headers since it is more recent
-# than the bundled version and has an incompatible DB file format.
-# In this way we can be sure DBD::SQLite can interoperate with
-# databases/sqlite3.
-BUILD_DEPENDS= sqlite3>=3.4.1:${PORTSDIR}/databases/sqlite3 \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+RUN_DEPENDS= p5-DBI>=1.57:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= USE_LOCAL_SQLITE=0
-CONFIGURE_ARGS+= SQLITE_LOCATION=${LOCALBASE}
+CONFIGURE_ARGS= USE_LOCAL_SQLITE=0 SQLITE_LOCATION=${LOCALBASE}
MAN3= DBD::SQLite.3 DBD::SQLite::Cookbook.3
-post-patch:
- ${RM} -f ${WRKSRC}/getsqlite.pl
- ${PERL} -pi -e 's/\$$Config{d_usleep}/1/' ${WRKSRC}/Makefile.PL
- ${PERL} -pi -e '$$_="" if m|getsqlite.pl|' ${WRKSRC}/MANIFEST
-
.include <bsd.port.mk>