aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-29 19:15:18 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-29 19:15:18 +0000
commit670fcd21150ece05c2005ad24b797226ae23fb3a (patch)
tree96bf7b61b7a3ac28c7882a5d6cd8ec736ca1a28f /databases/p5-DBD-mysql/Makefile
parent7e2f3eaf6fb82154aff4515d23084664d3195a5d (diff)
downloadports-670fcd21150ece05c2005ad24b797226ae23fb3a.tar.gz
ports-670fcd21150ece05c2005ad24b797226ae23fb3a.zip
databases/p5-DBD-mysql: fix build on GCC architectures
--libs needs -L/usr/local/lib/gcc9 to find libatomic (needed since MySQL 5.7) on GCC architectures. PR: 239505 Approved by: mat (mentor, maintainer)
Notes
Notes: svn path=/head/; revision=507586
Diffstat (limited to 'databases/p5-DBD-mysql/Makefile')
-rw-r--r--databases/p5-DBD-mysql/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 81d22214d494..c58f5a8851eb 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -22,7 +22,9 @@ TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep
CONFLICTS_INSTALL?= p5-DBD-mysql[45][0-9]-[0-9]*
-USES= mysql perl5
+USES= compiler:c11 mysql perl5
+CONFIGURE_ARGS= ${CONFIGURE_ARGS_${CHOSEN_COMPILER_TYPE}}
+CONFIGURE_ARGS_gcc= --libs="-L${PREFIX}/lib/gcc${GCC_DEFAULT} `mysql_config --libs | ${SED} 's/-pthread //'`"
USE_PERL5= configure
OPTIONS_DEFINE= SSL