aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBICx-MapMaker/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-24 09:31:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-24 09:31:36 +0000
commit44d4770b72d92ddfc76fa06b06c7f2a6dd792031 (patch)
tree12da6197233f1d8a9dbeb87375dff0a73338694f /databases/p5-DBICx-MapMaker/Makefile
parent10b9ccfd51f3086ac7f41b025bf22270f7f1afd2 (diff)
downloadports-44d4770b72d92ddfc76fa06b06c7f2a6dd792031.tar.gz
ports-44d4770b72d92ddfc76fa06b06c7f2a6dd792031.zip
The Perl 5 module DBICx::MapMaker automatically creates a DBIx::Class
result source for "many to many" relationship. WWW: http://search.cpan.org/dist/DBICx-MapMaker
Notes
Notes: svn path=/head/; revision=221964
Diffstat (limited to 'databases/p5-DBICx-MapMaker/Makefile')
-rw-r--r--databases/p5-DBICx-MapMaker/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/p5-DBICx-MapMaker/Makefile b/databases/p5-DBICx-MapMaker/Makefile
new file mode 100644
index 000000000000..ce641f9104b0
--- /dev/null
+++ b/databases/p5-DBICx-MapMaker/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: DBICx-MapMaker
+# Date created: 23 Oct 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBICx-MapMaker
+PORTVERSION= 0.01
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/J/JR/JROCKWAY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Perl 5 module to automatically create a DBIx::Class mapping table
+
+RUN_DEPENDS= p5-Moose>=0.39:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= p5-DBIx-Class>=0.07003:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-DBICx-TestDatabase>=0.02:${PORTSDIR}/databases/p5-DBICx-TestDatabase
+
+PERL_CONFIGURE= yes
+
+MAN3= DBICx::MapMaker.3
+
+.include <bsd.port.mk>