aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-25 10:43:25 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-25 10:43:25 +0000
commit471eca0026c968daed682855798b1554beca6661 (patch)
treefedf5fcd1ccfb6741d7cbcb79aa24229452fe44a /databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
parent1ddb7e8c83f302a164742e34a95ac5280e17be8c (diff)
downloadports-471eca0026c968daed682855798b1554beca6661.tar.gz
ports-471eca0026c968daed682855798b1554beca6661.zip
New port, databases/p5-DBIx-Class-ResultSet-RecursiveUpdate
It is a base class for ResultSets providing just one method: recur- sive_update which works just like update_or_create but can recursively update or create data objects composed of multiple rows. All rows need to be identified by primary keys - so you need to provide them in the update structure (unless they can be deduced from the parent row - for example when you have a belongs_to relationship). If not all colums comprising the primary key are specified - then a new row will be cre- ated, with the expectation that the missing columns will be filled by it (as in the case of auto_increment primary keys).
Notes
Notes: svn path=/head/; revision=230947
Diffstat (limited to 'databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile')
-rw-r--r--databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
new file mode 100644
index 000000000000..d86af29aafd8
--- /dev/null
+++ b/databases/p5-DBIx-Class-ResultSet-RecursiveUpdate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: DBIx::Class::ResultSet::RecursiveUpdate
+# Date created: 25 Mar 2009
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-ResultSet-RecursiveUpdate
+PORTVERSION= v0.002
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Like update_or_create - but recursive
+
+RUN_DEPENDS= \
+ p5-DBIx-Class>=0.08011:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-DBIx-Class-IntrospectableM2M>=0:${PORTSDIR}/databases/p5-DBIx-Class-IntrospectableM2M \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-SQL-Translator>=0.08:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::ResultSet::RecursiveUpdate.3
+
+.include <bsd.port.mk>