aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Custom
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-28 01:15:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-28 01:15:25 +0000
commita78dfd7c324dbbcf3238bc3e1298e5c8ed84f3e9 (patch)
treebb89a8c9992b8ba4e2f5aa5fba32d4a0e77814f8 /databases/p5-DBIx-Custom
parentea2824c221c25602a4675a85e884427f2881de4c (diff)
downloadports-a78dfd7c324dbbcf3238bc3e1298e5c8ed84f3e9.tar.gz
ports-a78dfd7c324dbbcf3238bc3e1298e5c8ed84f3e9.zip
Customizable DBI
WWW: http://search.cpan.org/dist/DBIx-Custom PR: ports/141138 Submitted by: Andrey Kostenko <andrey at kostenko.name>
Notes
Notes: svn path=/head/; revision=248737
Diffstat (limited to 'databases/p5-DBIx-Custom')
-rw-r--r--databases/p5-DBIx-Custom/Makefile32
-rw-r--r--databases/p5-DBIx-Custom/distinfo3
-rw-r--r--databases/p5-DBIx-Custom/pkg-descr3
-rw-r--r--databases/p5-DBIx-Custom/pkg-plist14
4 files changed, 52 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Custom/Makefile b/databases/p5-DBIx-Custom/Makefile
new file mode 100644
index 000000000000..0eff4e5aeba9
--- /dev/null
+++ b/databases/p5-DBIx-Custom/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: DBIx-Custom
+# Date created: 27 December 2009
+# Whom: Andrey Kostenko <andrey@kostenko.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Custom
+PORTVERSION= 0.0801
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Customizable DBI
+
+BUILD_DEPENDS= p5-DBD-SQLite>=1.25:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-DBI>=1.60.5:${PORTSDIR}/databases/p5-DBI \
+ p5-Object-Simple>=2.0702:${PORTSDIR}/devel/p5-Object-Simple \
+ p5-Time-Piece>=1.15:${PORTSDIR}/devel/p5-Time-Piece
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+MAN3= DBIx::Custom.3 \
+ DBIx::Custom::Basic.3 \
+ DBIx::Custom::MySQL.3 \
+ DBIx::Custom::Query.3 \
+ DBIx::Custom::Result.3 \
+ DBIx::Custom::SQL::Template.3 \
+ DBIx::Custom::SQLite.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Custom/distinfo b/databases/p5-DBIx-Custom/distinfo
new file mode 100644
index 000000000000..777e61c4c6fd
--- /dev/null
+++ b/databases/p5-DBIx-Custom/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Custom-0.0801.tar.gz) = 9f7a50c2efdb23532a363ad5ef4d7607
+SHA256 (DBIx-Custom-0.0801.tar.gz) = 8aa0c19840b63e19efe2045e87fea1a33c0677edebc1b61e0dc74f4fd5ab8344
+SIZE (DBIx-Custom-0.0801.tar.gz) = 26499
diff --git a/databases/p5-DBIx-Custom/pkg-descr b/databases/p5-DBIx-Custom/pkg-descr
new file mode 100644
index 000000000000..f715dbf6b89d
--- /dev/null
+++ b/databases/p5-DBIx-Custom/pkg-descr
@@ -0,0 +1,3 @@
+Customizable DBI
+
+WWW: http://search.cpan.org/dist/DBIx-Custom
diff --git a/databases/p5-DBIx-Custom/pkg-plist b/databases/p5-DBIx-Custom/pkg-plist
new file mode 100644
index 000000000000..b9c1b6d86712
--- /dev/null
+++ b/databases/p5-DBIx-Custom/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/DBIx/Custom.pm
+%%SITE_PERL%%/DBIx/Custom/Basic.pm
+%%SITE_PERL%%/DBIx/Custom/MySQL.pm
+%%SITE_PERL%%/DBIx/Custom/Query.pm
+%%SITE_PERL%%/DBIx/Custom/Result.pm
+%%SITE_PERL%%/DBIx/Custom/SQL/Template.pm
+%%SITE_PERL%%/DBIx/Custom/SQLite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Custom/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Custom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/DBIx/Custom/SQL
+@dirrmtry %%SITE_PERL%%/DBIx/Custom
+@dirrmtry %%SITE_PERL%%/DBIx