aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBM-Deep
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-10-12 10:57:42 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-10-12 10:57:42 +0000
commit6ec757c0b6f5f420895f728ddb6df2769eab7f17 (patch)
treedb199726a19fb6875c8f79e432b56cb10d6bcd52 /databases/p5-DBM-Deep
parentece90e951bb8cc9e21c23d9b0628f93005835aca (diff)
downloadports-6ec757c0b6f5f420895f728ddb6df2769eab7f17.tar.gz
ports-6ec757c0b6f5f420895f728ddb6df2769eab7f17.zip
Add p5-DBM-Deep 0.94, a pure perl persistent multi-level hash/array DBM.
PR: ports/70210 Submitted by: Janos.Mohacsi@bsd.hu
Notes
Notes: svn path=/head/; revision=118933
Diffstat (limited to 'databases/p5-DBM-Deep')
-rw-r--r--databases/p5-DBM-Deep/Makefile29
-rw-r--r--databases/p5-DBM-Deep/distinfo2
-rw-r--r--databases/p5-DBM-Deep/pkg-descr8
-rw-r--r--databases/p5-DBM-Deep/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/databases/p5-DBM-Deep/Makefile b/databases/p5-DBM-Deep/Makefile
new file mode 100644
index 000000000000..ff6680db81af
--- /dev/null
+++ b/databases/p5-DBM-Deep/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-DBM-Deep
+# Date created: 09 August 2004
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBM-Deep
+PORTVERSION= 0.94
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= A pure perl persistent multi-level hash/array DBM
+
+MAN3= DBM::Deep.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBM-Deep/distinfo b/databases/p5-DBM-Deep/distinfo
new file mode 100644
index 000000000000..3f84dcdfee93
--- /dev/null
+++ b/databases/p5-DBM-Deep/distinfo
@@ -0,0 +1,2 @@
+MD5 (DBM-Deep-0.94.tar.gz) = 157130c0e4e25e2baaf2dd2adfde70fd
+SIZE (DBM-Deep-0.94.tar.gz) = 41903
diff --git a/databases/p5-DBM-Deep/pkg-descr b/databases/p5-DBM-Deep/pkg-descr
new file mode 100644
index 000000000000..82d9307aa750
--- /dev/null
+++ b/databases/p5-DBM-Deep/pkg-descr
@@ -0,0 +1,8 @@
+A unique flat-file database module, written in pure perl. True multi-level
+hash/array support (unlike MLDBM, which is faked), hybrid OO / tie() interface,
+cross-platform FTPable files, and quite fast. Can handle millions of keys and
+unlimited hash levels without significant slow-down. Written from the ground-up
+in pure perl -- this is NOT a wrapper around a C-based DBM. Out-of-the-box
+compatibility with Unix, Mac OS X and Windows.
+
+WWW: http://search.cpan.org/dist/DBM-Deep/
diff --git a/databases/p5-DBM-Deep/pkg-plist b/databases/p5-DBM-Deep/pkg-plist
new file mode 100644
index 000000000000..2af22cc049b0
--- /dev/null
+++ b/databases/p5-DBM-Deep/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DBM/Deep.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBM/Deep/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBM/Deep
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBM 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBM 2>/dev/null || true