aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DR-Tarantool
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-05-25 14:41:37 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-05-25 14:41:37 +0000
commit5650ccf23e265979ce28b15368e0d456b19a6c72 (patch)
tree4838f3cd61c86ae597ba86b05e1db4302a521d92 /databases/p5-DR-Tarantool
parent4fac2656fc138dfad5bbb0b6f0232bbecc4a21b9 (diff)
downloadports-5650ccf23e265979ce28b15368e0d456b19a6c72.tar.gz
ports-5650ccf23e265979ce28b15368e0d456b19a6c72.zip
This module provides a synchronous and asynchronous driver for Tarantool.
The driver does not have external dependencies, but includes the official light-weight Tarantool C client (a single C header which implements all protocol formatting) for packing requests and unpacking server responses. WWW: https://github.com/dr-co/dr-tarantool/ PR: ports/178618 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com>
Notes
Notes: svn path=/head/; revision=319057
Diffstat (limited to 'databases/p5-DR-Tarantool')
-rw-r--r--databases/p5-DR-Tarantool/Makefile30
-rw-r--r--databases/p5-DR-Tarantool/distinfo2
-rw-r--r--databases/p5-DR-Tarantool/pkg-descr7
-rw-r--r--databases/p5-DR-Tarantool/pkg-plist17
4 files changed, 56 insertions, 0 deletions
diff --git a/databases/p5-DR-Tarantool/Makefile b/databases/p5-DR-Tarantool/Makefile
new file mode 100644
index 000000000000..8f2303cfca92
--- /dev/null
+++ b/databases/p5-DR-Tarantool/Makefile
@@ -0,0 +1,30 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= DR-Tarantool
+PORTVERSION= 0.37
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:UNERA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Perl driver for Tarantool
+
+LICENSE= ART10
+
+PERL_CONFIGURE= yes
+
+MAN3= \
+ DR::README.3 \
+ DR::Tarantool.3 \
+ DR::Tarantool::AsyncClient.3 \
+ DR::Tarantool::CoroClient.3 \
+ DR::Tarantool::Iterator.3 \
+ DR::Tarantool::LLClient.3 \
+ DR::Tarantool::Spaces.3 \
+ DR::Tarantool::StartTest.3 \
+ DR::Tarantool::SyncClient.3 \
+ DR::Tarantool::Tuple.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DR-Tarantool/distinfo b/databases/p5-DR-Tarantool/distinfo
new file mode 100644
index 000000000000..75dd25c1628a
--- /dev/null
+++ b/databases/p5-DR-Tarantool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DR-Tarantool-0.37.tar.gz) = 63fece40f2cf66d2e1be5778d0b1276223e52907ceec09cf96318264abc238e4
+SIZE (DR-Tarantool-0.37.tar.gz) = 56718
diff --git a/databases/p5-DR-Tarantool/pkg-descr b/databases/p5-DR-Tarantool/pkg-descr
new file mode 100644
index 000000000000..aa6970a488d0
--- /dev/null
+++ b/databases/p5-DR-Tarantool/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a synchronous and asynchronous driver for Tarantool.
+
+The driver does not have external dependencies, but includes the official
+light-weight Tarantool C client (a single C header which implements all
+protocol formatting) for packing requests and unpacking server responses.
+
+WWW: https://github.com/dr-co/dr-tarantool/
diff --git a/databases/p5-DR-Tarantool/pkg-plist b/databases/p5-DR-Tarantool/pkg-plist
new file mode 100644
index 000000000000..30b8da0fabe1
--- /dev/null
+++ b/databases/p5-DR-Tarantool/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/README.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/AsyncClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/CoroClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/Iterator.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/LLClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/Spaces.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/StartTest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/SyncClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool/Tuple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DR/Tarantool/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DR/Tarantool/Tarantool.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DR/Tarantool/Tarantool.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DR/Tarantool
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DR
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DR/Tarantool
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DR