aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-GDBM/Makefile
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>1999-11-09 19:07:57 +0000
committerNick Sayer <nsayer@FreeBSD.org>1999-11-09 19:07:57 +0000
commit310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2 (patch)
tree180f4ccb9eecff134ce6a324f4fda80726b7a7e7 /databases/p5-GDBM/Makefile
parent329cba84375ebe744a1ff9aa2afb2c437d1f65ea (diff)
downloadports-310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2.tar.gz
ports-310ba58c61dfbc2e2ad895b8ced4b8bcd32894e2.zip
Add p5-GDBM port. Sort of a merge of my first cut at it and another
from eivind.
Notes
Notes: svn path=/head/; revision=22992
Diffstat (limited to 'databases/p5-GDBM/Makefile')
-rw-r--r--databases/p5-GDBM/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/databases/p5-GDBM/Makefile b/databases/p5-GDBM/Makefile
new file mode 100644
index 000000000000..daf48fcf17eb
--- /dev/null
+++ b/databases/p5-GDBM/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-GDBM
+# Version required: 1.0
+# Date created: Nov 9 1999
+# Whom: Nick Sayer <nsayer@FreeBSD.ORG>
+#
+# Heavy input from eivind@freebsd.org
+#
+# $FreeBSD$
+#
+
+DISTNAME= perl5.005_03
+PKGNAME= p5-GDBM-1.00
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../src
+
+MAINTAINER= nsayer@FreeBSD.ORG
+
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+
+USE_PERL5= YES
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext/GDBM_File
+
+MAN3= GDBM_File.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.post.mk>