aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-GraphViz-DBI
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-10 00:13:54 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-10 00:13:54 +0000
commita373cc2a6ef56beb1cd747e22e6a2b2d1303cb17 (patch)
tree1ecba8e1c59c34cefe2fd667effee9d82d42c4f5 /databases/p5-GraphViz-DBI
parent30e8eb7f062438d6086addab81d4379b3d2760dc (diff)
downloadports-a373cc2a6ef56beb1cd747e22e6a2b2d1303cb17.tar.gz
ports-a373cc2a6ef56beb1cd747e22e6a2b2d1303cb17.zip
Add p5-GraphViz-DBI, perl module to graph database tables and relations.
Notes
Notes: svn path=/head/; revision=48634
Diffstat (limited to 'databases/p5-GraphViz-DBI')
-rw-r--r--databases/p5-GraphViz-DBI/Makefile31
-rw-r--r--databases/p5-GraphViz-DBI/distinfo1
-rw-r--r--databases/p5-GraphViz-DBI/pkg-comment1
-rw-r--r--databases/p5-GraphViz-DBI/pkg-descr10
-rw-r--r--databases/p5-GraphViz-DBI/pkg-plist4
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/p5-GraphViz-DBI/Makefile b/databases/p5-GraphViz-DBI/Makefile
new file mode 100644
index 000000000000..8b9d923e31cd
--- /dev/null
+++ b/databases/p5-GraphViz-DBI/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: databases/p5-GraphViz-DBI
+# Date created: 10 October 2001
+# Whom: tobez
+#
+# $FreeBSD$
+#
+
+PORTNAME= GraphViz-DBI
+PORTVERSION= 0.01
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GraphViz
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= GraphViz::DBI.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ -e '$$_="" if /require 5/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/DBI.pm
+
+.include <bsd.port.mk>
diff --git a/databases/p5-GraphViz-DBI/distinfo b/databases/p5-GraphViz-DBI/distinfo
new file mode 100644
index 000000000000..c0ae5a6c033e
--- /dev/null
+++ b/databases/p5-GraphViz-DBI/distinfo
@@ -0,0 +1 @@
+MD5 (GraphViz-DBI-0.01.tar.gz) = ba8485c65e048e92502fe8ed8255955a
diff --git a/databases/p5-GraphViz-DBI/pkg-comment b/databases/p5-GraphViz-DBI/pkg-comment
new file mode 100644
index 000000000000..b5bccb276865
--- /dev/null
+++ b/databases/p5-GraphViz-DBI/pkg-comment
@@ -0,0 +1 @@
+GraphViz::DBI - graph database tables and relations
diff --git a/databases/p5-GraphViz-DBI/pkg-descr b/databases/p5-GraphViz-DBI/pkg-descr
new file mode 100644
index 000000000000..f7a5ace0b051
--- /dev/null
+++ b/databases/p5-GraphViz-DBI/pkg-descr
@@ -0,0 +1,10 @@
+This perl module constructs a graph for a database showing tables and
+connecting them if they are related. While or after constructing the
+object, pass an open database handle, then call `graph_tables' to
+determine database metadata and construct a GraphViz graph from the
+table and field information.
+
+WWW: http://search.cpan.org/search?dist=GraphViz-DBI
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/databases/p5-GraphViz-DBI/pkg-plist b/databases/p5-GraphViz-DBI/pkg-plist
new file mode 100644
index 000000000000..eb5a9c2c0f83
--- /dev/null
+++ b/databases/p5-GraphViz-DBI/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GraphViz/DBI/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/GraphViz/DBI.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GraphViz/DBI
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/GraphViz 2>/dev/null || true