aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Mysql
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-06-18 19:39:25 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-06-18 19:39:25 +0000
commit0fa2622346e9f7588ab215f3745705a03db0f16c (patch)
tree3d6b7c68d1b364694d94ab37976b8318227e8b38 /databases/p5-Mysql
parent6a10d5281714c72959930c73ba2d7c94fa63d24b (diff)
downloadports-0fa2622346e9f7588ab215f3745705a03db0f16c.tar.gz
ports-0fa2622346e9f7588ab215f3745705a03db0f16c.zip
Import of a perl5 module for accessing MySQL databases
Notes
Notes: svn path=/head/; revision=6997
Diffstat (limited to 'databases/p5-Mysql')
-rw-r--r--databases/p5-Mysql/Makefile29
-rw-r--r--databases/p5-Mysql/distinfo1
-rw-r--r--databases/p5-Mysql/pkg-comment1
-rw-r--r--databases/p5-Mysql/pkg-descr58
-rw-r--r--databases/p5-Mysql/pkg-plist8
5 files changed, 97 insertions, 0 deletions
diff --git a/databases/p5-Mysql/Makefile b/databases/p5-Mysql/Makefile
new file mode 100644
index 000000000000..8d294ec30d49
--- /dev/null
+++ b/databases/p5-Mysql/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-MySQL
+# Version required: 1.17
+# Date created: June 17th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= Mysqlperl-1.17
+PKGNAME= p5-Mysql-1.17
+CATEGORIES= databases perl5
+MASTER_SITES= http://www.tcx.se/Contrib/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5 \
+ ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql
+RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+
+MAN3= Mysql.3
+MANPREFIX= ${PREFIX}/lib/perl5
+
+CONFIGURE_ENV+= PREFIX=${PREFIX}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Mysql/distinfo b/databases/p5-Mysql/distinfo
new file mode 100644
index 000000000000..71ed1556874a
--- /dev/null
+++ b/databases/p5-Mysql/distinfo
@@ -0,0 +1 @@
+MD5 (Mysqlperl-1.17.tgz) = a92064386ff373a31fb1fe854e81e461
diff --git a/databases/p5-Mysql/pkg-comment b/databases/p5-Mysql/pkg-comment
new file mode 100644
index 000000000000..5487f8277445
--- /dev/null
+++ b/databases/p5-Mysql/pkg-comment
@@ -0,0 +1 @@
+perl5 interface to the MySQL database
diff --git a/databases/p5-Mysql/pkg-descr b/databases/p5-Mysql/pkg-descr
new file mode 100644
index 000000000000..72e2acba0c74
--- /dev/null
+++ b/databases/p5-Mysql/pkg-descr
@@ -0,0 +1,58 @@
+What you achieve with MysqlPerl
+------------------------------
+
+MysqlPerl is an interface between the perl programming language and the
+MySQL programming API that comes with the MySQL relational database
+management system. All functions provided by the MySQL programming API
+are supported.
+
+From perl you activate the interface with the statement
+
+ use Mysql;
+
+After that you can connect to multiple msql database servers and send
+multiple queries to any of them via an simple object oriented
+interface. Two types of objects are available: database handles and
+statement handles. Perl returns a database handle to the Connect
+method like so:
+
+ $dbh = Mysql->connect($hostname,$databasename);
+
+Once you have connected to a database, you get a statement handle
+with:
+
+ $sth = $dbh->query("select foo from bar");
+
+You can open as many queries as you like simultaneously by selecting a
+different scalar to hold the object:
+
+ $another_sth = $dbh->Query("select bar from foo");
+
+
+The statement handle allows you to step through the virtual table
+returned from the database with the FetchRow method:
+
+ @row = $sth->fetchrow;
+or
+ %hash = $sth->fetchhash;
+
+You can access all metadata that MySQL supplies for a given table. To
+find out the number of rows or the number of fields returned by a
+query you simply say:
+
+ $numrows = $sth->numrows;
+ $numfields = $sth->numfields;
+
+To find out the size in bytes for the field with the offset 0 (the
+first field of a query), you say:
+
+ $length = $sth->length->[0];
+
+The list of the names for each column is returned by
+
+ @list => $sth->name;
+
+As for other metadata available, consult the manpage that comes with
+MysqlPerl and study the examples in the file t/msql.t, which is the
+extensive testscript to test your installation, but is heavily
+commented, so you may use it as a tutorial.
diff --git a/databases/p5-Mysql/pkg-plist b/databases/p5-Mysql/pkg-plist
new file mode 100644
index 000000000000..fcdf2c198273
--- /dev/null
+++ b/databases/p5-Mysql/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/man/man3/Mysql.3.gz
+lib/perl5/site_perl/Mysql.pm
+lib/perl5/site_perl/Mysql/Statement.pm
+lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.bs
+lib/perl5/site_perl/i386-freebsd/auto/Mysql/Mysql.so
+lib/perl5/site_perl/i386-freebsd/auto/Mysql/.packlist
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/Mysql
+@dirrm lib/perl5/site_perl/Mysql