aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Oryx
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-02-19 20:07:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-02-19 20:07:41 +0000
commit4fb343255671d16764f4418f8fa7f382e1004679 (patch)
tree61f7aa67a899324d930364b8bcdd9a55822216f9 /databases/p5-Oryx
parent7556ef8f9aa541720cc0a8e38b7ecd0aec7c0f6a (diff)
downloadports-4fb343255671d16764f4418f8fa7f382e1004679.tar.gz
ports-4fb343255671d16764f4418f8fa7f382e1004679.zip
Oryx is an object persistence framework which supports both object-relational
mapping as well as DMB style databases and as such is not coupled with any particular storage back-end. In other words, you should be able to swap out an RDMBS with a DBM style database (and vice versa) without changing your persistent classes at all. WWW: http://search.cpan.org/dist/Oryx/ PR: ports/93533 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
Notes
Notes: svn path=/head/; revision=156406
Diffstat (limited to 'databases/p5-Oryx')
-rw-r--r--databases/p5-Oryx/Makefile41
-rw-r--r--databases/p5-Oryx/distinfo3
-rw-r--r--databases/p5-Oryx/pkg-descr7
-rw-r--r--databases/p5-Oryx/pkg-plist55
4 files changed, 106 insertions, 0 deletions
diff --git a/databases/p5-Oryx/Makefile b/databases/p5-Oryx/Makefile
new file mode 100644
index 000000000000..776abe682ae7
--- /dev/null
+++ b/databases/p5-Oryx/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: databases/p5-Oryx
+# Date created: 18 February 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Oryx
+PORTVERSION= 0.19
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML/RHUNDT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Meta-Model Driven Object Persistance with Multiple Inheritance
+
+BUILD_DEPENDS= ${SITE_PERL}/SQL/Abstract.pm:${PORTSDIR}/databases/p5-SQL-Abstract \
+ ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
+ ${SITE_PERL}/DBM/Deep.pm:${PORTSDIR}/databases/p5-DBM-Deep \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/${PERL_ARCH}/Class/Date.pm:${PORTSDIR}/devel/p5-Class-Date \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Ima/DBI.pm:${PORTSDIR}/databases/p5-Ima-DBI \
+ ${SITE_PERL}/Data/Types.pm:${PORTSDIR}/devel/p5-Data-Types \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Oryx.3 Oryx::Association.3 Oryx::Association::Array.3 Oryx::Attribute.3 \
+ Oryx::Class.3 Oryx::DBI.3 Oryx::DBI::Util.3 Oryx::DBM.3 Oryx::Manual::Guts.3 \
+ Oryx::MetaClass.3 Oryx::Parent.3 Oryx::Schema.3 Oryx::Value.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Oryx/distinfo b/databases/p5-Oryx/distinfo
new file mode 100644
index 000000000000..79a00ba18707
--- /dev/null
+++ b/databases/p5-Oryx/distinfo
@@ -0,0 +1,3 @@
+MD5 (Oryx-0.19.tar.gz) = f80fcd3178c35aef2009187e21248cc3
+SHA256 (Oryx-0.19.tar.gz) = db410b3590d7c32524efbb8459ac402152f873cbf2cbf0c8f7dd2251e8721e84
+SIZE (Oryx-0.19.tar.gz) = 46493
diff --git a/databases/p5-Oryx/pkg-descr b/databases/p5-Oryx/pkg-descr
new file mode 100644
index 000000000000..194759bbdfaf
--- /dev/null
+++ b/databases/p5-Oryx/pkg-descr
@@ -0,0 +1,7 @@
+Oryx is an object persistence framework which supports both object-relational
+mapping as well as DMB style databases and as such is not coupled with any
+particular storage back-end. In other words, you should be able to
+swap out an RDMBS with a DBM style database (and vice versa) without
+changing your persistent classes at all.
+
+WWW: http://search.cpan.org/dist/Oryx/
diff --git a/databases/p5-Oryx/pkg-plist b/databases/p5-Oryx/pkg-plist
new file mode 100644
index 000000000000..4075445499e3
--- /dev/null
+++ b/databases/p5-Oryx/pkg-plist
@@ -0,0 +1,55 @@
+%%SITE_PERL%%/Oryx.pm
+%%SITE_PERL%%/Oryx/Association.pm
+%%SITE_PERL%%/Oryx/Association/Array.pm
+%%SITE_PERL%%/Oryx/Association/Hash.pm
+%%SITE_PERL%%/Oryx/Association/Reference.pm
+%%SITE_PERL%%/Oryx/Attribute.pm
+%%SITE_PERL%%/Oryx/Class.pm
+%%SITE_PERL%%/Oryx/DBI.pm
+%%SITE_PERL%%/Oryx/DBI/Association.pm
+%%SITE_PERL%%/Oryx/DBI/Association/Array.pm
+%%SITE_PERL%%/Oryx/DBI/Association/Hash.pm
+%%SITE_PERL%%/Oryx/DBI/Association/Reference.pm
+%%SITE_PERL%%/Oryx/DBI/Attribute.pm
+%%SITE_PERL%%/Oryx/DBI/Class.pm
+%%SITE_PERL%%/Oryx/DBI/Method.pm
+%%SITE_PERL%%/Oryx/DBI/Parent.pm
+%%SITE_PERL%%/Oryx/DBI/Util.pm
+%%SITE_PERL%%/Oryx/DBI/Util/Pg.pm
+%%SITE_PERL%%/Oryx/DBI/Util/SQLite.pm
+%%SITE_PERL%%/Oryx/DBI/Util/mysql.pm
+%%SITE_PERL%%/Oryx/DBM.pm
+%%SITE_PERL%%/Oryx/DBM/Association.pm
+%%SITE_PERL%%/Oryx/DBM/Association/Array.pm
+%%SITE_PERL%%/Oryx/DBM/Association/Hash.pm
+%%SITE_PERL%%/Oryx/DBM/Association/Reference.pm
+%%SITE_PERL%%/Oryx/DBM/Attribute.pm
+%%SITE_PERL%%/Oryx/DBM/Class.pm
+%%SITE_PERL%%/Oryx/DBM/Method.pm
+%%SITE_PERL%%/Oryx/DBM/Parent.pm
+%%SITE_PERL%%/Oryx/DBM/Util.pm
+%%SITE_PERL%%/Oryx/Manual/Guts.pod
+%%SITE_PERL%%/Oryx/MetaClass.pm
+%%SITE_PERL%%/Oryx/Parent.pm
+%%SITE_PERL%%/Oryx/Schema.pm
+%%SITE_PERL%%/Oryx/Value.pm
+%%SITE_PERL%%/Oryx/Value/Binary.pm
+%%SITE_PERL%%/Oryx/Value/Boolean.pm
+%%SITE_PERL%%/Oryx/Value/Complex.pm
+%%SITE_PERL%%/Oryx/Value/DateTime.pm
+%%SITE_PERL%%/Oryx/Value/Float.pm
+%%SITE_PERL%%/Oryx/Value/Integer.pm
+%%SITE_PERL%%/Oryx/Value/Oid.pm
+%%SITE_PERL%%/Oryx/Value/String.pm
+%%SITE_PERL%%/Oryx/Value/Text.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Oryx/.packlist
+@dirrm %%SITE_PERL%%/Oryx/DBI/Association
+@dirrm %%SITE_PERL%%/Oryx/DBM/Association
+@dirrm %%SITE_PERL%%/Oryx/Association
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Oryx
+@dirrm %%SITE_PERL%%/Oryx/DBI/Util
+@dirrm %%SITE_PERL%%/Oryx/Manual
+@dirrm %%SITE_PERL%%/Oryx/Value
+@dirrm %%SITE_PERL%%/Oryx/DBI
+@dirrm %%SITE_PERL%%/Oryx/DBM
+@dirrm %%SITE_PERL%%/Oryx