aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-DoctrineDBAL/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /databases/pear-DoctrineDBAL/Makefile
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'databases/pear-DoctrineDBAL/Makefile')
-rw-r--r--databases/pear-DoctrineDBAL/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/databases/pear-DoctrineDBAL/Makefile b/databases/pear-DoctrineDBAL/Makefile
index eb25d2fb5c26..cad8d44db855 100644
--- a/databases/pear-DoctrineDBAL/Makefile
+++ b/databases/pear-DoctrineDBAL/Makefile
@@ -11,10 +11,8 @@ COMMENT= Database abstraction layer used to power the ORM package
LICENSE= LGPL21
-BUILD_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:devel/pear-channel-doctrine
-RUN_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:devel/pear-channel-doctrine \
- ${PEARDIR}/Doctrine/Common/Version.php:databases/pear-DoctrineCommon \
- ${PEARDIR}/Symfony/Component/Console/Application.php:devel/pear-Symfony_Component_Console
+RUN_DEPENDS= ${PEARDIR}/Doctrine/Common/Version.php:databases/pear-DoctrineCommon@${PHP_FLAVOR} \
+ ${PEARDIR}/Symfony/Component/Console/Application.php:devel/pear-Symfony_Component_Console@${PHP_FLAVOR}
OPTIONS_DEFINE= DBLIB MYSQL ODBC PGSQL SQLITE
OPTIONS_DEFAULT=MYSQL