aboutsummaryrefslogtreecommitdiff
path: root/databases/pecl-memcached
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-31 14:35:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-31 14:35:15 +0000
commit8a9f18838f5b04793ab963c7f0e7d998c62904e3 (patch)
tree1d2675ac12ca4055bf7e6d6ad0000d7e584cc0d2 /databases/pecl-memcached
parentbb1a5f19287372436e6d4e434b9cdc570dfa2c5c (diff)
downloadports-8a9f18838f5b04793ab963c7f0e7d998c62904e3.tar.gz
ports-8a9f18838f5b04793ab963c7f0e7d998c62904e3.zip
- Add igbinary support to OPTIONS
- Remove experimental notice (1.0.0 was declared stable) - Bump PORTREVISION PR: 142873 Submitted by: mm@ Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=248970
Diffstat (limited to 'databases/pecl-memcached')
-rw-r--r--databases/pecl-memcached/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/pecl-memcached/Makefile b/databases/pecl-memcached/Makefile
index 1fdddab9b527..4b149a8477a7 100644
--- a/databases/pecl-memcached/Makefile
+++ b/databases/pecl-memcached/Makefile
@@ -7,6 +7,7 @@
PORTNAME= memcached
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -27,7 +28,14 @@ USE_PHPIZE= yes
USE_PHP_BUILD= yes
CONFIGURE_ARGS+=--with-libmemcached-dir=${LOCALBASE}
-post-install:
- @${CAT} ${WRKSRC}/EXPERIMENTAL
+OPTIONS= IGBINARY "Binary serializer support" off
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IGBINARY)
+CONFIGURE_ARGS+=--enable-memcached-igbinary
+BUILD_DEPENDS+= ${LOCALBASE}lib/php/${PHP_EXT_DIR}/igbinary.so:${PORTSDIR}/converters/igbinary
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/igbinary.so:${PORTSDIR}/converters/igbinary
+.endif
+
+.include <bsd.port.post.mk>