aboutsummaryrefslogtreecommitdiff
path: root/databases/percona57-client
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-04-01 15:11:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-04-01 15:11:14 +0000
commitb85734e5a8a8069eb9cdd9e433d87a48ad56cd2e (patch)
treecf36ee99baf262132ed098112ce81365db1c7f5b /databases/percona57-client
parentd39ad836d1ab4367b3bc4d8e47ea54824d74bc1b (diff)
downloadports-b85734e5a8a8069eb9cdd9e433d87a48ad56cd2e.tar.gz
ports-b85734e5a8a8069eb9cdd9e433d87a48ad56cd2e.zip
Update libedit to 20170329
Notes
Notes: svn path=/head/; revision=437438
Diffstat (limited to 'databases/percona57-client')
-rw-r--r--databases/percona57-client/Makefile2
-rw-r--r--databases/percona57-client/files/patch-client__mysql.cc25
2 files changed, 25 insertions, 2 deletions
diff --git a/databases/percona57-client/Makefile b/databases/percona57-client/Makefile
index 96eb22a7c580..65b97d41c50b 100644
--- a/databases/percona57-client/Makefile
+++ b/databases/percona57-client/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= percona
-PORTREVISION?= 2
+PORTREVISION?= 3
PKGNAMESUFFIX= 57-client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/percona57-client/files/patch-client__mysql.cc b/databases/percona57-client/files/patch-client__mysql.cc
index 26b9650400bf..d15700aa095f 100644
--- a/databases/percona57-client/files/patch-client__mysql.cc
+++ b/databases/percona57-client/files/patch-client__mysql.cc
@@ -1,4 +1,4 @@
---- client/mysql.cc.orig 2016-11-27 19:44:54 UTC
+--- client/mysql.cc.orig 2017-04-01 14:33:18 UTC
+++ client/mysql.cc
@@ -1903,11 +1903,11 @@ static void usage(int version)
#endif
@@ -14,3 +14,26 @@
MYSQL_SERVER_VERSION, SYSTEM_TYPE, MACHINE_TYPE);
#endif
+@@ -2865,9 +2865,11 @@ static void initialize_readline (char *name)
+ rl_add_defun("magic-space", (rl_command_func_t *)&fake_magic_space, -1);
+ #elif defined(USE_LIBEDIT_INTERFACE)
+ setlocale(LC_ALL,""); /* so as libedit use isprint */
+- rl_attempted_completion_function= (CPPFunction*)&new_mysql_completion;
+- rl_completion_entry_function= &no_completion;
++ rl_attempted_completion_function= (rl_completion_func_t*)&new_mysql_completion;
++ rl_completion_entry_function= (rl_compentry_func_t*)&no_completion;
++ /*
+ rl_add_defun("magic-space", (Function*)&fake_magic_space, -1);
++ */
+ #else
+ rl_attempted_completion_function= (CPPFunction*)&new_mysql_completion;
+ rl_completion_entry_function= &no_completion;
+@@ -2886,7 +2888,7 @@ static char **new_mysql_completion(const char *text,
+ int end MY_ATTRIBUTE((unused)))
+ {
+ if (!status.batch && !quick)
+-#if defined(USE_NEW_READLINE_INTERFACE)
++#if defined(USE_NEW_READLINE_INTERFACE) || defined(USE_LIBEDIT_INTERFACE)
+ return rl_completion_matches(text, new_command_generator);
+ #else
+ return completion_matches((char *)text, (CPFunction *)new_command_generator);